Bạn hiện đang ngoại tuyến, hãy chờ internet để kết nối lại

T.báo lỗi: “Dịch vụ cần thiết "Tự động Cập nhật" (WUAUSERV) không được khởi động hoặc Dịch vụ Chuyển Thông minh Nền (BITS) bị vô hiệu hoá. Lỗi 0x8DDD0...

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Nguồn: Hỗ trợ của Microsoft
NHANH CHÓNG XÂY DỰNG
NHANH CHÓNG XÂY DỰNG CÁC BÀI VIẾT CUNG CẤP THÔNG TIN TRỰC TIẾP TỪ TRUNG TÂM HỖ TRỢ CỦA MICROSOFT. THÔNG TIN CÓ TRONG TÀI LIỆU NÀY ĐƯỢC TẠO RA NHẰM TRẢ LỜI CÁC CHỦ ĐỀ MỚI XUẤT HIỆN HOẶC DUY NHẤT HOẶC NHẰM MỤC ĐÍCH BỔ SUNG CHO THÔNG TIN CƠ SỞ KIẾN THỨC KHÁC.
Hiện tượng
Khi bạn cố gắng quét tìm hoặc tải xuống các bản cập nhật từ Web site Microsoft Windows Update hoặc từ Web site Microsoft Update, bạn có thể nhận được thông báo lỗi tương tự như một trong các thông báo sau:

Windows Update đã gặp lỗi và không thể hiển thị trang yêu cầu. Dịch vụ cần thiết "Tự động Cập nhật" (WUAUSERV) không được khởi động hoặc Dịch vụ Chuyển Thông minh Nền (BITS) bị vô hiệu hoá.
Lỗi 0x8DDD0018

-hoặc-

Máy chủ không thể tìm thấy URI yêu cầu (Mã định danh Tài nguyên Thống nhất)
Lỗi 0x80244019


-hoặc-


Không thể khởi động dịch vụ vì dịch vụ bị vô hiệu hoá hoặc dịch vụ không có các thiết bị được kích hoạt liên kết với nó.
Lỗi 0x80070422

Ngoài ra, Dịch vụ Cập nhật Tự động có thể bị vô hiệu hoá hoặc không chạy trên hệ thống của bạn. Bạn cũng không thể Bật và khởi động Dịch vụ Cập nhật Tự động.

Nguyên nhân
Sự cố này có thể xảy ra nếu Cập nhật Tự động bị vô hiệu hoá trên hệ thống của bạn hoặc nếu Dịch vụ Chuyển Thông minh Nền (BITS) hiện không đang chạy.

Chú ý: Một số phần mềm chống Vi-rút và Phần mềm độc hại có thể vô hiệu hoá Dịch vụ Cập nhật Tự động và gây ra sự cố này. Xem phần Thông tin thêm ở cuối bài viết này để biết các biến thể đã xác định gây ra sự cố.



Để biết thêm thông tin chi tiết về những mã lỗi này, hãy xem phần Thông tin thêm sau trong bài viết này.
Giải pháp
Để khắc phục sự cố này, sử dụng các phương pháp sau, bắt đầu từ phương pháp 1.

Phương pháp 1: Tải xuống và chạy Công cụ Loại bỏ Phần mềm Nguy hiểm (MSRT), sau đó kiểm tra để đảm bảo các dịch vụ cần thiết đang chạy

Tải xuống và chạy MSRT mới nhất cho hệ thống của bạn, công cụ sẵn có cho các hệ thống 32 bit và 64 bit. Công cụ này kiểm tra các máy tính Windows Vista, Windows XP, Windows 2000 và Windows Server 2003 và giúp loại bỏ các mối lây nhiễm từ phần mềm độc hại cụ thể, phổ biến—bao gồm cả Blaster, Sasser và Mydoom. Sau khi chạy công cụ MSRT, bạn cần đi đến phương pháp 3 để đảm bảo rằng các dịch vụ cần thiết đang chạy trên hệ thống trước khi bạn cố cài đặt lại các bản cập nhật.

Để tải xuống phiên bản 32 bit của Công cụ Loại bỏ Phần mềm Nguy hiểm, bấm vào đây.

Để tải xuống phiên bản 64 bit của Công cụ Loại bỏ Phần mềm Nguy hiểm, bấm vào đây

Để biết thêm thông tin về Công cụ Loại bỏ Phần mềm Nguy hiểm, bấm vào liên kết bên dưới để xem bài viết trên web site của Microsoft.


KB890830 Công cụ Loại bỏ Phần mềm Nguy hiểm của Microsoft Windows giúp loại bỏ phần mềm nguy hiểm cụ thể, phổ biến khỏi máy tính đang chạy Windows Vista, Windows Server 2003, Windows Server 2008, Windows XP hoặc Windows 2000


Quan trọng Sau khi chạy công cụ MSRT, bạn cần đi đến phương pháp 3 để đảm bảo rằng các dịch vụ cần thiết đang chạy trên hệ thống trước khi bạn cố cài đặt lại các bản cập nhật.

Phương pháp 2: Khởi động lại máy tính ở Chế độ An toàn, sau đó quét hệ thống để tìm các mối lây nhiễm Vi-rút hoặc Phần mềm độc hại có thể xảy ra

Khởi động máy tính ở Chế độ An toàn, sau đó chạy phần mềm chống vi-rút trên máy tính để quét tìm và loại bỏ bất kỳ mối lây nhiễm Vi-rút và Phần mềm độc hại nào có thể xảy ra. Sau khi quét hệ thống để tìm các mối lây nhiễm Vi-rút và Phần mềm độc hại, bạn cần đi đến phương pháp 3 để đảm bảo rằng các dịch vụ cần thiết đang chạy trên hệ thống trước khi bạn cố cài đặt lại các bản cập nhật.

Để quét máy tính tìm vi-rút, bạn phải cài đặt chương trình chống vi-rút trên máy tính. Nếu bạn chưa cài đặt chương trình chống vi-rút, bạn có thể sử dụng trình quét an toàn Windows Live miễn phí để quét máy tính. Để chạy trình quét an toàn Windows Live, bấm vào liên kết bên dưới để truy cập website của Microsoft.


Chú ý: Để biết thêm thông tin về cách chạy Trình quét An toàn miễn phí ở Chế độ An toàn, bấm vào liên kết bên dưới để truy cập web site của Microsoft.

968091 (Trang này có thể có bằng tiếng Anh)Cách cài đặt Trình quét An toàn miễn phí của Microsoft và quét máy tính ở Chế độ An toàn

Chú ý: Quá trình quét máy tính có thể mất nhiều thời gian và đôi khi máy tính có thể đóng băng hoặc không hoạt động. Vui lòng cho phép quá trình quét hoàn tất thành công.

Bạn cũng có thể tải xuống bản sao từ website sau của Microsoft:


Cách quét máy tính và loại bỏ vi-rút khác nhau đối với từng chương trình chống vi-rút. Bạn nên xem trong hệ thống Trợ giúp của chương trình chống vi-rút để biết các bước về cách loại bỏ vi-rút. Thông thường, bạn có thể tìm thấy các bước cho chương trình chống vi-rút trên Internet. Để tìm các bước, gõ "quét vi-rút" và sau đó là tên của chương trình chống vi-rút vào công cụ tìm kiếm yêu thích của bạn rồi bấm Tìm kiếm.

Quan trọng Sau khi chạy công cụ MSRT, bạn cần đi đến phương pháp 3 để đảm bảo rằng các dịch vụ cần thiết đang chạy trên hệ thống trước khi bạn cố cài đặt lại các bản cập nhật.

Phương pháp 3: Xác minh rằng các dịch vụ cần thiết được cấu hình đúng và đang chạy

Xác minh rằng các dịch vụ cần thiết để tải xuống và cài đặt cập nhật được cấu hình đúng và đang chạy trên máy tính, sau đó thử tải xuống và cài đặt cập nhật một lần nữa.


Để được chúng tôi đảm bảo rằng các dịch vụ cần thiết được cấu hình đúng và đang chạy giúp bạn, hãy đi tới phần "Khắc phục sự cố giúp tôi". Nếu bạn muốn tự mình khắc phục sự cố này, hãy đi tới phần "Để tôi tự khắc phục sự cố".

Khắc phục sự cố giúp tôi



Để khắc phục sự cố này tự động, hãy bấm vào nút hoặc liên kết Khắc phục sự cố. Sau đó, bấm vào Chạy trong hộp thoại Tải tệp xuống và làm theo các bước trong thuật sĩ Fix it.




Chú ý
  • Thuật sỹ này có thể chỉ có bằng tiếng Anh. Tuy nhiên, bản vá tự động cũng sẽ hoạt động đối với các phiên bản ngôn ngữ khác của Windows.
  • Nếu bạn hiện không làm việc trên máy tính xảy ra sự cố, hãy lưu giải pháp Khắc phục sự cố vào ổ đĩa flash hoặc CD rồi chạy trên máy tính có sự cố.

Sau đó, đi tới phần "Phương pháp này có khắc phục được sự cố không?".



Để tôi tự khắc phục sự cố


Đối với Microsoft Windows 2000, Windows XP hoặc Windows Server 2003, hãy làm theo các bước sau:

Để đảm bảo rằng các dịch vụ cần thiết được cấu hình đúng và đang chạy, hãy làm theo các bước sau:

1. Bấm Bắt đầu, bấm Chạy, nhập services.msc, sau đó bấm OK.

2. Bấm đúp vào Dịch vụ Chuyển Thông minh Nền.

3. Trong hộp Kiểu khởi động , bấm Thủ công, sau đó bấm Áp dụng.

4. Trên tab Đăng nhập, xác minh rằng dịch vụ được kích hoạt trong mỗi cấu hình phần cứng đã liệt kê

5. Trên tab Chung, bấm Bắt đầu.

6. Bấm đúp vào dịch vụ Nhật ký Sự kiện

7. Đảm bảo rằng Kiểu khởi động được đặt thành Tự động

8. Nếu Trạng thái khởi động liệt kê Đã dừng, bấm vào Khởi động , sau đó bấm OK.

9. Bấm đúp vào dịch vụ Cập nhật Tự động.

10. Đảm bảo rằng Kiểu khởi động được đặt thành Tự động.

12. Nếu Trạng thái khởi động liệt kê Đã dừng, bấm vào Khởi động , sau đó bấm OK.

13 Đóng cửa sổ Dịch vụ và thử cài đặt lại các bản cập nhật Windows.


Đối với Windows Vista và Windows Server 2008, làm theo các bước liệt kê bên dưới:

Để đảm bảo rằng các dịch vụ cần thiết sẵn có và đang chạy, hãy làm theo các bước sau:

1. Bấm Bắt đầu, gõ services.msc vào vùng văn bản Bắt đầu Tìm kiếm, sau đó bấm services.msc trong danh sách chương trình. Nếu bạn được nhắc mật khẩu quản trị viên hoặc xác nhận, hãy gõ mật khẩu hoặc bấm vào Tiếp tục.

2. Bấm đúp vào Dịch vụ Chuyển Thông minh Nền.

3. Trong hộp Kiểu khởi động , bấm Thủ công, sau đó bấm Áp dụng.

4. Trên tab Đăng nhập, xác minh rằng dịch vụ được kích hoạt trong mỗi cấu hình phần cứng đã liệt kê

5. Trên tab Chung, bấm Bắt đầu.

6. Bấm đúp vào dịch vụ Nhật ký Sự kiện Windows

7. Đảm bảo rằng Kiểu khởi động được đặt thành Tự động

8. Nếu Trạng thái khởi động liệt kê Đã dừng, bấm vào Khởi động , sau đó bấm OK.

9. Bấm đúp vào dịch vụ Windows Update.

10. Đảm bảo rằng Kiểu khởi động được đặt thành Tự động.

12. Nếu Trạng thái khởi động liệt kê Đã dừng, bấm vào Khởi động , sau đó bấm OK.

13. Bấm đúp vào Dịch vụ Cấp phép Phần mềm.

14. Đảm bảo rằng Kiểu khởi động được đặt thành Tự động.

15. Nếu Trạng thái khởi động liệt kê Đã dừng, bấm vào Khởi động , sau đó bấm OK.

16. Đóng cửa sổ Dịch vụ và thử cài đặt lại các bản cập nhật Windows.

Chú ý: Nếu sau khi làm theo các bước trong Phương pháp 1 và Phương pháp 3 và thấy rằng bạn vẫn không thể tải xuống và cập nhật các bản cài đặt, bạn cần phải quay lại và làm theo các bước trong Phương pháp 2 để khắc phục sự cố. Những bước này sử dụng phần mềm quét Vi-rút và Phần mềm độc hại hiện đã được cài đặt hoặc Trình quét An toàn Microsoft Security Essentials trong khi chạy máy tính ở Chế độ An toàn để khắc phục sự cố.


Phương pháp này có khắc phục được sự cố không?

  • Kiểm tra xem sự cố đã được khắc phục hay chưa. Nếu sự cố đã được khắc phục, bạn đã hoàn thành phần này. Nếu sự cố vẫn chưa được khắc phục, bạn có thể liên hệ với bộ phận hỗ trợ.
  • Chúng tôi đánh giá cao phản hồi của bạn. Để cung cấp phản hồi hoặc báo cáo bất kỳ sự cố nào về giải pháp này, vui lòng để lại nhận xét trên blog "Khắc phục sự cố cho tôi" hoặc gửi thư email cho chúng tôi.

TÀI NGUYÊN BỔ SUNG

Cách nhận hỗ trợ có liên quan đến bảo mật và vi-rút máy tính



Dành cho Hoa Kỳ và Canada

Nhóm an toàn máy tính sẵn sàng hỗ trợ các vấn đề liên quan đến vi-rút máy tính và vấn đề bảo mật khác trong suốt 24 giờ một ngày ở Hoa Kỳ và Canada.


Để có được hỗ trợ về vi-rút máy tính và hỗ trợ liên quan đến bảo mật, làm theo những bước sau:

Bạn phải đảm bảo rằng bạn đã chạy phần mềm chống vi-rút và phần mềm loại bỏ phần mềm gián điệp đã được cập nhật trên máy tính bị nhiễm vi-rút trước khi liên hệ với kỹ sư trợ giúp.



Để biết thêm thông tin về cách lấy bản quét an toàn máy tính miễn phí, hãy truy cập trang Web sau của Microsoft:


Để biết thêm thông tin về phần mềm chống gián điệp, ghé thăm Web site sau của Microsoft:





Hãy gọi 1-866-PCSAFETY hoặc gọi 1-866-727-2338 để liên hệ hỗ trợ bảo mật.



Dành cho các địa điểm bên ngoài Bắc Mỹ



Để nhận hỗ trợ về vi-rút máy tính và các vấn đề liên quan đến bảo mật dành cho các địa điểm bên ngoài Bắc Mỹ, hãy truy cập Web site sau của Microsoft:

http://support.microsoft.com/common/international.aspx?rdpath=4
Các bước Nâng cao
Thông tin thêm

Hiện tượng mà khách hàng thấy khi bị ảnh hưởng bởi hoạt động Trojan này thay đổi tuỳ theo hệ điều hành và Trojan có liên quan. Tình huống Chung cho các sự cố này dựa trên Phiên bản Windows và như sau:

Windows XP, Windows Server 2003


Có thể gặp phải lỗi 0x8DDD0018 trong khi quét hoặc tải xuống Bản cập nhật.



Mã Lỗi: 0x8DDD0018

Chuỗi Lỗi: ErrorAUDisabled

Mô tả Lỗi Trang web:



Mô tả lỗi cho lỗi này: “Chương trình phát ra lệnh nhưng độ dài lệnh không đúng”. Đây là lỗi trả về từ Máy chủ Windows Update cho biết rằng Máy khách Windows Update không được cấu hình để nhận các bản cập nhật tự động.



Tình huống 1: Cập nhật Tự động có thể không bật.



Có một số trường hợp mà hiện tượng này biểu thị:

1. Người dùng có thể nhận thấy rằng Cập nhật Tự động không được kích hoạt.

2. Trung tâm Bảo mật Windows có thể cảnh báo người dùng rằng Cập nhật Tự động không được kích hoạt.

3. Phần mềm Bảo mật như Microsoft Security Essentials có thể thông báo cho người dùng rằng Cập nhật Tự động không được kích hoạt.

4. Khi Cập nhật Tự động bị vô hiệu hoá, ba trong số các dịch vụ cần thiết bị vô hiệu hoá, (Dịch vụ Chuyển Thông minh Nền (BITS), dịch vụ Nhật ký Sự kiện và dịch vụ Cập nhật Tự động). Khi người dùng cố kích hoạt ba dịch vụ này bằng cách đặt dịch vụ thành tự động; dịch vụ BITS và dịch vụ Nhật ký Sự kiện có thể được đặt lại, tuy nhiên dịch vụ Cập nhật Tự động cho biết lỗi Sự kiện 1058 (ERROR_SERVICE_DISABLED - Dịch vụ không thể khởi động vì dịch vụ bị vô hiệu hoá hoặc dịch vụ không có các thiết bị được kích hoạt liên kết với nó).



CHÚ Ý: Người dùng thường sẽ bật Cập nhật Tự động; tuy nhiên, người dùng có thể không biết rằng Cập nhật Tự động có thể đã được bật bởi ứng dụng mà AU EULA kích hoạt để thực hiện việc này nhằm đảm bảo rằng hệ thống vẫn duy trì cập nhật các bản vá Bảo mật mới nhất.



Tình huống 2: Cập nhật Tự động có thể tiếp tục tắt



Người dùng có thể kích hoạt lại Cập nhật Tự động nhưng sau khi hệ thống được khởi động lại, thiết đặt Cập nhật Tự động lại bị vô hiệu hoá. Hiện tượng này xảy ra khi Trojan vô hiệu hoá thiết đặt Cập nhật Tự động vẫn còn trên máy và trở nên hoạt động khi khởi động lại.



Windows Vista & Windows Server 2008



Tình huống 1: Lỗi 0x80244019 nhận được trong khi cố Tải xuống Cập nhật



Mã lỗi: 0x80244019

Chuỗi Lỗi: SUS_E_PT_HTTP_STATUS_NOT_FOUND

Mô tả Trạng thái Http 407 - xác thực proxy bắt buộc



Khi bạn cố gắng tải xuống bản cập nhật, bạn nhận được lỗi: “Máy chủ không thể tìm thấy URI yêu cầu (Mã định danh Tài nguyên Thống nhất)”. URI này thường liên kết với thiết đặt tường lửa hoặc proxy không đúng. Trong sự cố này, có vẻ như Trojan có ý gây cản trở giải pháp tên cho Trang web Cập nhật. Một ví dụ (mặc dù không tương quan với Sự cố AU) sẽ là Trojan DNSChanger (Trojan:Win32/Dnschanger).





Tình huống 2: Lỗi khi Tải xuống Bản cập nhật 0x80070422.



Mã Lỗi: 0x80070422

Chuỗi Lỗi: ERROR_SERVICE_DISABLED

Mô tả Dịch vụ chưa được bắt đầu



Khi cố gắng kết nối Windows Update, người dùng có thể nhận được lỗi 0x80070422 (ERROR_SERVICE_DISABLED - Dịch vụ chưa được bắt đầu). Lỗi này cho biết rằng Dịch vụ Chuyển Thông minh Nền (BITS), dịch vụ Nhật ký Sự kiện và Dịch vụ Cập nhật Tự động cần được đặt thành Tự động. Dịch vụ BITS và Dịch vụ Nhật ký Sự kiện có thể được đặt lại; tuy nhiên, Dịch vụ Cập nhật Tự động gặp lỗi 1058 (ERROR_SERVICE_DISABLED - Dịch vụ không thể bắt đầu vì dịch vụ bị vô hiệu hoá hoặc dịch vụ không có các thiết bị được kích hoạt liên kết với nó).



Một số người dùng cũng có thể gặp phải sự cố Dịch vụ Cấp phép Phần mềm không bắt đầu bất kể quyền của người dùng cao đến mức nào.



Nhật ký Sự kiện có thể hiển thị lỗi sau:



Lỗi Ứng dụng

Dịch vụ Cấp phép Phần mềm không bắt đầu được. hr=0xD0000022, [2, 4] Trình lập lịch Kích hoạt Giấy phép (SLUINotify.dll) thất bại với mã lỗi sau:0xC0000022





Cập nhật Tự động có thể đã bị vô hiệu hoá bởi Vi-rút hoặc Phần mềm độc hại



Một số phần mềm chống Vi-rút và Phần mềm độc hại có thể vô hiệu hoá Dịch vụ Cập nhật Tự động và gây ra sự cố này.

Mầm bệnh đã biết sẽ gây ra hoạt động này:

· TrojanDownloader:Win32/Zlob Family

· Trojan:Win32/vundo.gen!T

· Trojan:Win32/Vundo.gen!R

· Trojan:Win32/Vundo.gen!E

· Sâu: Win32/Conflicker.B



· Sâu: Win32/Conflicker.C



Chú ý: để biết thêm thông tin về Vi-rút hoặc Phần mềm độc hại, bấm vào mục để xem thông tin trong web site của Microsoft.

Để xem thông tin về các mối đe doạ vi-rút và phần mềm độc hại hàng đầu, bấm vào liên kết bên dưới để truy cập trang web trên web site của Microsoft.

Phát hiện Mối đe doạ Hàng đầu


Để tìm kiếm thông tin về các mối lây nhiễm Vi-rút và Phần mềm độc hại khác, bấm vào liên kết bên dưới để truy cập trang web trên web site của Microsoft.

Trung tâm Phòng chống Phần mềm Độc hại của Microsoft
fixit fix it fixme 
MIỄN TRỪ TRÁCH NHIỆM
MICROSOFT VÀ/HOẶC NHÀ CUNG CẤP CỦA MICROSOFT KHÔNG TUYÊN BỐ HOẶC BẢO ĐẢM VỀ TÍNH PHÙ HỢP, ĐỘ TIN CẬY HOẶC TÍNH CHÍNH XÁC VỀ THÔNG TIN CÓ TRONG TÀI LIỆU VÀ CÁC ĐỒ HOẠ LIÊN QUAN ĐƯỢC ĐĂNG TRÊN WEBSITE NÀY (GỌI LÀ “TÀI LIỆU”) VÌ BẤT KỲ MỤC ĐÍCH NÀO. TÀI LIỆU CÓ THỂ THIẾU CHÍNH XÁC VỀ MẶT KỸ THUẬT HOẶC CÓ LỖI IN ẤN VÀ CÓ THỂ ĐƯỢC SỬA ĐỔI BẤT CỨ LÚC NÀO MÀ KHÔNG CẦN THÔNG BÁO.

Ở PHẠM VI CHO PHÉP TỐI ĐA CỦA LUẬT ÁP DỤNG, MICROSOFT VÀ/HOẶC NHÀ CUNG CẤP CỦA MICROSOFT MIỄN TRỪ TRÁCH NHIỆM VÀ LOẠI TRỪ TẤT CẢ CÁC TUYÊN BỐ, BẢO ĐẢM VÀ ĐIỀU KIỆN CHO DÙ LÀ RÕ RÀNG, NGỤ Ý HAY THEO LUẬT ĐỊNH, BAO GỒM NHƯNG KHÔNG GIỚI HẠN Ở CÁC TUYÊN BỐ, BẢO ĐẢM HOẶC ĐIỀU KIỆN VỀ QUYỀN SỞ HỮU, SỰ KHÔNG VI PHẠM, ĐIỀU KIỆN HOẶC CHẤT LƯỢNG THOẢ MÃN, KHẢ NĂNG BÁN SẢN PHẨM VÀ TÍNH PHÙ HỢP CHO MỘT MỤC ĐÍCH CỤ THỂ CÓ NÊU TRONG TÀI LIỆU NÀY.
Thuộc tính

ID Bài viết: 959894 - Xem lại Lần cuối: 02/27/2012 16:37:00 - Bản sửa đổi: 4.0

Microsoft Windows XP Starter Edition, Microsoft Windows XP Home Edition, Microsoft Windows XP Professional, Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Standard x64 Edition, Microsoft Windows Server 2003, Web Edition, Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise x64 Edition, Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)

  • kbrapidpub kbnomt kbfixme kbmsifixme KB959894
Phản hồi