"UnknownIncomingEmailIntegrationError-2147220891 ngoại lệ" lỗi xuất hiện trong hộp thư thông báo trong Dynamics 365

Hiện tượng

Khi xem phần thông báo trong bản ghi thư trong Dynamics 365, bạn thấy một thông báo sau:

  • "Lỗi không xác định xảy ra khi nhận được email đến hộp thư"< tên hộp thư >". Chủ sở hữu cấu hình máy chủ email liên kết < tên hồ sơ > đã được thông báo. Hệ thống sẽ cố gắng nhận email sau. Email Server mã lỗi: Exchange server trả về ngoại lệ UnknownIncomingEmailIntegrationError-2147220891."

  • "Trong Microsoft Dynamics 365 lỗi khi đồng bộ hoá các cuộc hẹn, danh bạ và tác vụ cho hộp thư"< tên hộp thư >". Chủ sở hữu cấu hình máy chủ email liên kết < tên hồ sơ > đã được thông báo. Hệ thống sẽ thử lại sau. Email Server mã lỗi: CRM.80040265.ISV mã bỏ hoạt động."

Nguyên nhân

Mã lỗi 80040265 và-2147220891 chỉ ra lỗi IsvAborted.

Nếu bạn thấy thông báo đầu tiên được liệt kê trong phần hiện tượng, thông thường này là do một luồng công việc hoặc tuỳ chỉnh cắm chạy trên tạo một hồ sơ email.

Nếu bạn thấy thông báo thứ hai được liệt kê trong phần hiện tượng, thông thường này là do một luồng công việc hoặc tuỳ chỉnh cắm chạy trên tạo một cuộc hẹn, liên lạc hoặc tác vụ ghi.

Giải pháp

Kiểm tra xem bạn có bất kỳ tuỳ chỉnh bổ sung hoặc luồng công việc chạy đồng bộ tạo loại dữ liệu được đề cập trong các lỗi (ví dụ: email, cuộc hẹn, liên lạc hoặc tác vụ). Nếu một plugin hoặc luồng công việc gây ra lỗi trong quá trình tạo hồ sơ, đồng bộ hóa phía máy chủ sẽ không thể tạo hồ sơ thành công. Các bước dưới đây có thể giúp bạn xác định nếu có bất kỳ công việc hoặc bổ sung trong tổ chức của bạn chạy trong khi tạo một email. Các bước tương tự có thể được sử dụng cho khác như hẹn nếu đó là loại dữ liệu không được tạo ra:

Luồng công việc

  1. Trong ứng dụng web Dynamics 365, di chuyển cài đặt và sau đó nhấp vào quy trình.

  2. Thay đổi chế độ xem Quá trình kích hoạt.

  3. Sắp xếp cột Chính tổ chức và tìm bất kỳ hàng với Email chính tổ chức và luồng công việc với các loại. Hoặc bạn có thể sử dụng các tuỳ chọn lọc trong lưới lọc loại = luồng công việc và thực thể chính = Email

  4. Mở từng luồng công việc tìm kiếm của bạn đáp ứng các tiêu chí trên (nếu có).

  5. Nếu các tuỳ chọn khởi động khi có tuỳ chọn tạo hồ sơ được chọn và chạy luồng công việc này trong nền (được khuyến nghị) lựa chọn không được chọn, luồng công việc này có thể có thể là nguyên nhân.

  6. Bấm vào mục Trình phiên ở phía bên trái của trang lookg cho bất kỳ lỗi liên quan đến email không được tạo thành công.

Trình cắm

  1. Trong ứng dụng web Dynamics 365, chuyển đến cài đặt, tuỳ chỉnh, và sau đó bấm tùy chỉnh hệ thống.

  2. Bấm vào thông báo Sdk bước xử lý.

  3. Sắp xếp cột Mã loại đối tượng chính (SdkMessage lọc) và tìm mọi hàng cho tổ chức Email.

  4. Nếu bạn tìm thấy bất kỳ wors và chế độ thực hiện xoay, điều này có thể có thể interferring tạo email.

Nếu sự cố tái tạo nhất quán và có thể tạm thời vô hiệu hoá việc hoặc cắm như kiểm tra này có thể cho phép bạn xác định xem công việc hoặc plugin là nguyên nhân.

Bạn cần thêm trợ giúp?

Phát triển các kỹ năng của bạn
Khám phá nội dung đào tạo
Sở hữu tính năng mới đầu tiên
Tham gia Microsoft dùng nội bộ

Thông tin này có hữu ích không?

Cảm ơn phản hồi của bạn!

Cảm ơn bạn đã phản hồi! Để trợ giúp tốt hơn, có lẽ chúng tôi sẽ kết nối bạn với một trong những nhân viên hỗ trợ Office của chúng tôi.

×