Hiện tượng

Khi tìm cách nhập bản vá giải pháp trong Dynamics 365, bạn gặp phải lỗi sau đây:

"Việc nhập giải pháp: [tên bản vá giải pháp] không thành công. Mã lỗi 80048539. "

Nếu bạn tải xuống tệp nhật ký và mở nó trong Excel, bạn sẽ thấy các chi tiết bổ sung như sau:

Triệu chứng 1 thông tin chi tiết:

"Lỗi 0x80048539 Chuyển nhập biểu hiện giải pháp: không: bản vá phiên bản 1.0.1.0 không hợp lệ cho phiên bản mẹ 1.1.0.0 "

Triệu chứng 2 thông tin chi tiết:

"Lỗi 0x80048539 Giải pháp manifest Import: FAILURE: Holding Solution MyPatchTesting_Upgrade đã tồn tại. "

Nguyên nhân

Nếu bạn đang sử dụng make.powerapps.com để nhập bản Cập Nhật giải pháp không được quản lý của bạn và nhận được thông báo lỗi này, Microsoft đã biết về sự cố này và đang làm việc trên bản sửa lỗi. Để khắc phục sự cố khi mở thiết đặt nâng cao, rồi chọn tùy chọn "Cập Nhật (không được đề xuất)".

Mã lỗi 80048539 cho biết một bản vá không hợp lệ đang được nhập vào. Có một vài nguyên nhân tiềm ẩn bao gồm:

Gây ra 1: Nếu bạn thấy thông tin chi tiết lỗi được đề cập trong phần chi tiết về triệu chứng 1 được đề cập ở trên:

Phiên bản Patch giải pháp sẽ thấp hơn phiên bản của giải pháp đã được cài đặt. Ví dụ: một giải pháp được đặt tên là SolutionA đã được cài đặt với phiên bản 1.1.0.0 và bạn đang tìm cách nhập bản vá đó là phiên bản 1.0.1.0.

Nguyên nhân 2:Nếu bạn thấy thông tin chi tiết lỗi được đề cập trong phần chi tiết về triệu chứng 2 được đề cập ở trên:

Điều này có thể xảy ra nếu bạn đã có bản nâng cấp đã nhập cho giải pháp đó nhưng chưa áp dụng được. Sau khi nhập một giải pháp là một bản nâng cấp của một giải pháp hiện có, phần cuối của giải pháp nhập sẽ cung cấp một nút để áp dụng nâng cấp giải pháp. Nếu bạn không bấm vào nút đó trong khi nhập trước khi đã nâng cấp giải pháp cho giải pháp này, bạn cần xác định vị trí giải pháp trong danh sách giải pháp của bạn và bấm vào nút áp dụng nâng cấp giải pháp

Giải pháp

Độ phân giải 1: Nếu bạn thấy thông tin chi tiết lỗi được đề cập trong phần chi tiết về triệu chứng 1 được đề cập ở trên:

Kiểm tra phiên bản vá giải pháp mà bạn đang tìm cách nhập là phiên bản cao hơn so với giải pháp đã được cài đặt.

Độ phân giải 2: Nếu bạn thấy thông tin chi tiết lỗi được đề cập trong phần chi tiết về triệu chứng 2 được đề cập ở trên:

Dẫn hướng đến thiết đặt, tùy chỉnh, rồi bấm giải pháp. Chọn giải pháp đã cài đặt hiện có mà bạn đang tìm cách nâng cấp, rồi bấm vào áp dụng nâng cấp giải pháp

Bạn cần thêm trợ giúp?

Phát triển các kỹ năng của bạn
Khám phá nội dung đào tạo
Sở hữu tính năng mới đầu tiên
Tham gia Microsoft dùng nội bộ

Thông tin này có hữu ích không?

Bạn hài lòng đến đâu với chất lượng dịch thuật?
Điều gì ảnh hưởng đến trải nghiệm của bạn?

Cảm ơn phản hồi của bạn!

×