Triệu chứng

Khi một lệnh chạy dài hoặc khi bạn chạy một lệnh quản trị trong Remote PowerShell (RPS) trong Microsoft Office 365, bạn liên tục nhận được thông báo lỗi tương tự như sau:

Xử lý dữ liệu cho các lệnh từ xa không thành công với thông báo lỗi sau: [ClientAccessServer = Server1, BackEndServer = Server2 RequestId = <> gian = 4/8/2014 3:42:44 PM] [FailureCategory = WSMan InvalidShellID] yêu cầu Windows Remote Shell với ShellId <> thất bại vì vỏ không tìm thấy trên máy chủ. Nguyên nhân có thể là: ShellId được chỉ định không chính xác hoặc vỏ không tồn tại trên máy chủ. Cung cấp ShellId chính xác hoặc tạo một vỏ mới và thử lại thao tác. Để biết thêm thông tin, hãy xem chủ đề trợ giúp about_Remote_Troubleshooting. + CategoryInfo: OperationStopped:] (mail.contoso.com:String), PSRemotingTransportException + FullyQualifiedErrorId: JobFailure + PSComputerName: thư. contosocom

Nguyên nhân

Sự cố này xảy ra nếu các điều kiện sau là đúng:

  • Bạn đang sử dụng tài khoản kết hợp với người dùng kích hoạt thư (MEU) trong môi trường nhiều vùng.

  • Kết nối được chuyển đến một vùng khác từ người dùng.

Lỗi này có thể xảy ra khi máy chủ nền bị loại bỏ khỏi xoay được nâng cấp. Ngoài ra, sự cố này xảy ra thường xuyên.

Giải pháp

Tình huống 1: Khi tập lệnh đang chạy luồng công việc giữ hoặc khi tự động dừng

Trong trường hợp này, bạn có thể phải thay đổi kịch bản để tự động kết nối lại nếu máy chủ bị loại bỏ khỏi xoay trong tiến trình. Bạn có thể thực hiện việc này bằng cách sử dụng phù hợp với lỗi xử lý tập lệnh nếu phát hiện lỗi. Sau đó, kết nối và khởi động lại quá trình.

Tình huống 2: Khi bạn chạy một lệnh quản trị RPS

Trong trường hợp này, bạn phải chạy lệnh. Máy chủ nền khác sẽ được liên lạc và sau đó lệnh sẽ chạy thành công. Lưu ý Triển khai Exchange Online nhiều vùng, chúng tôi khuyên bạn nên sử dụng tài khoản quản trị được kích hoạt thư. Điều này đảm bảo kết nối RPS được thực hiện thông qua môi trường hiện tại. Nếu tài khoản quản trị liên quan đến một MEU, kết nối có thể được chuyển đến vùng khác. Hiện tượng này có thể làm chậm các lỗi kết nối hoặc kích hoạt. Nếu một trong hai vấn đề tiếp tục xảy ra, chuyển tới Microsoft để điều tra bổ sung. Bạn có thể gửi một gói dịch vụ hỗ trợ trực tuyến Microsoft trực tuyến dịch vụ hỗ trợ, hoặc bạn có thể liên hệ trực tuyến dịch vụ hỗ trợ của Microsoft qua điện thoại. Microsoft có thể yêu cầu theo dõi Fiddler điều tra vấn đề này. Nếu điều này là cần thiết, một kỹ sư hỗ trợ sẽ gửi gói chẩn đoán hỗ trợ an toàn chụp và tải thông tin này. Lấy thông tin này theo dõi Fiddler, bạn phải thêm một tùy chọn phiên PowerShell với tham số ProxyAccessType đặt IEConfig. Ví dụ:Import-PSSession (New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://mail.contoso.com/powershell -Credential (Get-Credential) -Authentication Basic -AllowRedirection -SessionOption (New-PSSessionOption -ProxyAccessType IEConfig)) Để biết thêm thông tin về cách chạy gói chẩn đoán hỗ trợ Microsoft, hãy xem làm thế nào để chạy theo dõi Fiddler bằng cách sử dụng tự động khắc phục sự cố dịch vụ của Microsoft.

Thông tin Bổ sung

Để biết thêm chi tiết về lỗi khi xử lý, hãy xem các tài nguyên sau:

Bạn cần thêm trợ giúp?

Phát triển các kỹ năng của bạn
Khám phá nội dung đào tạo
Sở hữu tính năng mới đầu tiên
Tham gia Microsoft dùng nội bộ

Thông tin này có hữu ích không?

Bạn hài lòng đến đâu với chất lượng dịch thuật?
Điều gì ảnh hưởng đến trải nghiệm của bạn?

Cảm ơn phản hồi của bạn!

×