An error occurs when deleting a report from the Microsoft Dynamics CRM 2011 application

This article provides a solution to an error that occurs when you delete a report from the Microsoft Dynamics CRM 2011 application.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2856604

Symptoms

Reports deleted from the SQL Report Server directly may still appear in the Microsoft Dynamics CRM user interface. While trying to delete it, the user might get the following error:

Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: System.Web.HttpUnhandledException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #49B448CDDetail:
<OrganizationServiceFault xmlns:i="https://www.w3.org/2001/XMLSchema-instance" xmlns="https://schemas.microsoft.com/xrm/2011/Contracts">
<ErrorCode>-2147220970</ErrorCode>
<ErrorDetails xmlns:d2p1="https://schemas.datacontract.org/2004/07/System.Collections.Generic" />
<Message>System.Web.HttpUnhandledException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #49B448CD</Message>
<Timestamp>2013-05-23T14:19:49.2545823Z</Timestamp>
<InnerFault>
<ErrorCode>-2147187945</ErrorCode>
<ErrorDetails xmlns:d3p1="https://schemas.datacontract.org/2004/07/System.Collections.Generic" />
<Message>Error occurred while deleting an item from the report server.</Message>
<Timestamp>2013-05-23T14:19:49.2545823Z</Timestamp>
<InnerFault i:nil="true" />
<TraceText i:nil="true" />
</InnerFault>
<TraceText i:nil="true" />
</OrganizationServiceFault>

Cause

When a report is deleted from Microsoft Dynamics CRM, it will check for its reference in Report Manager. If it can't find a reference in Report Manager, the deletion fails with the following error:

"Error occurred while deleting an item from the report server "

Resolution

To resolve this problem, follow these steps:

  1. On the CRM server, navigate to the CRM installation directory. Default path is C:\Program Files\ Microsoft Dynamics CRM\LangPacks\1033\Reports\MSCRM.

  2. Open Internet Explorer and navigate to https://srsservername/reports.

  3. Open the Organization_MSCRM folder and select Details View on the right-hand side of the toolbar.

  4. Open the Custom Reports folder.

  5. On the SQL Server, open SQL Server Management Studio and connect to the Server where the CRM databases stay.

  6. On the toolbar, select new query and change the dropdown to the proper CRM database.

  7. Execute the query below:

    select reportid, name from reportbase where name = 'reportname'
    

    Note

    Replace reportname with the name of the report you're trying to delete.

  8. Copy the reportid and go back to the Internet Explorer window.

  9. Select Upload File and browse to the path in Step 1 and select the User Summary.rdl file. Select Ok.

  10. Replace the name with the copied reportid from Step 7 and select Ok.

  11. From within Microsoft Dynamics CRM, navigate to Workplace, select Reports, and select the report you wish to delete. Mark the checkbox and select Delete on the toolbar.