如何管理 Microsoft Outlook 中的 .pst 文件

适用于: Microsoft Office Outlook 2003Microsoft Office Outlook 2007Microsoft Outlook 2010

有关本文的 Microsoft Outlook 2000 (CW) 版本,请参阅 195719

摘要


本文介绍如何使用个人存储文件夹(又称为 .pst 文件)备份在 Microsoft Office Outlook 2007、Microsoft Office Outlook 2003 和 Microsoft Office Outlook 2002 中创建的数据。 可以在 .pst 文件中备份邮件、联系人、约会、任务、便笺及日记条目。

注意 本文仅介绍如何在 Outlook 2007、Outlook 2003 和 Outlook 2002 中使用 .pst 文件。

如果使用其他电子邮件程序(如 Microsoft Outlook Express 或 Outlook.com),或者如果在使用电子邮件程序时遇到问题,则本文不适用于你。 有关其他文章及解决方案建议的链接,请转到“参考”部分。

简介


Microsoft Outlook 自动在以下两个位置之一存储邮件、联系人、约会、任务、便笺及日记条目:
  • 在硬盘驱动器上的个人存储文件夹(又称为 .pst 文件)中。
  • 在位于服务器上的邮箱中。 如果将 Outlook 与 Microsoft Exchange Server 一起使用,则邮箱位于服务器上。
如果遇到硬件故障,意外丢失数据,必须在计算机间传输数据,或者必须在硬盘驱动器间传输数据,则可以使用 .pst 文件的备份还原或移动 Outlook 数据。

本文介绍如何使用 .pst 文件执行一些操作。 从以下列表中选择一个操作:
  • 如何创建 .pst 文件的备份副本: 如果未将 Outlook 与 Microsoft Exchange Server 一起使用,则使用此部分备份整个 .pst 文件。
  • 如何备份位于 Microsoft Exchange Server 上的 .pst 文件数据: 如果将 Outlook 与 Microsoft Exchange Server 一起使用,则使用此部分备份 Outlook 数据。
  • 如何导出 .pst 文件数据: 如果仅希望备份少数几个文件夹或特定种类的数据(如仅邮件),则使用此部分。
  • 如何将 .pst 文件数据导入 Outlook: 使用此部分从已经备份的 .pst 文件将数据还原到 Outlook 中。
  • 如何在计算机间传输 Outlook 数据: 使用此部分在计算机间传输在 .pst 文件中保存的数据。
  • 如何备份“个人通讯簿”: 使用此部分备份“个人通讯簿”。
  • 如何使用“个人文件夹备份”实用工具自动备份 .pst 文件: 使用此部分可以每周、每月或按所选时间间隔自动备份 .pst 文件。
  • 如何备份 Outlook 设置文件: 使用此部分备份工具栏和菜单设置、Internet Explorer 收藏夹、签名文件以及你为联系人指定的任何昵称。
  • 如何查找 .pst 文件: 如果希望将现有 .pst 文件添加到 Outlook,但是不知道该文件在计算机上的确切位置,则可以进行搜索。

更多信息


如何创建 .pst 文件的备份副本

如果未将 Outlook 与 Microsoft Exchange Server 一起使用,则 Outlook 会将其所有数据存储在 .pst 文件中。 如果原始 .pst 文件损坏或丢失,则可以使用备份副本还原 Outlook 数据。 此部分说明如何创建整个 .pst 文件(包含该文件中的所有默认项目)。

执行下列步骤备份整个 .pst 文件:
  1. 关闭所有邮件处理程序,例如 Outlook、Microsoft Exchange 或 Microsoft Windows Messaging。
  2. 单击“开始”,然后单击“运行”。 在“打开”框中,复制并粘贴(或键入)以下命令,然后按 Enter:
    控制面板
    控制面板即会打开。

    注意 如果看到“选择一个类别”屏幕,请单击“用户帐户”,然后转到步骤 3。
  3. 双击“邮件”图标。
  4. 单击“显示配置文件”
  5. 单击相应的配置文件,然后单击“属性”
  6. 单击“数据文件”
  7. 在“名称”下,单击要备份的“个人文件夹服务”。 默认情况下,此服务称为“个人文件夹”。 但是,也可能命名为其他名称。

    注意 如果在你的配置文件中有多个“个人文件夹服务”,则必须分别备份每个 .pst 文件集。

    如果不存在名为“个人文件夹”的条目,并且尚未在 Outlook 中存储任何邮件、联系人或约会等信息,则可能尚未启用“个人文件夹服务”。 有关如何创建 .pst 文件的信息,请转到“参考”部分。

    如果配置文件中没有任何“个人文件夹服务”,并且你可以在 Outlook 中存储邮件、联系人或约会等信息,则信息有可能存储在 Exchange Server 上的邮箱中。 尝试使用“如何备份位于 Microsoft Exchange Server 上的 .pst 文件数据”部分中的说明:
  8. 单击“设置”,然后记下显示的路径和文件名。

    注意 因为 .pst 文件包含 Outlook 使用的 MAPI 文件夹中存储的所有数据,所以该文件可能非常大。 要减小 .pst 文件的大小,单击“设置”窗口中的“立即压缩”
  9. 关闭所有“属性”窗口。
  10. 使用“Windows 资源管理器”或“我的计算机”,复制步骤 8 中记下的文件。 可以将该文件复制到硬盘驱动器上的其他位置,也可以将其复制到任何种类的可移动存储媒体,如软盘、CD-ROM、便携式硬盘驱动器、盒式磁带或任何其他存储设备。

如何备份位于 Microsoft Exchange Server 上的 .pst 文件数据

要了解在将 Outlook 与 Microsoft Exchange Server 一起使用时如何备份数据,必须知道存储数据的位置。 Outlook 数据的默认交付和存储位置是 Exchange Server 邮箱。 Exchange Server 管理员通常会在服务器上处理邮箱的备份。 但是,一些 Exchange Server 管理员会将 Outlook 数据存储在硬盘驱动器上的 .pst 文件中。

请按照下列步骤执行操作,以查看 Outlook 当前存储数据的位置:
 

在 Outlook 2010 中:

  1. 在 Outlook 功能区上,单击“文件” 选项卡。
  2. 在“信息”类别中,单击“帐户设置”按钮,然后单击“帐户设置”
  3. 在“帐户设置”窗口中,单击“数据文件”选项卡。

    如果“位置”字段包含“Online”一词或包含文件扩展名为 .ost 的文件路径,则 Outlook 将数据存储在 Exchange Server 上的文件夹中。 有关如何处理备份的更多信息,请与 Exchange Server 管理员联系。

    如果“位置” 字段包含文件扩展名为 .pst 的文件路径,则 Outlook 将新邮件、联系人、约会及其他数据存储在硬盘上的 .pst 文件中。 若要备份该数据,请转到“如何创建 .pst 文件的备份副本”部分。
 

在 Outlook 2007 中:

  1. 在“工具”菜单上,依次单击“选项”、“邮件设置”选项卡,然后单击“电子邮件帐户”
  2. 在“帐户设置”窗口中,单击“数据文件”选项卡。

    如果“名称”字段包含“邮箱”一词,后跟电子邮件名称,则表明 Outlook 将数据存储在 Exchange Server 上的文件夹中。 有关如何处理备份的更多信息,请与 Exchange Server 管理员联系。

    如果该字段包含“个人文件夹”之类的词,或其他表示个人文件夹或 .pst 文件集的名称,则表明 Outlook 将新邮件、联系人、约会及其他数据存储在硬盘上的 .pst 文件中。 若要备份该数据,请转到“如何创建 .pst 文件的备份副本”部分。

在早期版本的 Outlook 中:

  1. 在“工具”菜单上,单击“电子邮件帐户”

    注意 此选项在某些网络上可能不可用。 网络管理员可能删除了此选项以保护帐户信息。 如果你没有看到“电子邮件帐户”选项,请联系网络管理员以获取帮助。
  2. 单击“查看或更改现有电子邮件帐户”,然后单击“下一步”
  3. 查看“将新电子邮件投递到以下位置”选项。 如果该选项包含“邮箱”一词,后跟电子邮件名称,则表明 Outlook 将数据存储在 Exchange Server 上的文件夹中。 有关如何处理备份的详细信息,请与 Exchange Server 管理员联系。

    如果该字段包含“个人文件夹”之类的词,或其他表示个人文件夹或 .pst 文件集的名称,则表明 Outlook 将新邮件、联系人、约会及其他数据存储在硬盘上的 .pst 文件中。 若要备份该数据,请转到“如何创建 .pst 文件的备份副本”部分。
     

如何导出 .pst 文件数据

如果你只想备份部分 Outlook 数据,则可以创建仅需要保存的数据的新备份 .pst 文件。 这也称为导出 .pst 文件数据。 例如,如果重要信息仅位于某些文件夹中,而其他不太重要的信息位于更多的文件夹中,则可能需要使用此部分。 可以仅导出重要的文件夹或联系人,而省略“已发送邮件”等文件夹。
 

在 Outlook 2010 中:

按照以下步骤导出特定文件夹:
  1. 单击“文件”选项卡。
  2. 在“Outlook 选项”窗口中,单击“高级”
  3. 单击“导出”
  4. 在“导入和导出向导”中,单击“导出到文件”,然后单击“下一步”
  5. 单击“Outlook 数据文件(.pst)”,然后单击“下一步”
  6. 选择要导出的文件夹,然后单击“下一步”
  7. 单击“浏览”,然后选择要保存新 .pst 文件的位置。
  8. 在“文件名”框中,键入要用于新 .pst 文件的名称,然后单击“确定”
  9. 单击“完成”

在早期版本的 Outlook 中:

  1. 打开 Outlook。
  2. 在“文件”菜单上,单击“导入和导出”。 如果看不到该菜单项,则将鼠标指针悬停在菜单底部的燕尾形箭头上,然后单击“导入和导出”
  3. 单击“导出到文件”,然后单击“下一步”
  4. 单击“个人文件夹文件(.pst)”,然后单击“下一步”
  5. 单击要将 .pst 文件导出到的文件夹,然后单击“下一步”
  6. 单击“浏览”,然后选择要保存新 .pst 文件的位置。
  7. 在“文件名”框中,键入要用于新 .pst 文件的名称,然后单击“确定”
  8. 单击“完成”
注意 文件夹设计属性包括权限、筛选器、说明、表单和视图。 如果要将一个 .pst 文件中的条目导出到另一个文件中,将不会保留任何文件夹设计属性。

如何将 .pst 文件数据导入 Outlook

如果原始 .pst 文件损坏或丢失,则可以使用 .pst 文件的备份副本还原 Outlook 数据。 .pst 文件中保存的所有内容都会返回到 Outlook。
 

在 Outlook 2010 中:

按照以下步骤将数据还原或导入到 Outlook 中:
  1. 单击“文件”选项卡。
  2. 在“打开”类别中,单击“导入”
  3. 在“导入和导出向导”对话框中,单击“从另一程序或文件导入”,然后单击“下一步”
  4. 单击“Outlook 数据文件(.pst)”,然后单击“下一步”
  5. 键入要导入的 .pst 文件的路径和名称,或者单击“浏览”选择要导入的文件。

    注意 在“选项”下,建议你单击“不导入重复项目”,除非你希望导入的信息替换或复制 Outlook 中已存在的项目。
  6. 单击“下一步”
  7. 选择要导入的文件夹。 要导入 .pst 文件中的所有内容,请选择层次结构的顶部。

    注意 自动选择顶级文件夹(通常是“个人文件夹”、“Outlook 数据文件”或电子邮件地址)。 默认情况下,选择“包括子文件夹”。 将导入所选文件夹下的所有文件夹
  8. 单击“完成”
 

在早期版本的 Outlook 中:

按照以下步骤将数据还原或导入到 Outlook 中:
  1. 如果希望导入的 .pst 文件存储在可移动设备(如软盘、便携式硬盘驱动器、CD-ROM、盒式磁带或者任何其他存储媒体)上,则插入或连接该存储设备,然后将 .pst 文件复制到计算机的硬盘驱动器上。

    复制 .pst 文件时,请确保没有选择“只读”属性。 如果选择此属性,你可能会收到以下错误消息:
    无法访问指定的设备、文件或路径。 It may have been deleted, it may be in use, you may be experiencing network problems, or you may not have sufficient permission to access it. Close any application using this file and try again.
    如果收到此错误消息,请清除“只读”属性,然后再次复制该文件。
  2. 打开 Outlook。
  3. 在“文件”菜单上,单击“导入和导出”。 如果命令不可用,则将鼠标指针悬停在菜单底部的燕尾形箭头上,然后单击“导入和导出”
  4. 单击“从另一程序或文件导入”,然后单击“下一步”
  5. 单击“个人文件夹文件(.pst)”,然后单击“下一步”
  6. 键入要导入的 .pst 文件的路径和名称,然后单击“下一步”
  7. 选择要导入的文件夹。 要导入 .pst 文件中的所有内容,请选择层次结构的顶部。
  8. 单击“完成”

如何在计算机间传输 Outlook 数据

不能在计算机间共享或同步 .pst 文件。 但是,仍然可以在计算机间传输 Outlook 数据。

使用“如何创建 .pst 文件的备份副本”部分中的说明将 .pst 文件复制到 CD 或 DVD-ROM 或其他便携式媒体,或者通过 LAN/WAN 链接将该文件复制到另一台计算机上。

注意 不支持通过 LAN/WAN 链接连接到 .pst 文件,通过此类链接连接到 .pst 文件可能发生问题。 有关更多信息,请参阅以下文章:

297019 LAN 或 WAN 链接不支持个人文件夹文件

你可能还需要创建一个仅用于传输数据的新的辅助 .pst 文件。 将要传输的数据保存在此新的 .pst 文件中,并省略不想传输的任何数据。 如果需要创建另一个 .pst 文件以存储要在两台不同的计算机间传输的数据,或用于备份目的,请使用下列步骤。
 

在 Outlook 2010 中:

  1. 单击“文件”选项卡。
  2. 在“信息”类别中,单击“帐户设置”按钮,然后单击“帐户设置”
  3. 在“帐户设置”窗口中,单击“数据文件”选项卡。
  4. 依次单击“添加”、“Outlook 数据文件(.pst)”,然后单击“确定”
  5. 为新的 .pst 文件键入唯一的名称。 例如,键入 Transfer.pst,然后单击“确定”
  6. 关闭 Outlook。
 

在早期版本的 Outlook 中:

  1. 在“文件”菜单上,指向“新建”,然后单击“Outlook 数据文件”
  2. 为新的 .pst 文件键入唯一的名称。 例如,键入 Transfer.pst,然后单击“确定”
  3. 为个人文件夹文件键入显示名称,然后单击“确定”
  4. 关闭 Outlook。
执行下列步骤复制现有 .pst 文件:
  1. 使用“如何创建 .pst 文件的备份副本”部分中的说明创建要传输的 .pst 文件的备份副本。 确保将备份 .pst 文件复制到 CD-ROM 或另一种可移动媒体。
  2. 将备份 .pst 文件从可移动媒体复制到第二台计算机上。
  3. 按照“如何将 .pst 文件数据导入 Outlook”部分中的步骤执行操作,将 .pst 文件数据导入第二台计算机上的 Outlook 中。

如何备份个人通讯簿

个人通讯簿可能包含 Outlook 通讯簿或联系人列表中未包含的电子邮件地址和联系人信息。 Outlook 通讯簿可保留在 Exchange Server 邮箱或 .pst 文件中。 但是,个人通讯簿会创建存储在硬盘驱动器上的单独文件。 为了确保备份此通讯簿,你必须在备份过程中包含任何具有 .pab 扩展名的文件。

按照以下步骤找到个人通讯簿文件:
  1. 如果你运行的是 Windows Vista: 单击“开始”

    如果你运行的是 Windows XP: 依次单击“开始”、“搜索”

    如果你运行的是 Windows 95 或 Windows 98: 单击 “开始”,指向“查找”,然后单击“文件或文件夹”

    如果你运行的是 Windows 2000 或 Windows Millennium Edition (Me): 单击“开始”,指向“搜索”,然后单击“要搜索的文件或文件夹”
  2. 键入 *.pab,然后按 Enter 键或单击“开始查找”

    记下 .pab 文件的位置。 使用“我的电脑”或“Windows 资源管理器”将 .pab 文件复制到包含 .pst 文件备份的同一文件夹或存储媒体中。
你可以使用此备份将个人通讯簿还原到你的计算机,或者将其传输到另一台计算机。 按照以下步骤还原个人通讯簿:
  1. 关闭所有邮件处理程序,如 Outlook、Microsoft Exchange 或 Windows Messaging。
  2. 单击“开始”,然后单击“运行”。 在“打开”框中,复制并粘贴(或键入)以下命令,然后按 Enter:
    控制面板
    控制面板即会打开。

    注意 如果看到“选择一个类别”屏幕,则单击“用户帐户”
  3. 双击“邮件”图标。
  4. 单击“显示配置文件”
  5. 单击相应的配置文件,然后单击“属性”
  6. 单击“电子邮件帐户”
  7. 单击“添加新目录或通讯簿”,然后单击“下一步”
  8. 单击“附加通讯簿”,然后单击“下一步”
  9. 单击“个人通讯簿”,然后单击“下一步”
  10. 键入要还原的“个人通讯簿”文件的路径和名称,单击“应用”,然后单击“确定”
  11. 单击“关闭”,然后单击“确定”
注意 Outlook 通讯簿是一种服务,配置文件使用该服务可以更加容易地将邮箱中的联系人文件夹、个人文件夹文件或公用文件夹用作电子邮件通讯簿。 Outlook 通讯簿本身不包含任何必须保存的数据。

如何使用个人文件夹备份实用工具自动备份 .pst 文件

Microsoft 发布了一个实用工具,用于自动完成个人文件夹 (.pst) 文件的备份。 要下载此实用工具,请访问下面的 Microsoft 网站:有关个人文件夹备份实用工具的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
 
238782 如何自动备份个人文件夹文件
 
注意 在 Microsoft Outlook 2010 中,默认情况下禁用“个人文件夹备份”加载项。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2030523 如何启用“个人文件夹备份”加载项以与 Outlook 2010 一起使用
 

如何备份 Outlook 设置文件


如果已自定义设置(如工具栏设置和收藏夹),您希望将这些设置复制到另一台计算机上,或者将其还原到相关计算机上,则可能需要在备份中包括以下文件:
  • Outcmd.dat: 此文件存储工具栏及菜单设置。
  • ProfileName.fav: 这是你的收藏夹文件,其中包括 Outlook 栏的设置(仅适用于 Outlook 2002 及更旧版本)。
  • ProfileName.xml: 此文件存储导航窗格首选项(仅适用于 Outlook 2003 及更新版本)。
  • ProfileName.nk2: 此文件存储自动完成的昵称。
  • 签名文件: 每个签名都有其自己的文件,其名称与你在创建该签名时使用的名称相同。 例如,如果你创建了一个名为 MySig 的签名,则“签名”文件夹中会创建如下文件:
    • MySig.htm: 此文件存储 HTML 格式的自动签名。
    • MySig.rtf: 此文件存储 Microsoft Outlook RTF 格式的自动签名。
    • MySig.txt: 此文件存储纯文本格式的自动签名。
    签名文件的位置取决于你运行的 Windows 版本。 使用此列表查找相应的位置:
    • Windows Vista 或 Windows 7Drive\users\Username\appdata,其中 Drive 表示安装 Outlook 的驱动器,Username 表示安装 Outlook 时使用的用户名。
       
    • Windows XP 或 Windows 2000Drive\Documents and Settings\Username\Local Settings\Application Data\Microsoft\Outlook,其中 Drive 表示安装 Outlook 的驱动器,Username 表示安装 Outlook 时使用的用户名。
    • Windows 98 或 Windows Me: Drive\Windows\Local Settings\Application Data,其中 Drive 表示安装 Outlook 的驱动器。
注意 如果将 Microsoft Word 用作电子邮件编辑器,则签名将作为自动图文集条目存储在 Normal.dot 文件中。 您也应备份此文件。
 

如何查找 .pst 文件

如果你不知道旧的或现有 .pst 文件在计算机上位于何处,但希望将此 .pst 文件添加到 Outlook 配置文件中,则此部分介绍如何搜索 .pst 文件并将其添加到 Outlook 配置文件中。



要搜索 .pst 文件,请按照下列步骤执行操作:
  1. 搜索 .pst 文件的步骤:
    • 如果你运行的是 Windows Vista: 单击“开始”,然后单击“计算机"。 在右上角找到搜索窗口。
    • 如果你运行的是 Windows XP: 依次单击“开始”、“搜索”
    • 如果你运行的是 Windows 95 或 Windows 98: 单击 “开始”,指向“查找”,然后单击“文件或文件夹”
       
    • 如果你运行的是 Windows 2000 或 Microsoft Windows Millennium Edition: 单击“开始”,指向“搜索”,然后单击“要搜索的文件或文件夹”
       
  2. 键入 *.pst,然后按 Enter 键或单击“开始查找”。 找到要添加到 Outlook 的所需 .pst 文件。 记录 .pst 文件的位置。
     
  3. 关闭搜索窗口并启动 Outlook。
    • 如果你运行的是 Outlook 2010,请单击“文件”选项卡,然后单击“信息”类别中的“帐户设置”。 再次单击“帐户设置”,然后在出现的窗口中单击“数据文件”选项卡。
    • 如果你运行的是 Outlook 2007 或更早版本,请单击“文件”菜单,然后选择“数据文件管理”
  4. 单击“添加”按钮,然后选择正确的 .pst 文件类型进行添加。如果 .pst 文件是在 Outlook 2007 中创建的,则选择“Office Outlook 个人文件夹文件(.pst)”。 如果 .pst 文件是在较旧的 Outlook 版本(例如 Outlook 97、2000 或 XP)中创建的,则选择“Outlook 97-2002 个人文件夹文件(.pst)”
  5. 导航到你在上述搜索中找到的所需 .pst 文件的位置。 选择 .pst 文件,然后单击“确定”
     
  6. 键入 .pst 文件的自定义名称,或接受默认名称。 单击“确定”。 单击“关闭”,退出当前窗口。
     
Outlook 即会在 Outlook 文件夹列表中显示该 .pst 文件。

后续步骤


如果这些方法不能帮助你,则可能需要向认识的其他人员寻求帮助。 或者,如果你结合使用 Outlook 和 Exchange Server,则可能需要联系 Exchange Server 管理员获取帮助。 你还可以使用 Microsoft 客户支持服务网站以查找其他解决方案。 Microsoft 客户支持服务网站提供以下服务: 如果使用上述 Microsoft 网站之后仍有问题,或者如果你在 Microsoft 支持服务网站中无法找到解决方案,请单击下面的链接联系支持部门。

参考


有关如何对配置文件和服务进行配置的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

289467 用户配置文件和信息服务

有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

269520 Outlook 为何不支持只读媒体

238782 如何在 Outlook 2000 和 Outlook 2003 中自动备份个人文件夹文件

257831 如何在以“仅支持 Internet 邮件”模式安装的 Outlook 2000 中移动个人文件夹文件

291627 如何在 Outlook 中为两台不同的计算机管理 .pst 文件

291636 如何在 Outlook 2002 和 Outlook 2007 中移动个人文件夹 (.pst) 文件

883401 如何更改 Outlook 2003 或 Outlook 2002 用于创建或打开个人文件夹 (.pst) 文件的默认位置