Users can't log on to a Windows Server 2012 R2-based server through remote desktop because of RDSLS database corruption

This article describes an issue in which users can't get a client access license (CAL) or log on to a Windows Server 2012 R2-based server. A hotfix is available to fix this issue. Before you install this hotfix, check out the Prerequisites section.

Symptoms

This issue occurs when many users log on to the system in a short time.

Cause

This issue occurs because incorrect handling of the transaction causes the rollback of an active transaction and that corrupts the Remote Desktop Services Licensing Server (RDSLS) database.

Resolution

To fix this issue, we have released a hotfix for Windows Server 2012 R2.

Hotfix information

Important If you install a language pack after you install this hotfix, you must reinstall this hotfix. Therefore, we recommend that you install any language packs that you need before you install this hotfix. For more information, see Add language packs to Windows.


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that's described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there's a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section doesn't appear, submit a request to Microsoft Customer Service and Support to get the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that don't qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you don't see your language, it's because a hotfix isn't available for that language.


Prerequisites

To apply this hotfix, install update 2919355 in Windows Server 2012 R2.

Registry information

To use the hotfix in this package, you don't have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix doesn't replace a previously released hotfix.
File information

File Information

The English (United States) version of this software update installs files that have the attributes that are listed in the following tables. The dates and times for these files are listed in Coordinated Universal Time (UTC). Be aware that dates and times for these files on your local computer are displayed in your local time and with your current daylight saving time bias. The dates and times may also change when you perform certain operations on the files.
Additional file information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

See the terminology that Microsoft uses to describe software updates.
属性

文章 ID:3084952 - 上次审阅时间:2015年9月8日 - 修订版本: 1

Windows Server 2012 R2 Datacenter, Windows Server 2012 R2 Standard, Windows Server 2012 R2 Essentials, Windows Server 2012 R2 Foundation

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