ADO.NET applications require MDAC 2.6 or later and the .NET Framework

已弃用知识库内容免责声明

本文介绍 Microsoft 不再提供支持的产品。 因此,本文“按原样”提供,并且不再更新。

Symptoms

When you try to open a connection in a deployed .NET application, you may encounter an exception similar to the following:
The .NET Data SQL Provider (System.Data.SqlClient) requires Microsoft Data Access Components (MDAC) version 2.6 or later.

Cause

This behavior occurs if MDAC version 2.6 or later is not installed on your computer. The Microsoft .NET Framework SDK and the .NET Framework redistributable package do not include the MDAC installation. All .NET applications that use data-access functionality require MDAC 2.6 or later (MDAC 2.7 is recommended).

Note Microsoft Visual Studio .NET installation includes MDAC 2.7 and Microsoft Visual Studio 2005 installation includes MDAC 2.8.

Resolution

 To resolve this issue, install MDAC 2.6 or later on your computer. To download the MDAC components, visit the following Microsoft website: 

Status

This behavior is by design.

More Information

Applications and controls that are written for the Microsoft .NET Framework require the .NET Framework to be installed on the computer on which the application or control runs. For more information about the .NET Framework, visit the following Microsoft website: 

References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

320788 "How to install MDAC with a Windows Installer Merge Module" white paper is available

属性

文章 ID:315467 - 上次审阅时间:2012年5月25日 - 修订版本: 1

反馈