ActiveSync 客户端无法连接或在Exchange Server环境中延迟同步

原始 KB 编号: 4456227、4337638

症状

在 Exchange Server 2016 或 Exchange Server 2013 环境中,Exchange ActiveSync客户端无法连接,或者在用户同步其移动设备时遇到延迟。 除这些问题外,CAS 角色的所有功能都将停止工作。 在Exchange ActiveSync应用程序池运行一段时间(通常为数周)之后,会出现此问题。 此外,你可能会遇到以下行为:

  • 事件 ID 4227 记录在事件查看器的系统日志中。
  • Exchange ActiveSync应用程序池会消耗大量内存。
  • 对应于Exchange ActiveSync应用程序池的 w3wp 实例的 GC 中的 .NET CLR 内存/% 时间异常高。
  • TCP 端口耗尽是由于Exchange ActiveSync中的大量请求而发生的。
  • MSExchangeSyncAppPool 实例的W3SVC_W3WP/活动请求计数器显示值在几天或几周内稳步增加。
  • netstat -anob 命令可能会显示许多处于 CLOSE_WAIT 状态的连接。

原因

这是Exchange ActiveSync Ping 命令在应用程序池中搁浅时出现的已知问题。

解决方法

对于 Exchange Server 2013,若要解决此问题,请定期为所有服务器循环Exchange ActiveSync应用程序池以释放搁浅的命令。 有关如何将应用程序池配置为定期自动回收的详细信息,请参阅应用程序池<回收>的回收设置

解决方案

对于 Exchange Server 2016,若要解决此问题,请安装适用于 Exchange Server 2016 的累积更新 11,或安装适用于 Exchange Server 2016 的更高版本的累积更新

状态

Microsoft 已确认,在 “适用范围”中列出的 Microsoft 产品中存在此问题。

References

了解 Microsoft 用于描述软件更新 的术语