2019 年 1 月 8 日左右,批量许可的 Windows 7 Service Pack 1 KMS 客户端上的激活失败和 (非正版) 通知

本文提供了以下问题的解决方案:用户可能会在 2019 年 1 月 8 日 UTC 10:00 或之后收到 Windows 激活或“Windows 不是正版”通知。

适用于: Windows 7 Service Pack 1
原始 KB 编号: 4487266

摘要

本文适用于批量许可的 Windows 7 Service Pack 1 设备,这些设备使用密钥管理服务 (KMS) 激活并安装 KB 971033 更新。 从 2019 年 1 月 8 日 10:00 UTC 开始或之后,某些用户可能会收到 Windows 激活或“Windows 不是正版”通知。

2019 年 1 月 9 日,我们还原了对 Microsoft 激活和验证服务器所做的更改。 对于继续报告激活和“非正版”通知的设备,应按照“解决方法”部分中的步骤删除 KB 971033

支持批量许可激活的 Windows 版本包括:

  • Windows 7 专业版
  • Windows 7 专业版 N
  • Windows 7 专业版 E
  • Windows 7 企业版
  • Windows 7 企业版 N
  • Windows 7 企业版 E

对于在 2019 年 1 月 8 日左右遇到激活和“非正版”错误的 Windows 版本,建议遵循标准激活故障排除。

症状

  1. 登录后,你会收到 Windows 不是正版 错误消息。

    Windows 不是正版错误消息的屏幕截图。

  2. A 此窗口副本不是正版 水印显示在 Windows 桌面的右下角,背景为黑色。

    水印的屏幕截图显示在 Windows 桌面的右下角。

  3. 输出 slmgr /dlv 0xC004F200报告错误。

    命令输出的屏幕截图,其中报告了错误0xC004F200。

  4. 使用 slmgr /ato 命令进行的激活失败,并返回以下消息:

    Windows 在非正版通知期内运行。 运行“slui.exe”以联机并验证 Windows。

    使用 命令后返回的消息的屏幕截图。

  5. 以下事件记录在事件日志中。

事件日志 事件源 事件 ID 描述
Application Microsoft-Windows-Security-SPP 8209 应用程序 ID 55c92734-d682-4d71-983e-d6ec3f16059f 的正版状态设置为非正版 (0x00000000)
Application Microsoft-Windows-Security-SPP 8208 获取正版票证失败 (hr=0xC004C4A2) 模板 ID 66c92734-d682-4d71-983e-d6ec3f16059f
Application Windows 激活技术 13 正版验证结果:hrOffline = 0x00000000,hrOnline =0xC004C4A2
Application Microsoft-Windows-Security-SPP 8196 许可证激活计划程序 (sppuinotify.dll) 无法自动激活。 错误代码:0xC004F200:

原因

Microsoft 激活和验证的最新更新无意中在安装了 KB971033 的批量许可 Windows 7 客户端上无意中导致“非正版”错误。 更改于 2019 年 1 月 8 日 UTC 10:00:00 引入,并在 2019 年 1 月 9 日 4:30:00 UTC 还原。

注意

此时间与 2019 年 1 月 8 日星期二发布的“1B”更新 (KB 4480960KB 4480970) 发布相吻合。 这些事件不相关。

在 2019 年 1 月 8 日 KB971033 10:00:00 UTC 更改时间 (10:00:00 到该更改 (201) 9 年 1 月 9 日 4:30:00 UTC 之间未遇到此问题的 Windows 7 设备,) 不应遇到本文中所述的问题。

KB971033 包含以下文本:

“注意 对于使用密钥管理服务 (KMS) 或多重激活密钥 (MAK) 批量激活的企业客户,我们通常建议不要在其引用映像或已部署的计算机中安装此更新。 此更新面向使用 RETAIL 激活的 Windows 的使用者安装。”

强烈建议从所有基于 Windows 7 的批量许可设备卸载 KB971033 。 这包括当前不受 症状 部分中提到的问题影响的设备。

解决方案

若要确定是否安装了 KB 971033 ,请使用以下方法之一。

  • 控制面板 (控制面板 中打开已安装汇报>项Windows 更新>查看更新历史记录>已安装汇报) ,然后在列表中查找 Microsoft Windows (KB971033) 更新

  • 以管理员身份在命令提示符窗口中运行以下命令,然后在结果中查找“Microsoft-Windows-Security-WindowsActivationTechnologies-package~31bf3856ad364e35~amd64~~7.1.7600.16395”:

    dism /online /get-packages
    
  • 在命令提示符处运行以下命令,然后在结果中查看已安装 KB 971033 的指示:

    wmic qfe where HotFixID="KB971033"
    
  • 在 Windows PowerShell 中运行以下命令,然后在结果中查找已安装 KB 971033的指示:

    Get-Hotfix -id KB971033
    

    如果当前安装了 KB 971033 ,请使用以下方法之一删除更新。 建议在删除更新后重启系统。

  • “控制面板 (控制面板”中的“已安装汇报>项Windows 更新>查看更新历史记录>”“已安装汇报) ”,右键单击“Microsoft Windows (KB971033) 更新”,然后选择“卸载”。

  • 以管理员身份在命令提示符窗口中运行以下命令:

    wusa /uninstall /kb:971033
    
  • 以管理员身份在命令提示符窗口中运行以下命令:

    dism /online /Remove-Package /PackageName:Microsoft-Windows-Security-WindowsActivationTechnologies-Package~31bf3856ad364e35~amd64~~7.1.7600.16395
    

卸载 KB 971033 或不再显示为已安装后,请重新生成与激活相关的文件,然后通过在命令提示符窗口中以管理员身份运行以下命令来重新激活系统:

net stop sppuinotify
sc config sppuinotify start= disabled
net stop sppsvc
del %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-0.C7483456-A289-439d-8115-601632D005A0 /ah
del %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-1.C7483456-A289-439d-8115-601632D005A0 /ah
del %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\tokens.dat
del %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\cache\cache.dat
net start sppsvc
cscript c:\windows\system32\slmgr.vbs /ipk <edition-specific KMS client key>
cscript c:\windows\system32\slmgr.vbs /ato
sc config sppuinotify start= demand

注意

在第一个 cscript 命令中,将特定于版本的 KMS 客户端密钥>替换为<实际密钥。 有关详细信息,请参阅 KMS 客户端设置密钥

下表列出了每个版本的 Windows 7 的 KMS 客户端密钥。

操作系统版本 KMS 客户端安装密钥
Windows 7 专业版 FJ82H-XT6CR-J8D7P-XQJJJ2-GPDD4
Windows 7 专业版 N MRPKT-YTG23-K7D7T-X2JMM-QY7MG
Windows 7 专业版 E W82YF-2Q76Y-63HXB-FGJG9-GF7QX
Windows 7 企业版 33PXH-7Y6KF-2VJC9-XBBR8-HVTHH
Windows 7 企业版 N YDRBP-3D83W-TY26F-D46B2-XCKRJ
Windows 7 企业版 E C29WB-22CC8-VJ326-GHFJW-H9DH4

注意

  • 包含 KMS 客户端安装密钥的脚本必须面向相应的操作系统版本。
  • 对于未安装 KB 971033 但遇到 症状 部分中提到的问题的服务,还可以使用重新激活命令列表中提到的脚本重新生成与激活相关的文件并重新激活系统。

数据收集

如果需要 Microsoft 支持方面的帮助,建议按照使用 TSS 针对与部署相关的问题收集信息中所述的步骤收集信息。