安装 Adobe Acrobat 7.0 后,Word 无法保存更改或者在 Office 程序中收到错误消息


重要说明:本文包含有关如何修改注册表的信息。修改注册表之前,一定要先进行备份,并且一定要知道在发生问题时如何还原注册表。有关如何备份、还原和修改注册表的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
256986 Microsoft Windows 注册表说明

症状


使用“适用于”一节中列出的 Microsoft Office 程序时,可能会遇到下列一种或多种症状:
  • 在 Microsoft Word 中更改工作区后,退出 Word 时无法保存更改。对工作区所做的更改包括下列示例:
    • 创建宏。
    • 更改默认字体。
    • 添加“自动图文集”条目。
    • 添加工具栏。
    重新启动 Word 时,无法使用您已更改或添加的项目。

    注意:即使选中“提示保存 Normal 模板”复选框,也会出现此问题。
  • 当您尝试启动 Office 程序时,会收到类似下列某一内容的错误消息:
    visual c++ runtime error
    Microsoft visual c++ runtime library

    Program files\Microsoft office\office10\product name.exe

    This application has requested the runtime to terminate it in an unusual way.
  • 打开一个 Word 文档时,可能会收到下面的错误消息:
    There is insufficient memory or disk space.Word cannot display the requested font.

原因


安装 Adobe Acrobat 7.0 Professional、Adobe Acrobat 7.0 Standard 或 Adobe Acrobat 7.0 Elements 后,会出现这些问题。

Acrobat 7.0 会在下面的文件夹中安装 COM 加载项:
\Acrobat 7.0\PDFMaker\Office
此 COM 加载项为 Office 程序提供 PDFMaker 图标和菜单命令。

替代方法


要变通解决此问题,请根据您的情况使用下列方法之一。如果在退出 Word 后未保存更改,请使用方法 1 或方法 2。如果在尝试启动 Office 程序或尝试打开 Word 文档时收到错误消息,则使用方法 3 或方法 4。

方法 1:使用“文件”菜单上的“全部保存”命令保存 Word 中的宏、首选项和自定义设置

要在 Word 中手动保存宏、首选项和自定义设置,请按照下列步骤操作:
  1. 按住 Shift 键。
  2. 在“文件”菜单上,单击“全部保存”。
即会保存更改。而且,这些更改在其他 Word 文档中也可用。

方法 2:自定义“文件”菜单以添加“全部保存”命令

在 Word 中,将“全部保存”命令添加到“文件”菜单中。然后,在每次创建宏、首选项或自定义设置后都使用“全部保存”命令。

要向 Word 中的“文件”菜单添加“全部保存”命令,请按照下列步骤操作:

  1. 在“工具”菜单上,单击“自定义”。
  2. 在“命令”选项卡上,单击“类别”下的“文件”。
  3. 在“命令”下,将“全部保存”拖动至“文件”菜单。打开“文件”菜单后,将“全部保存”命令放在所需的位置。
  4. 关闭“自定义”对话框。

方法 3:与 Adobe 联系

与 Adobe Systems Incorporated 联系以确定是否有可用的 Acrobat 7.0 更新。
有关如何与 Adobe Systems Incorporated 联系的信息,请单击下面列表中相应的文章编号,以查看 Microsoft 知识库文章:
65416 硬件和软件供应商联系信息,A-K

60781 硬件和软件供应商联系信息,L-P

60782 硬件和软件供应商联系信息,Q-Z
Microsoft 提供了第三方联系信息以便于您寻求技术支持。这些联系信息如有更改,恕不另行通知。Microsoft 不保证这些第三方联系信息的准确性。

方法 4:从 Office 中删除 Adobe 加载项

如果删除 Adobe 加载项,则无法在 Office 程序中将文件另存为可移植文档文件 (PDF)。

要删除 Adobe 加载项,请按照下列步骤操作。

注意:由于 Microsoft Windows 有多个版本,因此下列步骤可能会因您使用的计算机而有所不同。如果是这样,请参见您的产品文档来完成这些步骤。
  1. 退出所有程序。
  2. 单击“开始”,指向“设置”,然后单击“控制面板”。
  3. 双击“添加或删除程序”。
  4. 在“当前安装的程序”下,单击“Adobe Acrobat Professional 7.0”,然后单击“更改”¡£
  5. 单击“修改”,然后单击“下一步”。
  6. 展开“创建 Adobe PDF”。
  7. 展开“Acrobat PDFMaker”。
  8. 单击“Microsoft Office”旁的箭头,然后单击“未安装”。
  9. 在 Adobe Acrobat Professional 7.0 安装向导中,单击“确定”。
  10. 关闭“添加或删除程序”。
如果在完成这些步骤后,仍遇到前面提到的症状,那么可能需要从注册表中手动删除 Adobe 加载项。

重要说明:在手动删除 Adobe 加载项之前,请与 Adobe 联系以获得更多信息。

警告:如果使用注册表编辑器或其他方法错误地修改了注册表,则可能导致严重问题。这些问题可能需要重新安装操作系统才能解决。Microsoft 不能保证您可以解决这些问题。修改注册表需要您自担风险。
要手动删除 Adobe 加载项,请按照下列步骤操作:
  1. 单击“开始”,单击“运行”,键入 regedit,然后单击“确定”。
  2. 找到并单击下面的注册表子项:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin
  3. 在“文件”菜单上,单击“导出”,键入一个文件名,然后单击“保存”。
  4. 右键单击“PDFMaker.OfficeAddin”注册表项,然后单击“删除”。
  5. 执行步骤 3 和 4 以在下面的注册表子项中删除加载项注册表项:
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin



    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook
  6. 退出注册表编辑器。

更多信息


Normal.dot 文件是 Word 使用的默认模板。默认情况下,影响所有新文档的更改将保存到 Normal.dot 文件。除非在保存更改时指定另一个模板,否则将更改保存到 Normal.dot 文件。Acrobat 7.0 会防止 Word 自动将更改保存到 Normal.dot 文件中。

有关此问题的更多信息,请访问下面的 Adobe 网站: