你目前正处于脱机状态,正在等待 Internet 重新连接

如何在安装了“用于企业和工作组”选项的 Outlook 2000 中使用收件箱修复工具恢复邮件

有关本文的 Microsoft Outlook 2002 和 Microsoft Office Outlook 2003 版本,请参阅 287497.
有关本文的 Microsoft Outlook 2000 (IMO) 版本,请参阅 197315.
有关本文的 Microsoft Outlook 98 (CW) 版本,请参阅 181325.
有关本文的 Microsoft Outlook 98 (IMO) 版本,请参阅 181523.
注意: 只有在安装 Outlook 时选择了“用于企业或工作组”选项时,本文中的过程才适用。 选择此选项后,您就可以使用消息处理应用程序编程接口 (MAPI) 服务。 要确定安装类型,请单击“帮助”菜单上的“关于 Microsoft Outlook”。 如果您在安装时选择了“用于企业或工作组”,此时就会看到“用于企业或工作组”。
概要
本文介绍如何使用收件箱修复工具从损坏的个人文件夹 (.pst) 文件中恢复文件夹和项目。  
更多信息
注意: 下面列出的示例涉及到对 .pst 文件使用收件箱修复工具。 这些过程同样适用于脱机文件夹 (.ost) 文件。 要找到脱机文件夹 (.ost) 文件,请单击以选择“选择要扫描的文件”中的“脱机文件夹 (*.ost)”

收件箱修复工具 (Scanpst.exe) 是一种旨在帮助修复与个人文件夹 (.pst) 文件有关的问题的工具。 该工具还可以修复脱机文件夹 (.ost) 文件。

收件箱修复工具随 Microsoft Windows 95 一起发行,并且包含在 Microsoft Outlook 98 和 Microsoft Office 2000 光盘中。 它是安装期间自动安装的。 该实用工具还随 Microsoft Windows 98 光盘上的 Windows 消息服务安装程序一起安装。 您可以在以下文件夹中找到这些程序:
<CD drive>:\tools\oldwin95\message\us\wms.exe
在 Windows 2000 中,您可以在以下文件夹中找到这些程序:
<CD drive>:\Program Files\Common Files\System\Mapi\1033\NT\Scanpst.exe

视频: 如何修复您的 Outlook 个人文件夹 (.pst) 文件



运行收件箱修复工具

  1. 单击“开始”,然后指向“查找”或“搜索”,具体取决于您的操作系统。
  2. 在“要搜索的文件或文件夹名为”框中,键入 scanpst.exe
  3. 键入 pst 文件的路径和文件名,或单击“浏览”以通过使用 Windows 文件系统来查找文件。
  4. 单击“开始”

收件箱修复工具的功能

当您对个人文件夹 (.pst) 文件运行收件箱修复工具时,它将执行以下操作:
  • 收件箱修复工具分析个人文件夹 (.pst) 文件的目录结构和项目标题,以尝试并恢复所有文件夹和项目。
  • 如果收件箱修复工具恢复了个人文件夹 (.pst) 文件,意味着修复工具发现了问题并修复了它能够修复的问题。
  • 收件箱修复工具尝试将所有文件转换成个人文件夹 (.pst) 文件。 例如,如果您将某个可执行文件重命名为“Something.pst”(不带引号),此工具会将该文件更改为可装入的 .pst 文件。

恢复的个人文件夹文件

运行收件箱修复工具后,请启动 Outlook,方法是使用包含您尝试修复的个人文件夹 (.pst) 文件的配置文件。 在“视图”菜单上,单击“文件夹列表”打开文件夹列表视图。 在“文件夹列表”中,您应该可以看到以下已恢复的文件夹:
   恢复的个人文件夹      日历      联系人      已删除邮件      收件箱      日记账      备注      发件箱      已发送邮件      任务				
这些已恢复的文件夹通常是空的,因为这是一个重新生成的 .pst 文件。 您还应该看到一个名为“Lost And Found”(不带引号)的文件夹。 该文件夹包含收件箱修复工具恢复的文件夹和项目。 “Lost and Found”文件夹中所没有的项目将无法修复。

如何恢复已修复的项目

您应该将尽可能多的项目从“Lost And Found”文件夹移动到您的配置文件中新的个人文件夹 (.pst) 文件中。 首先,在您的配置文件中创建一个新的个人文件夹 (.pst) 文件项,然后将任何已恢复的项目从“Lost And Found”文件夹拖到该新的个人文件夹 (.pst) 文件中的适当位置。

如何在配置文件中创建新的个人文件夹 (.pst) 文件

  1. 使用包含已恢复的个人文件夹 (.pst) 文件的配置文件启动 Outlook。
  2. 在“文件”菜单上,单击“数据文件管理”
  3. 单击“添加”打开“新建 Outlook 数据文件”对话框。
  4. 在“存储类型”对话框中,单击选择“个人文件夹文件(.pst)”,然后单击“确定”
  5. 在“创建或打开 Outlook 数据文件”对话框中,选择新个人文件夹 (.pst) 文件的目录和文件名,然后单击“打开”
  6. 单击“确定”
您的配置文件中应该有一个新的个人文件夹 (.pst) 文件。 将恢复的项目从“Lost And Found”文件夹拖到该新的个人文件夹 (.pst) 文件中。 移动完所有项目后,可以从您的配置文件中删除“恢复的个人文件夹(.pst)”文件,包括“Lost And Found”文件夹。

如何恢复备份个人文件夹 (.pst) 文件中的项目

注意: 如果在运行收件箱修复工具之前无法打开原始个人文件夹 (.pst) 文件,则以下过程可能不起作用。 如果您能够打开原来的个人文件夹 (.pst) 文件,则可以使用以下过程从损坏的个人文件夹 (.pst) 文件中恢复更多的项目。

运行收件箱修复工具时,将选择创建原始个人文件夹 (.pst) 文件的备份这一选项。 该选项将在您的硬盘上创建一个名为 <file name>.bak 的文件,它是原来的 <file name>.pst 文件的副本,只是具有不同的扩展名。 .bak 文件与您原来的个人文件夹 (.pst) 文件驻留在同一目录中。

您可以从该 .bak 文件恢复那些收件箱修复工具无法恢复的项目。 制作 .bak 文件的一个副本,并使用 .pst 扩展名为该文件指定一个新名称,例如,“Newname.pst”(不带引号)。

使用相应的配置文件(该配置文件包含您在本文“恢复已修复的项目”部分的步骤 4 中创建的新个人文件夹 (.pst) 文件)打开 Outlook,并尝试使用导入和导出向导导入“Newname.pst”文件夹。 为此,请按照下列步骤操作:
  1. 在“文件”菜单上,单击“导入和导出”
  2. 单击“从另一程序或文件导入”,然后单击“下一步”
  3. 单击选择“个人文件夹文件(.pst)”,然后单击“下一步”
  4. 在“要导入的文件”下,键入您的 Newname.pst 文件。 在“选项”下,单击“不导入重复项目”,然后单击“下一步”
  5. 在“从下面位置选择要导入的文件夹”下,依次单击以选择“个人文件夹 (.pst)”文件、“包括子文件夹”和“将文件夹导入以下位置中的同一文件夹”,单击您在本文“恢复已修复的项目”部分的步骤 4 中创建的新个人文件夹 (.pst) 文件,然后单击“完成”
注意: 请记住,该备份文件是原来被损坏的文件,而且您可能会发现您无法恢复除在“Lost And Found”文件夹中恢复的项目以外的任何项目。 如果您无法将 Newname.pst 文件导入 Outlook,则您已丢失了所有不在“Lost And Found”文件夹中的信息。

如何恢复 2 GB 的个人文件夹 (.pst)

个人文件夹 (.pst) 的上限是 2 GB。 通常当个人文件夹 (.pst) 接近此限制时,您可能无法保存或检索项目。 脱机文件夹 (.ost) 也具有同样的大小限制。

Microsoft 已提供了一个实用工具,该工具旨在通过将个人文件夹 (.pst) 的大小减小到临界限制以下来恢复其中存储的项目。 使用该实用工具会导致为恢复最多的数据而丢失某些数据。

有关 PST 大小限制和 PST/OST 裁剪工具的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
296088 超出大小限制的 PST 和 OST 的裁剪工具
damaged damage OL2K
属性

文章 ID:197316 - 上次审阅时间:03/22/2013 14:27:00 - 修订版本: 3.0

  • Microsoft Outlook 2000 标准版
  • kbcorrupt kbrepair kbhowto kbvideocontent KB197316
反馈