你目前正处于脱机状态,正在等待 Internet 重新连接

如何在 Excel 中使用直方图加载宏

有关本文的 Microsoft Excel 98 版本,请参见 189519.

本任务的内容

概要
这篇分步指导文章介绍如何根据一组示例数据使用图表创建直方图。Microsoft Excel 中附带的分析工具库包括了一个直方图工具。

返回页首

验证是否安装了分析工具库

在使用直方图工具之前,需要确保已经安装了分析工具库加载宏。要确定是否已安装分析工具库,请执行以下步骤:
  1. 在 Microsoft Office Excel 2003 和更低版本的 Excel 中,单击“工具”菜单上的“加载宏”。

    在 Microsoft Office Excel 2007 中,请按照下列步骤操作:
    1. 单击“Office 按钮”,然后单击“Excel 选项”。
    2. 单击“加载项”类别。
    3. 在“管理”列表中,选择“Excel 加载项”,然后单击“转到”。
  2. 在“加载宏”对话框中,确保选中了“可用加载宏”下的“分析工具库”复选框。单击“确定”。
注意:若要在“加载宏”对话框中显示分析工具库,该工具库必须已经安装在计算机上。如果在“加载宏”对话框中没有看到“分析工具库”,请运行 Microsoft Excel 安装程序并将此组件添加到安装项列表中。

返回页首

创建直方图

  1. 在新工作表中输入以下数据:
    A1:87     B1: 20A2:27     B2: 40A3:45     B3: 60A4:62     B4: 80A5:3      B5:A6:52     B6:A7:20     B7:A8:43     B8:A9:74     B9:A10:61    B10:					
  2. 在 Excel 2003 和更早的 Excel 版本中,单击“工具”菜单上的“数据分析”。

    在 Excel 2007 中,在“数据”选项卡上的“分析”组中单击“数据分析”。
  3. 在“数据分析”对话框中,单击“直方图”,然后单击“确定”。
  4. 在“输入区域”框中,输入 A1:A10。
  5. 在“接收区域”框中,输入 B1:B4。
  6. 在“输出选项”中,单击“新工作簿”,选择“图表输出”复选框,然后单击“确定”。
将生成一个包含直方图表格和嵌入图表的新工作簿。

根据第 1 步中输入的示例数据,直方图表格看起来如同下表所示:
A1:接收     B1:频率A2:20     B2:        2A3:40     B3:        1A4:60     B4:        3A5:80     B5:        3A6:其他   B6:        1				
而且,您的图表将是一个反映此直方图表格中的数据的柱状图图表。

Excel 将统计每个数据接收中的数据点的数量。如果某个数据点大于特定数据接收的下限并且小于等于其上限,则将其包括在该数据接收中。在此例中,对应于从 0 到 20 的数据值的接收包含两个数据点:3 和 20。

如果省略接收区域,Excel 将在数据的最小值和最大值之间创建一组平均分布的接收。

注意:如果指定在数据所在的同一工作簿中创建直方图表格的选项(“输出区域”或“新工作表”),将无法创建直方图图表。

有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
214029如果对 Excel 工作簿中的工作表进行了分组,选定的数据分析工具将只使用活动工作表中的数据
返回页首
ATP Tool Pack Toolpack histo
属性

文章 ID:214269 - 上次审阅时间:07/16/2013 06:51:00 - 修订版本: 5.3

Microsoft Office Excel 2007, Microsoft Excel 2002 标准版, Microsoft Excel 97 标准版, Microsoft Excel 2000 标准版

  • kbfunctions kbfuncstat kbaddin kbhowtomaster KB214269
反馈