安装或升级第三方打印驱动程序后遇到打印后台处理程序错误消息

本文提供了一种解决方案,用于修复安装或升级第三方打印驱动程序后出现的打印后台处理程序错误。

适用于:Windows 10 - 所有版本,Windows Server 2012 R2
原始 KB 编号: 2793718

症状

在基于 Windows 的客户端计算机上,可能会遇到以下任何症状:

  • 在安装或升级第三方打印驱动程序期间,可能会收到以下错误消息:

    • 操作失败,出现错误 0x00000057
    • 未安装打印机驱动程序。 操作无法完成(错误 0x00000057)
    • 操作失败,出现错误 0x000005b3
    • 操作无法完成(错误 0x00000bc4)。 未找到打印机。
    • Windows 无法连接到打印机。 操作无法完成(错误 0x00000002)
  • 尝试启动或停止打印后台处理程序服务时,可能会收到以下错误消息:

    后台处理程序子系统应用遇到问题,需要关闭

  • 单击“开始”,然后在 Windows XP 中单击“打印机和传真”,或在 Windows Vista 或更高版本中单击“设备和打印机”时,可能会收到以下错误消息:

    后台处理程序子系统应用遇到错误,需要关闭

  • 单击“开始”,然后在 Windows XP 中单击“打印机和传真”,或在 Windows Vista 或更高版本中单击“设备和打印机”以尝试查看打印机时,不会显示打印机。 即使安装了打印机,也可能会出现此问题。

原因

如果第三方打印机驱动程序或服务影响现有或新安装打印机的功能,则可能会出现这些问题。

解决方案

要清除和重置打印后台处理程序,请执行以下步骤:

  1. 在任务栏的搜索框中,键入“服务”,并从结果列表中选择“服务”
  2. 选择“标准”选项卡,然后双击服务列表中的“打印后台处理程序”
  3. 选择“停止”,然后选择“确定”
  4. 在任务栏上的搜索框中,输入“%WINDIR%\system32\spool\printers”,在结果列表中选择“%WINDIR%\system32\spool\PRINTERS”,然后删除文件夹中的所有文件。
  5. 在任务栏的搜索框中,搜索服务,然后在结果列表中选择“服务”
  6. 选择“标准”选项卡,并在服务列表中双击“打印后台处理程序”
  7. 选择“开始”,在“启动类型”框中选择“自动”,然后选择“确定”

数据收集

如果需要 Microsoft 支持方面的帮助,建议按照 使用 TSS 收集用户体验问题中的信息中所述的步骤收集信息。