当您尝试登录到应用程序设置的 Azure AD B2C"服务器错误 / 应用程序中"错误

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症状
当您尝试登录到已设置为 Microsoft Azure 活动目录 (AD) 企业对消费者 (B2C) 的应用程序时,您会收到以下错误消息:

/ 应用程序中的服务器错误

响应状态码并不表示成功: 404 (未找到)

说明: 执行当前 web 请求期间,出现了未经处理的异常。请检查堆栈跟踪有关该错误以及其原始代码中的位置的详细信息。

异常详细信息: System.Net.Http.HttpRequestException: 响应状态代码,并不表示成功: 404 (未找到)

源错误: 执行当前 web 请求期间,出现了未经处理的异常。可以使用下面的异常堆栈跟踪来标识来源和位置异常的有关信息。

堆栈跟踪:


[IOException: 无法获得从文档: https://login.microsoftonline.com/contoso.onmicrosoft.com/.well-known/openid-configuration?p=Policyname]
原因
注册策略名称在应用程序的 Web.config 文件中可能会丢失或不正确。
解决方案
若要解决此问题,请执行以下步骤:
  1. 打开该应用程序的 Web.config 文件。
  2. 在 Web.config 文件中,请验证的应用程序键是否"ida: SignUpPolicyId"存在。
  3. 应用程序键的值替换为您在 Azure AD B2C 管理门户中提供注册策略的名称。

    该文件的更改的部分将如下所示:
    <appSettings></appSettings>

    <add key="ida:SignUpPolicyId" value=" key="ida:SignUpPolicyId" value=""></add key="ida:SignUpPolicyId" value=">B2C_Signup_Policy_Name">

更多信息

属性

文章 ID:3092588 - 上次审阅时间:09/18/2015 03:24:00 - 修订版本: 1.0

Microsoft Azure Active Directory

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