从 KB3135244 安装了 SQL Server 2008 或 SQL Server 2008 R2 的任何版本后出现了间歇性服务终止

症状
在安装 3135244 中介绍的适用于 Microsoft SQL Server 2008 和 Microsoft SQL Server 2008 R2 的任何 TLS 1.2 支持更新后,可能会出现间歇性服务终止。
更多信息
2016 年 1 月 29 日,Microsoft 发布了适用于 SQL Server 2008 和 SQL Server 2008 R2 的 TLS 1.2 更新。 我们已经发现该更新中存在的缺陷,该缺陷可能会在您尝试连接到 SQL Server 实例时导致间歇性服务终止。

出现此问题时,会在 SQL Server 错误日志中记录类似于以下消息的一个错误消息:

Date and time spid1s ***Stack Dump being sent to C:\Program Files\Microsoft SQL Server\MSSQL10.DEV08\MSSQL\LOG\SQLDump0002.txt
Date and time spid1s * *******************************************************************************
Date and time spid1s *
Date and time spid1s * BEGIN STACK DUMP:
Date and time spid1s * Date and time spid 1
Date and time spid1s *
Date and time spid1s * Location: sosmemobj.cpp:2760
Date and time spid1s * Expression: pvb->FInUse ()
Date and time spid1s * SPID: 1
Date and time spid1s * Process ID: 1164

Date and time Server ***Stack Dump being sent to C:\Program Files\Microsoft SQL Server\MSSQL10.DEV08\MSSQL\LOG\SQLDump0001.txt
Date and time Server * *******************************************************************************
Date and time Server *
Date and time Server * BEGIN STACK DUMP:
Date and time Server * Date and time spid 2076
Date and time Server *
Date and time Server * ex_terminator - Last chance exception handling

受影响的版本

以下 SQL Server 发布版本受此问题的影响。
SQL Server 版本受影响的版本
SQL Server 2008 R2 SP3(x86 和 x64)10.50.6537.0
SQL Server 2008 R2 SP2 GDR(仅 IA-64)10.50.4046.0
SQL Server 2008 R2 SP2(仅 IA-64)10.50.4343.0
SQL Server 2008 SP4(x86 和 x64)10.0.6543.0
SQL Server 2008 SP3 GDR(仅 IA-64)10.0.5544.0
SQL Server 2008 SP3(仅 IA-64)10.0.5894.0
解决方案
对于要使自己免受服务终止问题影响的客户,如果他们的 SQL Server 版本在上一节的“受影响的版本”表中列出,则建议他们安装 KB 3135244 中介绍的适用于 Microsoft SQL Server 的 TLS 1.2 支持更新。

我们已经发布了 SQL Server 2008 R2 和 SQL Server 2008 的更新版本,可解决 TLS 1.2 更新中发现的缺陷。 我们建议您使用这个新版本将所有 SQL Server 实例更新到应用了 TLS 1.2 更新的实例。

有关更新版本的下载位置的详细信息,请参阅下面的 Microsoft 知识库文章:
3135244 适用于 Microsoft SQL Server 的 TLS 1.2 支持
更多信息

FAQ

此更新是否包含其他任何与安全相关的功能更改?

除了在 KB 3135244 中介绍的更改外,此更新还包括纵深防御更新,以帮助提高与安全相关的功能。
状态
Microsoft 已经确认“适用于”部分中列出的 Microsoft 产品存在此问题。
属性

文章 ID:3146034 - 上次审阅时间:03/04/2016 13:58:00 - 修订版本: 2.0

Microsoft SQL Server 2008 R2 Developer, Microsoft SQL Server 2008 R2 Enterprise, Microsoft SQL Server 2008 R2 Standard, Microsoft SQL Server 2008 R2 Express, Microsoft SQL Server 2008 Developer, Microsoft SQL Server 2008 Enterprise, Microsoft SQL Server 2008 Standard, Microsoft SQL Server 2008 Express

  • kbbug kbexpertiseinter kbsecurity kbsecvulnerability KB3146034
反馈