"配置保护,输入不正确的格式在"Azure PowerShell 若要启用虚拟机备份运行时错误

重要说明:本文是由 Microsoft 机器翻译软件进行的翻译并可能由 Microsoft 社区通过社区翻译机构(CTF)技术进行后期编辑,或可能是由人工进行的翻译。Microsoft 同时向您提供机器翻译、人工翻译及社区后期编辑的文章,以便对我们知识库中的所有文章以多种语言提供访问。翻译的文章可能存在词汇、句法和/或语法方面的错误。Microsoft 对由于内容的误译或客户对内容的使用所导致的任何不准确、错误或损失不承担责任。

点击这里察看该文章的英文版: 3172632
症状
当您启用 usinga 以前版本的 Microsoft Azure PowerShellthat 1.5.1 Microsoft Azure 虚拟机 (Vm) 的备份时,您将收到类似于以下内容的错误消息︰

PS C:\WINDOWS\system32 > 启用 AzureRmRecoveryServicesBackupProtection-$policy 策略的名称 BackupItemName -ResourceGroupName ResourceGroupName
启用-AzureRmRecoveryServicesBackupProtection:
BMSUserErrorInvalidConfigureProtectionRequest︰ 用于输入配置保护不是正确的格式
请确保容器存在和其他参数是有效的格式
原因
发生此问题是因为 Microsoft Azure 恢复服务电子仓库的 命令 已经更新为重要的安全修补程序,并且此更新触发 Azure PowerShell 获得预 1.5.1 版本。
替代方法
若要变通解决此问题,请下载并安装最新版本的 Azure PowerShell.To 执行此操作,请转到 Azure 下载 >命令行工具> PowerShell > Windows 设置

当您执行此操作时,您将看到下面的下载页面︰

下载页面的屏幕快照

警告:本文已自动翻译

属性

文章 ID:3172632 - 上次审阅时间:07/21/2016 20:53:00 - 修订版本: 2.0

Microsoft Azure Recovery Services

  • kbsurveynew kbprb kbfix kbexpertiseadvanced kbmt KB3172632 KbMtzh
反馈