你目前正处于脱机状态,正在等待 Internet 重新连接

T-SQL 调试程序之后会关闭默认情况下为早期版本的客户端安装 SQL Server 2000 Service Pack 3

注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。

点击这里察看该文章的英文版: 328151
本文已归档。它按“原样”提供,并且不再更新。
概要
默认状态下,安装 Microsoft SQL Server 2000 Service Pack 3 (SP3) 之后您不能使用 T-SQL 调试程序如果使用 Microsoft Visual Studio 的版本早于 Microsoft Visual Studio.net 或者早于 Microsoft SQL Server 2000 SP3 的查询分析器的版本。

如果您尝试使用 T-SQL 调试程序从一台更早版本的客户机,您可能会收到以下错误消息:
服务器: 消息 514,级别 16,状态 1 过程 sp_sdidebug 行 1 [Microsoft] [ODBC 驱动 SQL Server 程序] [SQL Server] 无法与 [SQL Server 名称] 上的调试器 (错误 = 0x80070005)。为连接 53 禁用调试。
更多信息
注意早于 SQL Server 2000 SP3 的版本的查询分析器和早于 Visual Studio.net 的 Visual Studio 的版本被称为"早期的客户端"这篇文章中。

Microsoft 已为早期版本的客户端,出于安全原因禁用 T-SQL 调试程序。若要启用 T-SQL 调试程序的早期版本的客户端,如 sa系统管理员 服务器角色的成员必须显式启用调试通过运行下面的代码:
        Exec sp_sdidebug 'legacy_on'				
每次重新启动服务器时,您必须重复此过程。 Microsoft 不建议您在生产服务器上使用 T-SQL 调试程序。

若要禁用的早期版本的客户端的 T-SQL 调试程序,系统管理员 服务器角色的成员可以运行下面的代码:
       Exec sp_sdidebug 'legacy_off'				

下表描述了默认行为的 TRANSACT-SQL SQL Server sp3 的调试器。
调试客户端默认值legacy_on
查询分析器 (SP3 之前)已禁用已启用
查询分析器 (SP3)已启用已启用
visual Studio 5 和 6已禁用已启用
visual Studio.net 直接数据库调试已启用已启用
visual Studio.net 应用程序调试已禁用已启用
参考
T-SQL 调试程序有关的详细信息,请参阅 SQL Server 联机丛书中的使用 TRANSACT-SQL 调试器和"疑难解答 TRANSACT-SQL 调试器"主题。

警告:本文已自动翻译

属性

文章 ID:328151 - 上次审阅时间:02/26/2014 23:26:09 - 修订版本: 6.4

Microsoft SQL Server 2000 Service Pack 3

  • kbnosurvey kbarchive kbmt kbproductlink kbinfo KB328151 KbMtzh
反馈