在 Outlook 中的"发生未知的错误"错误消息

针对 Office 2003 的支持已终止

Microsoft 已于 2014 年 4 月 8 日终止了针对 Office 2003 的支持。该更改已影响到您的软件更新和安全选项。 了解这一措施对于您的含义以及如何继续保持受保护状态。

重要说明:本文是由 Microsoft 机器翻译软件进行的翻译并可能由 Microsoft 社区通过社区翻译机构(CTF)技术进行后期编辑,或可能是由人工进行的翻译。Microsoft 同时向您提供机器翻译、人工翻译及社区后期编辑的文章,以便对我们知识库中的所有文章以多种语言提供访问。翻译的文章可能存在词汇、句法和/或语法方面的错误。Microsoft 对由于内容的误译或客户对内容的使用所导致的任何不准确、错误或损失不承担责任。

点击这里察看该文章的英文版: 814441
症状
如果您使用 Microsoft Outlook 2010,Outlook 2007 中,Outlook 2003 中,或与 Windows 7、 与 Windows Vista 中,或与 Windows XP Outlook 2002 中,您可能会收到以下错误消息之一时尝试读取,发送、 接收或删除电子邮件:

错误消息 1
发生了未知的错误。0x80040119
错误消息 2
发生了未知的错误。0x80040600
当您尝试删除电子邮件时,您可能会收到以下错误消息:
消息传递接口已导致出现未知的错误
解决方案
您可以通过使用收件箱修复工具来分析并修复的.pst 文件来解决此问题。.Pst 文件是您的电子邮件、 联系人、 笔记、 日历项和其他数据存储的个人文件夹文件。

若要使用收件箱修复工具的步骤有所不同,这取决于您的计算机的操作系统。使用一组适当的以下步骤解决此问题。

注意:如果.pst 文件是 ANSI 格式太平洋标准时间,并超过 2 千兆字节 (GB),则收件箱修复工具 (Scanpst.exe) 不工作。

有关 ANSI 和 Unicode 格式对.pst 文件以及如何将新的 Unicode PST 添加到您的 Outlook 配置文件的详细信息,请参阅以下文章 Microsoft 知识库中相应的文章:

829971 如何在 Outlook 2003 中创建的.pst 文件

有关 ANSI 和 Unicode.pst 文件大小限制的详细信息,请参阅以下文章 Microsoft 知识库中相应的文章:
830336 .Pst 文件具有不同的格式和文件夹大小限制在 Outlook 2007 中,在 Outlook 2003 中

本文适用于初级和中级计算机用户。

您可能会发现如果先将本文打印,再按照步骤会变得更容易。

系统必备组件
当您按照步骤来解决此问题,您需要使用的文件,通常是隐藏的文件。以便在需要时可以找到该文件,您必须配置 Windows 资源管理器显示计算机上的隐藏的文件。若要执行此操作,请按照下列步骤操作:

在 Windows 7 中显示隐藏的文件

  1. 单击开始 开始键入文件夹选项 开始搜索 ,,然后按 Enter。
  2. 单击视图 选项卡。下面列出了此步骤的截屏。
    屏幕快照的文件夹选项
  3. 高级设置中,单击显示隐藏的文件和文件夹,然后单击确定

在 Windows Vista 中显示隐藏的文件

  1. 单击开始开始键入 控件开始搜索框,然后按 Enter。
  2. 单击外观和个性化
  3. 单击文件夹选项
  4. 单击视图选项卡。
  5. 高级设置中,单击显示隐藏的文件和文件夹,然后单击确定

在 Windows XP 中显示隐藏的文件

  1. 开始 Windows 资源管理器。
  2. 工具菜单上单击文件夹选项
  3. 单击视图选项卡。
  4. 隐藏文件和文件夹,单击显示隐藏的文件和文件夹,然后单击确定


若要解决此问题,在 Windows 7 中和在 Windows Vista 中的步骤

步骤 1: 退出 Outlook

步骤 2: 查找 Outlook.pst 文件

  1. 单击开始开始键入 控制面板 开始搜索框,然后按 Enter。
  2. 如果您看到控制面板主页视图,请单击用户帐户和家庭安全

    如果看不到控制面板主页视图,请转到步骤 3。
  3. 搜索控件面板 框中的右上角,类型邮件然后按 enter 键。
  4. 单击邮件 邮件 (32 位)。下面列出了此步骤的截屏。
    屏幕快照的邮件。
  5. 单击数据文件。 下面列出了此步骤的截屏。
    为邮件设置的截屏。
  6. 单击个人文件夹,然后单击设置

    注意:如果您的配置文件中有没有个人文件夹服务,您可以在 Outlook 中存储信息,如邮件、 联系人或约会,您的信息可能被存储在 Exchange 服务器上的邮箱中。如果是这样,信息通常备份服务器上。有关详细信息,请与 Exchange 服务器管理员联系。
  7. 记下的文件名框中的文本。

    注意:您可能需要在文件名框中单击,然后使用向右箭头键查看所有文本。
  8. 单击确定,然后单击关闭两次。

第 3 步: 找到收件箱修复工具

  1. 根据需要为您正在运行的 Outlook 的版本使用下列方法之一。

    注意:如果您不确定您使用的 Outlook 的版本,打开 Outlook,请单击帮助 菜单,然后再单击有关 Microsoft Outlook 以查看的版本。
    • Microsoft Office Outlook 2010

      单击开始开始键入 %ProgramFiles%\Microsoft Office\Office14\开始搜索框,然后按 Enter。
    • Microsoft Office Outlook 2007

      单击开始开始键入 %ProgramFiles%\Microsoft Office\Office12\开始搜索框,然后按 Enter。
    • Microsoft Office Outlook 2003

      单击开始开始键入 %ProgramFiles%\Common Files\System\MSMAPI\1033\开始搜索框,然后按 Enter。
    • Microsoft Outlook 2002

      单击开始开始键入 %ProgramFiles%\Common Files\System\Mapi\1033\开始搜索框,然后按 Enter。
  2. 查找,然后双击SCANPST。EXE启动收件箱修复工具。

步骤 4: 使用收件箱修复工具

  1. 输入所要扫描的文件框中,键入您在步骤 2 中找到的 Outlook.pst 文件的路径和文件名称。
  2. 单击开始
  3. 在收件箱修复工具操作完成后,单击确定
如果您现在可以读取和删除的电子邮件,可以单击发送/接收在 Outlook 中没有错误、 问题得到解决。如果您仍然收到错误信息,请转到"后续步骤"部分。


若要解决此问题,在 Windows XP 中的步骤

步骤 1: 退出 Outlook

步骤 2: 查找 Outlook.pst 文件

  1. 单击开始,然后单击运行
  2. 键入 控件打开框中,并按 Enter。
  3. 如果您看到选择一个类别视图中,单击用户帐户

    如果看不到选择一个类别视图中,请转到步骤 4。
  4. 双击邮件
  5. 单击数据文件
  6. 单击个人文件夹,然后单击设置

    注意:如果您的配置文件中有没有个人文件夹服务,您可以在 Outlook 中存储信息,如邮件、 联系人或约会,您的信息可能被存储在 Exchange 服务器上的邮箱中。如果是这样,信息通常备份服务器上。有关详细信息,请与 Exchange 服务器管理员联系。
  7. 记下的文件名框中的文本。

    注意:您可能需要在文件名框中单击,然后使用向右箭头键查看所有文本。
  8. 单击确定,然后单击关闭两次。

第 3 步: 找到收件箱修复工具

  1. 单击开始,然后单击搜索
  2. 单击所有文件和文件夹
  3. 全部或部分文件名框中,键入 Scanpst.exe.
  4. 查找范围框中的选定内容更改为本地硬盘。例如,将所选内容更改为本地磁盘 (c:)
  5. 单击搜索
  6. 搜索完成后,双击SCANPST。EXE启动收件箱修复工具。

步骤 4: 使用收件箱修复工具

  1. 输入所要扫描的文件框中,键入您在步骤 2 中找到的 Outlook.pst 文件的路径和文件名称。
  2. 单击开始
  3. 在收件箱修复工具操作完成后,单击确定
如果您现在可以读取和删除的电子邮件,可以单击发送/接收在 Outlook 中没有错误、 问题得到解决。如果您仍然收到一条错误消息,请转到"后续步骤"部分。


下一步行动
如果前面所述的方法不能解决此问题,您可以尝试创建一个新的 Unicode.pst 文件,将其设置为默认值,然后从旧.pst 文件导入数据。有关如何创建新的.pst 文件和设置的信息作为默认值,请参阅下面的 Microsoft 知识库中相应的文章文章"如何到点 Outlook 向您新个人文件夹文件"部分:
291636 如何将您在 Outlook 中的个人文件夹 (.pst) 文件移动

要导入原始.pst 文件,必须从 Outlook 配置文件将被删除。当 Outlook 正在运行时,请右键单击您想要删除的 Outlook 数据文件 (.pst) 的名称Outlook 面板 导航窗格,然后单击关闭名称。如果关闭 命令不可用,您可能在试图用来保存新邮件的默认 Outlook 数据文件 (.pst) 中删除。前面所引用的文章提供了更改用作默认送达位置的.pst 文件的步骤。

从配置文件中删除原始.pst 文件后,您可以将数据导入新的.pst 文件使用"如何导入 Outlook.pst 文件数据"部分下面 Microsoft 知识库中相应的文章:

287070 如何管理在 Outlook 2007 中,在 Outlook 2003 中,并在 Outlook 2002 中的.pst 文件

如果这些方法不能帮助您,您可能需要寻求他人的帮助。或者,如果您使用 Outlook 与 Exchange Server 时,您可能需要与 Exchange Server 管理员联系获得帮助。您也可以使用 Microsoft 客户支持服务网站查找其他解决方案。某些 Microsoft 客户支持服务网站提供的服务包括:
  • 可搜索的知识库: 搜索 Microsoft 产品的自助工具和技术支持信息。
  • 解决方案中心: 查看特定于产品的常见问题解答以及重要的支持信息。
  • 其它支持选项: 使用 web 提出问题、 联系微软客户支持服务,或提供反馈意见。
如果您继续使用以下 Microsoft 网站,或在 Microsoft 支持服务的网站上找不到解决方案后,有任何疑问,请转到 与 Microsoft 联系 网站。
属性

文章 ID:814441 - 上次审阅时间:10/04/2014 01:14:00 - 修订版本: 12.0

Microsoft Outlook 2010, Microsoft Office Outlook 2007, Microsoft Office Outlook 2003, Microsoft Outlook 2002 标准版, Microsoft Exchange Online

  • kbceip kbnomt kbexpertiseinter kbexpertisebeginner kbtshoot kbreceivemail kbsendmail kberrmsg kbprb kbmt KB814441 KbMtzh
反馈