如何创建 FrontPage 2003 中的子文件夹按分组的 Windows SharePoint Services 文档库的一个 XSLT 数据视图

Support for Office 2003 has ended

Microsoft ended support for Office 2003 on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。

点击这里察看该文章的英文版: 839592
本文已归档。它按“原样”提供,并且不再更新。
概要
本文讨论了如何使用 Microsoft Office FrontPage 2003 在由子文件夹创建一个文档库,则在分组的一个 XSLT 数据视图。

如果您的 Microsoft Windows SharePoint Services Web 站点上的文档库中包含子文件夹,并且您将在文档库的 List View Web Part 转换为可扩展样式表语言转换 (XSLT) 数据视图子文件夹将不再显示在视图中。列出子文件夹的内容。 但是,内容都不根据分组存储内容的子文件夹。 之后您将文档库转换为 XSLT 数据视图显示文档库的子文件夹,按子文件夹的路径进行分组视图。本文介绍如何将文档库配置 XSLT 数据视图中,以便按 URL Dir 名称 选项进行分组的视图。
更多信息
本文包括描述如何执行以下步骤:
  • 创建包含子文件夹的文档库。
  • 将文档库的 List View Web Part 转换为 XLST 数据视图。
  • 使用 URL Dir 名称 选项的子文件夹的路径来分组视图。
如果您还没有还创建了一个文档库包含子文件夹,请转到步骤 1 并按照本文中其余的步骤操作。如果您已经创建包含子文件夹的文档库,请转到步骤 4,然后按照本文中其余的步骤进行操作。
  1. Windows SharePoint Services 网站中创建新文档库。若要这样做,请按照下列步骤操作:
    1. 连接到您 Windows SharePoint Services 网站,然后单击 文档和列表
    2. 单击 创建,然后单击在 文档库 下的 文档库
    3. 指定要用于新的文档库设置,然后单击 创建
  2. 在您创建的新文档库中创建子文件夹。若要这样做,请按照下列步骤操作:
    1. DocumentLibraryName 页上单击 新建文件夹
    2. 名称 框中键入新文件夹的名称,然后单击 保存并关闭
    3. 对每个想要在文档库中创建子文件夹重复步骤 2a 和 2b。
  3. 将一个或多个文档上载到文档库中的每个子文件夹中。若要这样做,请按照下列步骤操作:
    1. 单击您要上载到文档子文件夹。
    2. 单击 上载文档
    3. 在该 DocumentLibraryName: 上载文档 页面上,使用以下过程之一:
      • 若要上载一个文档,单击 浏览,单击您要上载、 单击 打开,然后单击 保存并关闭 该文件。
      • 要同时上载多个文档,单击 上载多个文件。单击以选中您想要上载,该文件旁的复选框,然后单击 保存并关闭
    4. 重复步骤 3a 3c 通过为文档库中的每个子文件夹。
  4. 将文档库的 List View Web Part 转换为 XSLT 数据视图。若要这样做,请按照下列步骤操作:
    1. 启动 FrontPage 2003,然后打开 Windows SharePoint Services Web 站点。
    2. 打开您所创建的文档库的 AllItems.aspx 页。
    3. 视图 菜单上单击 (如果它尚未被选中,然后单击在页面底部的 设计
    4. 用鼠标右键单击 List View Web Part,然后单击 转换为 XSLT 数据视图

      注意在视图中不显示子文件夹。
  5. 若要按文件夹的路径进行分组视图中,单击 排序和分组数据视图详细信息 任务窗格中。
  6. 排序和分组 对话框的 可用字段 列表中单击 URL Dir 名称,然后单击 添加

    注意如果在 可用字段 列表中未显示 URL Dir 名称,将 URL Dir 名称 添加到列表中。若要这样做,请按照下列步骤操作:
    1. 关闭 排序和分组 对话框。
    2. 数据视图详细信息 任务窗格中单击 数据源属性
    3. 查询,在 数据源属性 对话框中,单击
    4. 显示域 对话框中的 可用字段 列表中单击 URL 目录名称 并单击 添加,然后单击 确定 两次。
  7. 排序和分组 对话框中的 组属性,下单击以选中 显示组页眉 复选框,单击 按默认值折叠组,然后单击 确定
  8. 文件 菜单上单击 保存

    作为组页眉显示在子文件夹的路径。当您预览页在 Web 浏览器中的时,组标题被折叠。展开要查看子文件夹的内容组标头。
参考
有关如何使用数据视图在 FrontPage 2003 中的其他信息,请参阅 FrontPage 2003 帮助。要做到这点,单击 帮助 菜单上的 Microsoft Office FrontPage 帮助,在 搜索 框中键入 数据视图 然后按 ENTER 键。

属性

文章 ID:839592 - 上次审阅时间:01/11/2015 05:53:25 - 修订版本: 1.4

Microsoft Office SharePoint Portal Server 2003, Microsoft Windows SharePoint Services, Microsoft Office FrontPage 2003

  • kbnosurvey kbarchive kbmt kbdisplay kbhowto kbinfo KB839592 KbMtzh
反馈