Windows 更新或 Microsoft 更新重复提供相同的更新

本文介绍如何排查在 Windows 更新 或 Microsoft 更新中反复提供相同更新的问题。

适用于:Windows 10 - 所有版本、Windows 7 Service Pack 1
原始 KB 编号: 910339

原因

如果首次未正确安装更新,或者Windows 更新设置无法检测到更新,则可能会发生这种情况。

解决方案

如果一直看到为安装提供相同的更新,请尝试稍后安装更新。

你可能还希望检查更新历史记录,以查看是否存在任何错误消息。 然后,可以通过转到Microsoft 支持部门搜索找到的任何错误。

若要检查更新历史记录,请执行以下步骤。

  • 对于 Windows 8

    1. 从右侧向内轻扫以查看超级按钮,点击或单击“ 搜索”,然后键入“ 查看更新历史记录”。
    2. 点击或单击“ 设置”,然后选择“ 查看更新历史记录”。
    3. 点击或单击“ 状态 ”按状态排序,然后查找状态为 “失败”的任何更新。
    4. 点击并按住或右键单击状态为 “失败”的更新,然后选择“ 查看详细信息”。 打开的窗口显示该更新的错误代码。
  • 对于 Windows 7、Windows Vista 和 Windows XP

    1. 启动Windows 更新。 为此,请单击“开始”,在搜索框中键入“更新”,然后在结果列表中单击“Windows 更新”。
    2. 在导航窗格中,单击“ 查看更新历史记录”。
    3. 单击“ 状态 ”按状态排序,然后查找状态为 “失败”的任何更新。
    4. 右键单击状态为 “失败”的更新,然后选择“ 查看详细信息”。 打开的窗口显示该更新的错误代码。 如果此问题仍然存在,请将此问题发布到 Microsoft 社区

    还可以检查电话号码联系Microsoft 支持部门寻求帮助。 可能会收取费用。

数据收集

如果需要 Microsoft 支持方面的帮助,建议按照使用 TSS 针对与部署相关的问题收集信息中所述的步骤收集信息。