按周进行分组的服务活动报表,在 Microsoft 动态 CRM 时报告服务出现错误消息:"SET DATEFIRST 0 是超出了范围"

注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。

点击这里察看该文章的英文版: 913330
本文已归档。它按“原样”提供,并且不再更新。
本文中讨论的修补程序不是可用于 Microsoft 动态 CRM 的中文版本或日语版的 Microsoft 动态 CRM。
症状
在按星期分组时在 Microsoft 动态 CRM 中的设置服务活动报表,您可能会收到下面的报表服务错误消息:
SET DATEFIRST 0 超出了范围。
原因
出现此问题是由于下面的一组条件:
  • Microsoft CRM 设置星期天为 0。编号为 0 至 6 周日期。
  • Microsoft SQL Server 设置为 7 星期日。周日期编号 1 到 7。
在按星期分组时该服务活动报表,Microsoft SQL Server 不会将 0 解释为一周的天。
解决方案

修补程序信息

可以从 Microsoft 获得支持的修补程序。但是,此修补程序被用于解决本文所述的此问题。此修补程序仅应用于出现这一特定问题的系统。此修补程序可能会接受进一步的测试。因此,如果此问题没有对您造成严重的影响,我们建议您等待包含此修补程序的下一个软件更新。

是否可供下载此修补程序没有"提供修补程序下载"部分中,在这篇知识库文章的顶部。如果不会显示此部分,请联系 Microsoft 客户服务和支持以获取此修复程序。

注意如果出现其他问题,或者如果需要进行任何故障诊断,则您可能不得不创建单独的服务请求。将正常收取支持费用将应用于其他支持问题和不需要进行此特定的修补程序的问题。有关完整列表的 Microsoft 客户服务和支持的电话号码,或创建一个单独的服务请求,请访问下面的 Microsoft 网站:注意"提供修补程序下载"窗体所显示的此修复程序是可用的语言。如果您看不到您的语言,则是一个修复程序不能用于该语言。

安装信息

在运行 Microsoft CRM 3.0 服务器的计算机上安装此修补程序。

系统必备组件

没有要应用此修补程序需要任何先决条件。

删除信息

您不能删除此修补程序。

重新启动要求

在应用此修补程序后,会提示您重新启动计算机。

文件信息

此修补程序的英文版具有的文件属性 (或更新的文件属性) 在下表中列出。日期和时间对这些文件列出在协调世界时 (UTC)。当您查看文件信息时,将转换为本地时间。若要 UTC 与本地时间之间的时差使用控制面板中的日期和时间工具中的 时区 选项卡。
文件的名称文件版本文件大小日期时间
服务活动 volume.rdl不适用65,0292006 年一月 17 日08: 22
更多信息
有关用于描述 Microsoft 软件更新术语的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
824684用于描述 Microsoft 软件更新的标准术语的说明
887283Microsoft 企业解决方案 CRM 软件修补程序和更新包的命名标准
crm3 crm30 crm3.0

警告:本文已自动翻译

属性

文章 ID:913330 - 上次审阅时间:01/15/2015 08:55:30 - 修订版本: 1.7

Microsoft CRM 3.0

  • kbnosurvey kbarchive kbmt kbautohotfix kberrmsg kbbug kbmbsreports kbmbsmigrate kbqfe kbhotfixserver KB913330 KbMtzh
反馈