使用 Internet Explorer 7 访问网站时,收到指明所具有的 Internet Explorer 版本不是最新的错误消息

本文可用作中级计算机用户的入门参考。您可能会发现,事先将本文打印出来会更易于按步骤操作。
问题的症状
当您使用 Windows Internet Explorer 7 访问网站时,可能会收到错误消息,指明:
  • 您的 Internet Explorer 不是最新版本。
  • 该网站支持 Microsoft Internet Explorer 6 或更高版本。
即使 Internet Explorer 7 是最新版本的 Internet Explorer,也会出现此问题。
解决此问题的步骤
要解决此问题,请要求网站所有者将网站修改为能够正确检测 Internet Explorer 7。
变通解决此问题的步骤
某些网站设计成将 Internet Explorer 6 识别为 Internet Explorer 的最新版本。要变通解决此问题,您可以使用 User Agent String Utility。只有在访问无法识别 Internet Explorer 7 的网站时才应该使用此实用工具。完成对这些网站的访问后,请关闭此实用工具打开的所有 Internet Explorer 窗口。

步骤 1:下载 User Agent String Utility

要下载此实用工具,请按照下列步骤操作:
  1. 单击紧接着步骤 1c 提供的链接。
  2. 在“文件下载 - 安全警告”对话框中,单击“运行”。
  3. 在“Internet Explorer - 安全警告”对话框中,当系统询问是否要运行此软件时单击“运行”。然后,转到下一步安装 User Agent String Utility。
可以从 Microsoft 下载中心下载以下文件:

下载立即下载 User Agent String Utility 程序包。

发布日期:2006 年 8 月 4 日

有关如何下载 Microsoft 支持文件的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
119591 如何从联机服务获取 Microsoft 支持文件
Microsoft 已对此文件进行了病毒扫描。Microsoft 使用的是该文件发布时可以获得的最新病毒检测软件。该文件存储在安全性得到增强的服务器上,这些服务器可帮助防止对该文件进行未经授权的更改。

步骤 2:安装 User Agent String Utility
  1. 在安装向导的“欢迎使用 User Agent String Utility 安装程序”页上,单击“下一步”。
  2. 在“选择安装文件夹”页上,单击“下一步”。
  3. 在“确认安装”页上,单击“下一步”。

    该向导可能需要一至两分钟的时间来安装文件。
  4. 在“安装完成”页上,单击“关闭”退出向导。
步骤 3:使用 User Agent String Utility 访问网页
  1. 要启动 User Agent String Utility,请双击桌面上的“User Agent String Utility”图标。
  2. 在“Internet Explorer User Agent String Utility v2.0”对话框中,单击“更改设置”。

    这时会打开一个浏览器窗口。您可以完全按照使用 Internet Explorer 7 窗口的方式使用此浏览器窗口。
  3. 访问不能识别 Internet Explorer 7 的网站。完成之后关闭该实用工具打开的浏览器窗口。
ie7 ie7.0
属性

文章 ID:923196 - 上次审阅时间:04/23/2007 06:04:00 - 修订版本: 3.0

Windows Internet Explorer 7 for Windows Server 2003, Windows Internet Explorer 7 for Windows XP

  • kbtshoot kbprb kbexpertisebeginner kbceip KB923196
反馈