你目前正处于脱机状态,正在等待 Internet 重新连接

如何解决损坏的演示文稿在 PowerPoint 2007 中,PowerPoint 2010

重要说明:本文是由 Microsoft 机器翻译软件进行的翻译并可能由 Microsoft 社区通过社区翻译机构(CTF)技术进行后期编辑,或可能是由人工进行的翻译。Microsoft 同时向您提供机器翻译、人工翻译及社区后期编辑的文章,以便对我们知识库中的所有文章以多种语言提供访问。翻译的文章可能存在词汇、句法和/或语法方面的错误。Microsoft 对由于内容的误译或客户对内容的使用所导致的任何不准确、错误或损失不承担责任。

点击这里察看该文章的英文版: 927477
这篇文章的 Microsoft Office PowerPoint 2003 和 Microsoft PowerPoint 2002 版本,请参见 826810.
这篇文章的 Microsoft PowerPoint 2000 版本,请参见 207377.
概要
当您使用 Microsoft Office PowerPoint 2007 或 PowerPoint 2010 演示文稿时,您可能会遇到意外的行为。由于已损坏的演示文稿,则可能发生此问题。本文包含的分步方法有助于部分还原或完全还原您的演示文稿。
本文适用于初级和中级计算机用户。
您可能会发现如果先将本文打印,再按照步骤会变得更容易。
问题的症状
当您尝试打开或更改演示文稿损坏时,您可能会遇到下列症状:
  • 当您尝试打开的演示文稿时,您会收到以下错误消息之一:
    这不是一个 PowerPoint 演示文稿
    无法打开的文件所表示的类型 文件名.ppt
    找不到该文件的一部分。
  • 您会收到以下错误消息的类型:
    一般性保护错误
    非法指令
    无效页错误
    系统资源不足
    内存不足
若要确定是否有损坏的演示文稿的方法
有几种方法来帮助确定您是否有损坏的演示文稿。您可以尝试打开具有 PowerPoint 2007 安装中看到意外的行为是否发生在另一台计算机上的另一台计算机上的文件。您可以尝试在 PowerPoint 中创建一个新文件,并使用新的文件中是否发生了意外的行为,请参阅。本部分介绍如何使用现有的演示文稿和如何在 PowerPoint 来确定演示文稿是否具有相同的行为中创建一个新文件。

方法 1: 打开现有的演示文稿

  1. InPowerPoint 2007 单击Microsoft Office 按钮。<b00> </b00> 在 PowerPoint 2010 中单击文件菜单 ,然后单击打开
  2. 不同的演示文稿,请单击,然后单击打开
如果此演示文稿打开,并出现未损坏,则转到方法 3 本部分中。否则,请转到方法 2 来创建新的演示文稿。

方法 2: 创建新的演示文稿

步骤 1: 创建演示文稿

  1. 在 PowerPoint 2007 中单击Microsoft Office 按钮,然后单击新建。在 PowerPoint 2010 中,请单击文件菜单
  2. 在 PowerPoint 2007 中,请单击已安装 的模板,然后单击PowerPoint 2007 中引入。在 PowerPoint 2010 中单击文件菜单上, 单击新建, 示例模板,单击引入了 PowerPoint 2010。
  3. 单击创建。此过程将创建基于该模板的演示文稿。
  4. 在 PowerPoint 2007 中单击Microsoft Office 按钮,然后单击保存。在 PowerPoint 2010 中,请单击文件菜单,然后单击保存。
  5. 为演示文稿中,键入一个名称,然后单击保存
  6. 退出 PowerPoint。

步骤 2: 打开新的演示文稿

  1. 在 PowerPoint 2007 中单击Microsoft Office 按钮,然后单击打开。在 PowerPoint 2010文件菜单上,单击然后单击打开
  2. 新演示文稿,请单击,然后单击打开
如果您无法打开或保存的新演示文稿,请转到方法 3。如果不能创建新的演示文稿时,PowerPoint 将可能已损坏,必须进行修复。

方法 3: 一般故障诊断

步骤 1: 开始 Windows 在安全模式下

Windows Vista
  1. 从计算机中删除所有的软盘、 Cd 和 Dvd,然后重新启动计算机。
  2. 单击开始 开始按钮单击锁定,旁边的箭头,然后单击重新启动
  3. 使用以下过程之一:
    • 如果您的计算机安装了一个操作系统,则在计算机重新启动时按住 F8 键。Windows 徽标出现之前,您必须按 f8 键。如果出现 Windows 徽标,您必须再试一次通过等待直到出现 Windows 登录提示是,然后关闭并重新启动计算机。
    • 如果您的计算机有多个操作系统,请使用箭头键突出显示要在安全模式下启动的操作系统,然后按 f8 键。
  4. 高级启动选项屏幕上,使用箭头键选择安全模式,然后按 ENTER。
  5. 使用具有管理员权限的用户帐户登录到您的计算机上。
Windows XP
  1. 从计算机中删除所有的软盘、 Cd 和 Dvd,然后重新启动计算机。
  2. 单击开始,然后单击关闭
  3. 希望计算机做什么列表中,单击重新启动,然后单击确定
  4. 当您重新启动计算机,请按住 CTRL 键。
  5. 当您看到正在启动 Windows的消息,请按 f8 键,使用箭头键在开始菜单中,选择安全模式,然后按 ENTER。
如果以安全模式启动 Windows 后,演示文稿可以打开系统存在冲突阻止您打开演示文稿。

如果您无法打开演示文稿,或者损坏或奇怪的行为仍然存在,请参阅本文中的相应章节。
如果您无法打开演示文稿,请尝试的方法

方法 1: 将演示文稿拖到 PowerPoint 程序文件图标

Windows Vista
  1. 单击开始 开始按钮然后单击文档
  2. 开始搜索框中,键入%programfiles%\Microsoft Office\Office12 (PowerPoint 2007 年),然后按 enter 键。如果您有 PowerPoint 2010 安装类型%programfiles%\microsoft office\office14 (PowerPoint 2010 年),,然后按 enter 键。
  3. 在 Windows 资源管理器中查找 Powerpnt.exe 图标。
  4. 将损坏的演示文稿图标从一个窗口拖动到另一窗口中的 Powerpnt.exe 图标。
Windows XP
  1. 单击开始,然后单击运行
  2. 打开框中,键入 %userprofile%\My 文档.
  3. 单击确定
  4. 单击开始,然后单击运行
  5. 打开框中,键入 %programfiles%\Microsoft Office\Office12 (PowerPoint 2007 年)。如果您有安装 PowerPoint 2010 键入%programfiles%\Microsoft Office\Office14
  6. 单击确定
  7. 在 Windows 资源管理器中查找 Powerpnt.exe 图标。
  8. 将损坏的演示文稿图标从一个窗口拖动到另一窗口中的 Powerpnt.exe 图标。
PowerPoint 会尝试打开的演示文稿。如果 PowerPoint 演示文稿未打开,请转到方法 2。

方法 2: 双击 Windows 资源管理器中的演示文稿图标

Windows Vista
  1. 单击开始 开始按钮然后单击文档
  2. 双击演示文稿图标。
PowerPoint 2007 将尝试打开的演示文稿。如果 PowerPoint 2007 中没有打开的演示文稿,请转到方法 3。Windows XP 中
  1. 单击开始,然后单击运行
  2. 打开框中,键入 %userprofile%\My 文档.
  3. 单击确定
  4. 双击演示文稿图标。
PowerPoint 2007 将尝试打开的演示文稿。如果 PowerPoint 2007 中没有打开的演示文稿,请转到方法 3。

方法 3: 尝试将幻灯片插入空白演示文稿

步骤 1: 创建一个空白演示文稿

  1. 在 PowerPoint 2007 中,单击Microsoft Office 按钮,然后单击新建。在 PowerPoint 2010 中,请单击文件菜单上,然后单击新建
  2. 空白演示文稿,请单击,然后单击创建

    此过程将创建一个空白标题幻灯片。重新创建演示文稿后,您可以稍后删除此幻灯片。

步骤 2: 插入幻灯片为损坏的演示文稿

  1. 主页选项卡上,单击箭头旁边新幻灯片 幻灯片组,然后单击重用幻灯片
  2. 重用幻灯片任务窗格中,单击浏览。损坏的演示文稿,请单击,然后单击打开
  3. 用鼠标右键单击其中一个重用幻灯片任务窗格中的幻灯片,然后单击全部插入

    如果此操作成功,除幻灯片母版上,损坏的演示文稿中的所有幻灯片都插入到新演示文稿。
  4. 在 PowerPoint 2007 中单击Microsoft Office 按钮,然后单击保存。在 PowerPoint 2010文件菜单上,单击然后单击保存
  5. 键入该演示文稿的新名称,然后单击保存

步骤 3: 将损坏的演示文稿作为模板应用

如果演示文稿显示不正常您期望的方式重试这些步骤后,请尝试将损坏的演示文稿作为模板应用。若要执行此操作,请按照下列步骤操作:
  1. 单击Microsoft Office 按钮,然后单击另存为
  2. 键入该演示文稿的新名称,然后单击保存

    这将使已恢复的演示文稿的备份副本,以防损坏的演示文稿损坏此新的演示文稿。
  3. 设计选项卡上的主题组中,单击高级,然后单击浏览主题
  4. 损坏的演示文稿,请单击,然后单击应用。损坏的演示文稿的幻灯片母版替换新幻灯片母版。
注意:如果开始时遇到意外的情况,在执行这些步骤后,模板可能已损坏演示文稿。在这种情况下,使用备份副本重新创建母版幻灯片。

如果同样的损坏或原始演示文稿的奇怪行为,表现出新的演示文稿的备份副本,则转到方法 4。

方法 4: 尝试打开演示文稿的临时文件版本

编辑演示文稿时,PowerPoint 会创建该文件的临时副本。此临时文件被命名为 PPT####.tmp。

注意: #### 表示一个随机的四位数字。

此临时文件可能驻留在与演示文稿相同的文件夹中。或者,它可能位于临时文件文件夹中。

步骤 1: 查看文档文件夹中的临时文件

Windows Vista
  1. 单击开始 开始按钮然后单击文档
  2. 查找名为 PPT 文件 ####.tmp。
Windows XP
  1. 单击开始,然后单击运行
  2. 打开框中,键入 %userprofile%\My 文档.
  3. 单击确定
  4. 查找名为 PPT 文件 ####.tmp。
如果找不到该文件,您必须搜索它。若要执行此操作,请转到步骤 2。

如果您找到了该文件,请转到步骤 3。

步骤 2: 搜索临时文件

Windows Vista
  1. 单击开始 开始按钮然后键入 PPT*.tmp开始搜索框中。
  2. 按 enter 键。
Microsoft XP Windows
  1. 单击开始,然后单击搜索
  2. 名称框中或在搜索文件或文件夹名称框中,键入 PPT*.tmp.
  3. 查找范围框中,单击我的电脑,然后单击立即查找立即搜索

步骤 3: 重命名该文件,然后再在 PowerPoint 中打开该文件

  1. 用鼠标右键单击该文件,然后单击重命名
  2. 将旧文件的扩展名从.tmp 更改为.pptx 这样的文件的名称类似于以下文件名:
    PPT ####.pptx
  3. 开始 PowerPoint。
  4. 在 PowerPoint 2007 中单击Microsoft Office 按钮,然后单击打开。在 PowerPoint 2010文件菜单上,单击然后单击打开
  5. 浏览到包含已重命名的文件的文件夹。
  6. 尝试在 PowerPoint 中打开该文件。
注意:多个文件可能对应于创建的最后一次保存演示文稿的临时文件中。在这种情况下,您可能必须打开每个文件,以查看是否有该演示文稿的临时副本。

如果没有临时文件或临时文件显示相同类型的损坏或奇怪的行为,请转到方法 5。

方法 5: 请在 PowerPoint 播放器中打开该演示文稿。

Windows Vista

步骤 1: 访问 PowerPoint 查看器下载网页

  1. 单击开始 开始按钮.
  2. 开始搜索框中键入 iexplore.exe然后按 enter 键。
  3. 请访问下面的 Microsoft Web 站点 PowerPoint 2007 查看器
  4. http://www.microsoft.com/downloads/en/details.aspx?FamilyID=048dc840-14e1-467d-8dca-19d2a8fd7485
  5. 请访问下面的 Microsoft Web 站点 PowerPoint 2010 查看器
  6. http://www.microsoft.com/downloads/en/details.aspx?FamilyID=cb9bf144-1076-4615-9951-294eeb832823

步骤 2: 设置 PowerPoint 查看器

  1. 单击下载
  2. 单击运行
  3. 单击以选中单击此处可接受 Microsoft 软件许可条款复选框,然后单击继续
  4. 单击确定
    用户帐户控制权限 如果提示您输入管理员密码或进行确认,键入密码,或单击继续

步骤 3: 在 PowerPoint Viewer 中打开损坏的演示文稿

  1. 单击开始 开始按钮然后单击所有程序
  2. 单击Microsoft Office PowerPoint 查看器 [2007年/2010]
  3. 单击接受
  4. 损坏的演示文稿,请单击,然后单击打开
如果可以打开演示文稿在 PowerPoint 2007 中查看器中,PowerPoint 2007 安装到计算机上的副本可能已损坏。

如果无法打开演示文稿在 PowerPoint 2007 中查看器中,转到方法 6。

方法 6: 创建损坏的演示文稿的副本

步骤 1: 打开我的文档

Windows Vista
  1. 单击开始,然后单击文档
Windows XP
  1. 单击开始,然后单击运行
  2. 打开框中,键入 %userprofile%\My 文档.
  3. 单击确定

步骤 2: 复制损坏的演示文稿

  1. 用鼠标右键单击该演示文稿,然后单击复制
  2. 在 Windows 资源管理器窗口中的空白位置右键单击,然后单击粘贴
如果您不能复制该文件,该文件可能已损坏,或该文件可以位于计算机的硬盘的损坏部件。在这种情况下,请转到方法 7。

如果您可以将复制该文件,请在 PowerPoint 2007 中打开损坏的演示文稿的副本。如果不能打开损坏的演示文稿的副本,请试着重复方法 1 至方法 5"方法中,如果您无法打开演示文稿,请尝试"部分中使用损坏的演示文稿的副本。

方法 7: 运行磁盘扫描程序会在硬盘驱动器上

Windows Vista
  1. 退出所有打开的程序。
  2. 单击开始,然后单击计算机
  3. 用鼠标右键单击硬盘包含损坏的演示文稿。
  4. 单击属性,然后单击工具选项卡。
  5. 错误检查,单击立即检查
  6. 单击以选中自动修复文件系统错误复选框。
  7. 单击以选中扫描并试图恢复坏扇区复选框。
  8. 单击开始
Windows XP
  1. 退出所有打开的程序。
  2. 在 Windows 桌面上,双击我的电脑
  3. 用鼠标右键单击硬盘包含损坏的演示文稿。
  4. 单击属性,然后单击工具选项卡。
  5. 错误检查,单击立即检查
  6. 单击以选中自动修复文件系统错误复选框。
  7. 单击以选中扫描并试图恢复坏扇区复选框。
  8. 单击开始
注意:磁盘扫描程序可以验证演示文稿是交叉链接,并可能会修复该演示文稿。但是,这不是保证 PowerPoint 2007 中将能够读取该演示文稿。
如果可以打开损坏的演示文稿,请尝试的方法

方法 1: 尝试将损坏的演示文稿作为模板应用

步骤 1: 创建一个空白演示文稿

  1. 在 PowerPoint 2007 中,单击Microsoft Office 按钮,然后单击新建。在 PowerPoint 2010 中,请单击文件菜单上,然后单击新建
  2. 空白演示文稿,请单击,然后单击创建。此过程将创建一个空白标题幻灯片。重新创建演示文稿后,您可以稍后删除此幻灯片。

步骤 2: 将损坏的演示文稿插入空白演示文稿

  1. 主页选项卡上,单击中的幻灯片组中,新的幻灯片旁边的箭头,然后单击重用幻灯片
  2. 重用幻灯片任务窗格中,单击浏览。选择损坏的演示文稿,然后单击打开
  3. 用鼠标右键单击其中一个重用幻灯片任务窗格中的幻灯片,然后单击全部插入。

    如果此操作成功,除幻灯片母版上,损坏的演示文稿中的所有幻灯片都插入到新演示文稿。
  4. 单击Microsoft Office 按钮,然后单击保存
  5. 键入该演示文稿的新名称,然后单击保存

步骤 3: 将损坏的演示文稿作为模板应用

如果演示文稿显示不正常您期望的方式重试这些步骤后,请尝试将损坏的演示文稿作为模板应用。若要执行此操作,请按照下列步骤操作:
  1. 在 PowerPoint 2007 中,单击Microsoft Office 按钮,然后单击另存为。在 PowerPoint 2010 中,请单击文件菜单上,然后单击另存为
  2. 键入该演示文稿的新名称,然后单击保存

    这将使已恢复的演示文稿的备份副本,以防损坏的演示文稿损坏此新的演示文稿。
  3. 设计选项卡上的主题组中,单击高级,然后单击浏览主题
  4. 选择损坏的演示文稿,然后单击应用。损坏的演示文稿的幻灯片母版替换新幻灯片母版。
注意:如果开始时遇到意外的情况,在执行这些步骤后,模板可能已损坏演示文稿。在这种情况下,使用备份副本重新创建母版幻灯片。

如果新的演示文稿的备份副本仍然出现损坏或奇怪的行为,则转到方法 2。

方法 2: 将幻灯片从损坏的演示文稿转移到一个空演示文稿

步骤 1: 创建一个空白演示文稿

  1. 开始 PowerPoint 2007,单击Microsoft Office 按钮,然后单击打开。在 PowerPoint 2010 中,请单击文件菜单上,然后单击打开
  2. 找到损坏的演示文稿,然后单击打开
  3. 在 PowerPoint 2007 中,单击Microsoft Office 按钮,然后单击新建。在 PowerPoint 2010 中,请单击文件菜单上,然后单击新建
  4. 空白演示文稿,请单击,然后单击创建。此过程将创建一个空白标题幻灯片。

步骤 2: 将幻灯片从损坏的演示文稿复制到新演示文稿

  1. 视图选项卡上,单击幻灯片浏览。如果在切换视图时收到错误信息,请尝试使用大纲视图。
  2. 单击您要复制的幻灯片。
  3. 主页选项卡上,单击复制

    注意:如果您想要同时复制多张幻灯片,请按住 SHIFT 键,然后单击每个要复制的幻灯片。
  4. 切换到新的演示文稿。在窗口选项卡上的视图组中,单击交换机窗口,然后单击您在步骤 2 中创建的演示文稿。
  5. 视图选项卡上,单击幻灯片浏览
  6. 主页选项卡上,单击粘贴
  7. 直到传送整个演示文稿,请重复步骤 2a 至 2f。
注意:在某些情况下,一张损坏的幻灯片可能导致整个演示文稿出现问题。如果将幻灯片复制到演示文稿后,您会发现新的演示文稿中的意外的行为,则该幻灯片很可能已损坏。重新创建该幻灯片或幻灯片的各个部分复制到新的幻灯片。

如果新的演示文稿显示损坏或奇怪的行为,请转到方法 3。

方法 3: 将演示文稿另存为丰富文本格式 (RTF) 文件

如果整个演示文稿损坏,则恢复演示文稿的唯一办法可能是将演示文稿另存为丰富文本格式 (RTF) 文件。这种方法,如果成功,将恢复仅在大纲视图中显示的文本。

步骤 1: 以 rtf 格式的文件格式保存演示文稿

  1. 打开的演示文稿。
  2. 单击Microsoft Office 按钮,单击另存为,然后单击其他设置
  3. 将文件另存为类型列表中,单击Outline/RTF(*.rtf)
  4. 文件名框中,键入所需,选取要在其中保存该演示文稿的位置的名称,然后单击保存
  5. 关闭该演示文稿。
注意:所有的图形、 图表或其他原始演示文稿中的文本不会保存在.rtf 文件中。

步骤 2: 在 PowerPoint 中打开的.rtf 文件

  1. 单击Microsoft Office 按钮,然后单击打开
  2. 文件类型列表中单击所有大纲所有文件
  3. 单击您在步骤 1d 中保存该.rtf 文件,然后单击打开
这将重新创建原始演示文稿的大纲视图所基于的演示文稿。
ppt powerpt powerpnt 页错误无效的非法行为很奇怪崩溃崩溃断开 gpf ipf 破坏损坏至 t 射球已损坏演示文稿疑难解答损坏损坏 inf

警告:本文已自动翻译

属性

文章 ID:927477 - 上次审阅时间:03/14/2015 10:25:00 - 修订版本: 3.0

Microsoft Office PowerPoint 2007, Microsoft PowerPoint 2010

  • kbhowto kbopenfile kbnewfile kbcorrupt kberrmsg kbexpertisebeginner kbtshoot kbfix kbmt KB927477 KbMtzh
反馈