在 4.0 动态 CRM 中查看工作流时的错误消息:"找不到请求的记录或您没有足够的权限来查看它"

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症状
请考虑以下方案中 Microsoft 动态 CRM 4.0:
  • 若要自动将新潜在顾客给 Microsoft 动态 CRM 用户的潜在顾客实体上创建一个工作流。
  • 组织的导入新的 Microsoft 动态 CRM 环境。在这种环境中,您必须重新映射到一个新的 Active Directory 用户 Microsoft 动态 CRM 用户。
  • 您创建一个新的潜在顾客触发工作流在尝试将其分配给硬编码 Microsoft 动态 CRM 的用户。
  • 查看工作流。
在这种情况下您会收到以下错误消息:
平台错误
====================================
找不到请求的记录或您没有足够的权限来查看它。
用户错误
====================================
找不到请求的记录或您没有足够的权限来查看它。
原因
因为工作流 pluginassemblybase 表中存储为编译后的数据记录,则会出现此问题。导入过程不会反编译更正到系统用户实体可能存在于工作流程规则中的任何引用这些记录。此外,导入过程不会执行包含对系统用户实体的引用将现有的工作流程进程实例。 因此之前组织完全导入,,不能运行这些实例。
解决方案
对于 Microsoft 动态 CRM 4.0 中最新的累积更新汇总解决此问题。有关详细的信息请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
949256Microsoft CRM 4.0 动态更新和修补程序
状态
Microsoft 已经确认这是在"适用于"一节中列出的 Microsoft 产品中的问题。
更多信息
有关软件更新术语的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
824684用于描述 Microsoft 软件更新的标准术语的说明
887283Microsoft 企业解决方案 CRM 软件修补程序和更新包的命名标准

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属性

文章 ID:951640 - 上次审阅时间:01/16/2015 17:43:18 - 修订版本: 3.0

Microsoft Dynamics CRM 4.0

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反馈
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