创建或运行宏

在 Word 中,可以通过创建和运行宏自动执行常用任务。 宏是一系列命令和说明,可以组合为单个命令来自动完成任务。

若要节省花费在经常执行的任务上的时间,可以将多个步骤捆绑到一个宏中。 首先,需要录制宏。 然后,您可以通过单击“快速访问”工具栏上的按钮或按键组合来运行该宏。 具体取决于您的设置方式。

  1. 单击“视图”>“”>“录制宏”。

    “录制宏”命令

  2. 键入宏的名称。

    “宏名”框

  3. 若要在创建的所有新文档中使用此宏,请确保“将宏保存在”框中显示了“所有文档 (Normal.dotm)”。

    用于选择宏存储位置的框

  4. 若要通过单击按钮运行宏,请单击“按钮”。

    单击以将该宏指定到某个按钮

  5. 单击新宏(其名称类似于 Normal.NewMacros.<您的宏名>),然后单击“添加”。

    宏和“添加”按钮

  6. 单击“修改”。

    在“自定义快速访问工具栏”框中修改按钮

  7. 选择按钮图像,键入所需的名称,然后单击两次“确定”。

    “修改按钮”框中的按钮选项

  8. 现在,便可以开始录制步骤了。 单击命令或者按下任务中每个步骤对应的键。 Word 将会录制您的单击和键击动作。

    注意: 录制宏时,使用键盘选择文本。 宏不会录制使用鼠标所做的选择。

  9. 若要停止录制,请单击“视图”>“”>“停止录制”。

    “停止录制”命令

宏的按钮将显示在快速访问工具栏上。

快速访问工具栏上的“宏”按钮

若要运行该宏,请单击其按钮。

  1. 单击“视图”>“”>“录制宏”。

    “录制宏”命令

  2. 键入宏的名称。

    “宏名”框

  3. 若要在创建的所有新文档中使用此宏,请确保“将宏保存在”框中显示了“所有文档 (Normal.dotm)”。

    用于选择宏存储位置的框

  4. 若要通过按键盘快捷方式运行宏,请单击“键盘”。

    单击以将该宏指定到某个键盘快捷方式

  5. 在“请按新快捷键”框中键入组合键。

  6. 检查该组合键是否已指定给其他项目。 如果已被指定,请尝试其他组合键。

  7. 若要在创建的所有新文档中使用此键盘快捷方式,请确保“将更改保存在”框中显示了“Normal.dotm”。

  8. 单击“指定”。

  9. 现在,便可以开始录制步骤了。 单击命令或者按下任务中每个步骤对应的键。 Word 将会录制您的单击和键击动作。

    注意: 录制宏时,使用键盘选择文本。 宏不会录制使用鼠标所做的选择。

  10. 若要停止录制,请单击“视图”>“”>“停止录制”。

    “停止录制”命令

若要运行该宏,请按相应的键盘快捷键。

若要运行宏,请单击“快速访问”工具栏上的按钮、按键盘快捷键,也可以从“”列表运行宏。

  1. 单击“视图”>“”>“查看宏”。

    “查看宏”命令

  2. 在“宏名”下面的列表中,单击要运行的宏。

  3. 单击“运行”

若要在所有文档中使用从某一个文档录制的宏,请将该宏添加到 Normal.dotm 模板。

  1. 打开包含该宏的文档。

  2. 单击“视图”>“”>“查看宏”。

    “查看宏”命令

  3. 单击“管理器”。

    “查看宏”框中的“管理器”按钮

  4. 单击要添加到 Normal.dotm 模板的宏,然后单击“复制”。

  1. 单击“文件”>“选项”>“自定义功能区”。

  2. “从下列位置选择命令”下,单击“宏”

  3. 单击所需的宏。

  4. 在“自定义功能区”下,单击要在其中添加该宏的选项卡和自定义组。

如果没有自定义组,请单击“新建组”。 然后单击“重命名”并键入自定义组的名称。

  1. 单击“添加”

  2. 单击“重命名”以选择该宏的图像并键入所需的名称。

  3. 单击两次“确定”。

  1. “开发工具”选项卡上的“代码”组中,单击“宏”

  2. 在“宏名”框中,键入宏名称。

    注意: 如果在 Word 中为新宏提供与内置宏相同的名称,新的宏操作将替换内置宏。 若要查看内置宏的列表,请单击"宏"列表中的 "Word命令 "。

  3. "宏"列表中 ,单击要存储宏的模板或文档。

    若要使宏在所有文档中可用,请务必单击"Normal.dotm"。

  4. 单击 "创建 "打开"Visual Basic编辑器"。

打开"Visual Basic编辑器"后,可能需要详细了解如何Visual Basic for Applications。 有关详细信息,请单击"帮助Visual Basic上的"Microsoft 帮助"或按 F1。

可以录制一系列操作,也可以从头开始编写宏,Visual Basic for Applications中输入 Visual Basic 编辑器 。

注意: 若要在 Office Word 2007 宏,需要显示"开发 工具" 选项卡。

  1. 单击“Microsoft Office 按钮Office 按钮图像 ,然后单击“Word 选项”。

  2. 单击“常规”。

  3. "使用 Word 的顶级选项"下,选中"在功能区 中显示开发工具" 选项卡复选框。

    注意: 功能区是 Microsoft Office Fluent 用户界面的一个组件。

  1. “开发工具”选项卡上的“代码”组中,单击“录制宏”

    “开发工具”选项卡上的“代码”组
  2. 在“宏名”框中,键入宏名称。

    注意: 如果为新宏提供的名称与 Office Word 2007 中的内置宏相同,则新的宏操作将替换内置宏。 若要查看内置宏的列表,请在"开发工具"选项卡上的"代码"组中,单击"宏"。 在"宏"列表中,单击"Word 命令"。

  3. "将宏存储在模板 中,单击要存储宏的宏或文档。

    重要: 若要使宏在所有文档中可用,请务必单击"Normal.dotm"。

  4. "说明 "框中,键入宏的说明。

  5. 请执行下列操作之一:

    • 开始录制    若要开始录制宏而不将其分配给快速访问工具栏上的按钮或快捷键,请单击"确定"。

    • 创建按钮    若要将宏分配到快速访问工具栏上的按钮,请执行下列操作:

      1. 单击"按钮"。

      2. "自定义快速访问工具栏" (,选择要) 宏添加到快速访问工具栏的文档或所有文档。

        重要: 若要使宏在所有文档中可用,请务必单击"Normal.dotm"。

      3. "从对话框中选择命令"下,单击要录制的宏,然后单击"添加"。

      4. 若要自定义按钮,请单击"修改"。

      5. "符号"下,单击要用于按钮的符号。

      6. "显示名称 "框中,键入要显示的宏名称。

      7. 单击 "确定 "两次,开始录制宏。

        选择的符号会显示在快速访问工具栏中。 指向符号时,将显示键入的名称。

    • 指定键盘快捷方式    若要将宏分配到键盘快捷方式,请执行下列操作:

      1. 单击“键盘”。

      2. 在" 命令 "框中,单击要录制的宏。

      3. 在"按新快捷键"框中,键入想要的键序列,然后单击"分配"。

      4. 单击 "关闭 "开始录制宏。

  6. 执行要包括在宏中的操作。

    注意: 录制宏时,可以使用鼠标单击命令和选项,但不能选择文本。 必须使用键盘选择文本。 有关使用键盘选择文本的信息,请参阅选择 文本

  7. 若要停止录制操作,请单击" 代码"组中 "停止 录制 "。

更改宏的键盘快捷方式

  1. 单击“Microsoft Office 按钮Office 按钮图像 ,然后单击“Word 选项”。

  2. 单击“自定义”。

  3. 在"键盘快捷方式"旁边,单击"自定义"。

  4. 在"类别"列表中,单击"宏"。

  5. "宏" 列表中,单击要更改的宏。

  6. "按新快捷键" 框中,键入要选择的键组合。

  7. 选中 "当前 密钥"框,确保未分配已用于执行其他任务的键组合。

  8. "将更改保存在 列表中"列表中,单击与要运行宏的地方匹配的选项。

    重要: 若要使宏在所有文档中可用,请务必单击"Normal.dotm"。

  9. 单击“关闭”。

  1. “开发工具”选项卡上的“代码”组中,单击“宏”

    “开发工具”选项卡上的“代码”组

  2. 在"宏名称 "下的列表中,单击要运行的宏。

  3. 单击“运行”

  1. “开发工具”选项卡上的“代码”组中,单击“宏”

    “开发工具”选项卡上的“代码”组

  2. 在“宏名”框中,键入宏名称。

    注意: 如果为新宏提供的名称与 Office Word 2007 中的内置宏相同,则新的宏操作将替换内置宏。 若要查看内置宏的列表,请单击"宏"列表中的 "Word命令 "。

  3. "宏"列表中 , 模板 宏的宏或文档。

    若要使宏在所有文档中可用,请务必单击"Normal.dotm"。

  4. 单击 "创建 "打开"Visual Basic编辑器"。

打开"Visual Basic编辑器"后,可能需要详细了解如何Visual Basic for Applications。 有关详细信息,请单击"帮助Visual Basic上的"Microsoft 帮助"或按 F1。

若要快速完成经常执行的任务,在桌面版本的 Word 中,只需单击一次即可将步骤捆绑到运行的宏中。 在 Word 网页版 中,必须手动逐步完成此类任务。

如果您有 Word,请首先单击 "在 Word 中打开 "以在 Word 中打开文档。

"在桌面应用中打开"命令的图像

然后按照桌面版本的 Word 的说明 进行操作

在 Word 中运行宏并保存文档时,在 中重新打开文档时,会看到宏 Word 网页版 。

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

×