创建新数据库

本文介绍启动和 Access 数据库的基本过程,该数据库将用于台式计算机,而不是 Web。 其中介绍了如何使用模板创建桌面数据库,以及如何通过创建自己的表、窗体、报表和其他数据库对象从头开始构建数据库。 此外,还介绍了一些可用于将现有数据放入新数据库的技术。

本文内容

概述

首次启动 Access 时,或者如果关闭数据库时未关闭 Access,Microsoft Office Backstage 视图。

Backstage 视图是一个起点,可以从中创建新数据库、打开现有数据库、查看 Office.com 中的精选内容 - 可以使用 Access 对数据库文件或数据库外部(而不是在数据库内)执行的任何操作。

创建数据库

打开 Access 时,Backstage 视图会显示 "新建" 选项卡。 " 新建 "选项卡提供了几种创建新数据库的方法:

  • 空白数据库    如果需要,可以从头开始。 如果具有非常具体的设计要求,或者有需要容纳或合并的现有数据,则这是一个不错的选择。

  • 随 Access 一起安装的模板    如果你要启动新项目并且希望一个头条开始,请考虑使用模板。 Access 默认安装了多个模板。

  • 来自 Office.com    除了 Access 的模板外,还可以在 Office.com 上找到更多模板。 甚至不需要打开浏览器,模板可从"新建" 选项卡 获得。

添加到数据库

使用数据库后,可以添加字段、表或应用程序部件。

应用程序部件是一项功能,可让你将多个相关的数据库对象一起使用,就像它们是一个一样。 例如,应用程序部件可能包含一个表和一个基于该表的窗体。 可以使用应用程序部件同时添加表和窗体。

还可以创建查询、窗体、报表、宏 - 用于处理的所有数据库对象。

使用模板创建数据库

Access 附带了各种模板,可以像现在一样或作为起点使用。 模板是一个随时可供使用的数据库,其中包含执行特定任务所需的所有表、查询、窗体、宏和报表。 例如,可以使用一些模板来跟踪问题、管理联系人或保留费用记录。 某些模板包含一些示例记录,以帮助演示其用途。

如果其中一个模板符合你的需求,则使用它通常是启动数据库的最快方式。 但是,如果另一个程序中有要导入 Access 的数据,你可能会决定最好创建一个数据库,而不使用模板。 模板已定义数据结构,可能需要大量工作才能使现有数据适应模板的结构。

  1. 如果数据库已打开,请在"文件"选项卡上单击"关闭"。 Backstage 视图显示" 新建" 选项卡。

  2. "新建"选项卡中提供了多组模板,其中一些模板内置于 Access 中。 可以从 Office.com 下载其他模板。 有关详细信息,请参阅本文的下一部分。

  3. 选择想要使用的模板。

  4. Access 在"文件名"框中为数据库建议文件名 - 如果需要,可以更改文件名。 若要将数据库保存在与文件名框下方显示的文件夹不同的文件夹中,请单击 备用文字 ,浏览到要保存该数据库的文件夹,然后单击"确定"。 (可选)可以创建数据库并链接到 SharePoint 网站。

  5. 单击“创建”

    Access 从选择的模板创建数据库,然后打开数据库。 对于许多模板,将显示一个窗体,可在其中开始输入数据。 如果模板包含示例数据,则可以通过单击记录框 (左侧的底纹框或条形中的记录选择器删除每条) ,然后执行以下操作:

    在“开始”选项卡上的“记录”组中,单击“删除”。 按钮图像

  6. 若要开始输入数据,请单击窗体上的第一个空单元格,然后开始键入。 使用 导航窗格 浏览你可能想要使用的其他窗体或报表。 某些模板包括一个导航窗体,可用于在不同的数据库对象之间移动。

有关使用模板的信息,请参阅"使用模板创建 Access 桌面数据库"一文

返回页首

创建数据库而不使用模板

如果对使用模板感兴趣,可以通过构建自己的表、窗体、报表和其他数据库对象来创建数据库。 在大多数情况下,这涉及以下一项或两项:

  • 在创建新数据库时创建的表中输入、粘贴或导入数据,然后使用"创建"选项卡上的"表"命令使用创建的新表重复该过程。

  • 从其他源导入数据,并创建过程中的新表。

创建空白数据库

  1. 在"文件"选项卡上,单击"新建",然后单击"空白数据库"。

  2. 在"文件名"框中 键入 文件名。 若要将文件的位置从默认值更改为"浏览",请单击"浏览"以将数据库 备用文字 (放在"文件名"框) 旁,浏览到新位置,然后单击"确定"。

  3. 单击“创建”

    Access 使用名为 Table1 的空表创建数据库,然后在数据表视图中打开 Table1。 光标位于"单击以添加"列的第 一个空单元格 中。

  4. 开始键入以添加数据,也可以粘贴另一个源的数据,如"将数据从另一个源复制到 Access 表"部分中所述

在数据表视图中输入数据的设计与在 Excel 工作表中操作非常相似。 输入数据时将创建表结构。 向数据表添加新列时,表中将定义一个新字段。 Access 根据输入数据类型自动设置每个字段的字段名称。

如果目前不想在 Table1 中输入数据,请单击"关闭" 按钮图像 。 如果对表进行了任何更改,Access 会提示保存更改。 单击"是"保存更改,单击"否"放弃更改,或单击"取消"使表保持打开状态。

提示:  Access 在 [安装驱动器]:\Program Files\Microsoft Office\Templates\1033\Access\ 的文件夹中查找名为 Blank.accdb 的文件。 如果存在 ,Blank.accdb 是所有新空白数据库的模板。 它包含的任何内容都由所有新的空白数据库继承。 这是分发默认内容(例如部件号或公司免责声明和策略)的一个好方法。

重要: 如果关闭 Table1 但不至少保存一次,Access 会删除整个表,即使已输入数据。

添加表格

可以使用"创建"选项卡上的"表"组中的命令将新表添加到现有数据库。

Access 功能区图像

从数据表视图开始创建表    在数据表视图中,可以立即输入数据,让 Access 在后台构建表结构。 字段名称按数字 (字段 1、字段 2 等) ,Access 根据输入的数据自动设置每个数据类型字段的字段名称。

  1. 在“创建”选项卡上的“”组中,单击“”。 按钮图像

    Access 将创建表,并选择"单击以添加"列中 的第一个空 单元格。

  2. 在" 字段" 选项卡上的"添加 &" 组中,单击要添加的字段类型。 如果看不到想要的类型,请单击"更多字段" 按钮图像

  3. Access 会显示常用字段类型的列表。 单击想要的字段类型,Access 会将新字段添加到插入点的数据表。

    可以通过拖动字段来移动该字段。 在数据表拖动字段时,将显示垂直插入栏,该字段将放置在该位置。

  4. 若要添加数据,请开始键入第一个空单元格,或粘贴另一个源的数据,如"将数据从另一个源复制到 Access 表"部分中所述

  5. 若要重命名列 (字段) ,请双击列标题,然后键入新名称。

    应该为每个字段提供一个有意义的名称,以便当在"字段列表"窗格中看到该字段时 ,可以判断它包含的内容

  6. 若要移动列,请单击其标题以选择该列,然后将该列拖动到想要的位置。 还可以选择多个连续列,然后将其一次拖动到新位置。 若要选择多个连续列,请单击第一列的列标题,然后在按住 SHIFT 的同时单击最后一列的列标题。

从设计视图开始创建表    在设计视图中,首先创建表结构。 然后切换到数据表视图以输入数据,或通过使用其他某种方法(如粘贴或导入)输入数据。

  1. 在“创建”选项卡上的“”组中,单击“表设计”。 按钮图像

  2. 对于表中的每个字段,请在"字段名称"列中键入名称,然后从数据类型列表中选择一个名称。

  3. 如果需要,可以在"说明"列中键入每个 字段 的说明。 然后,当光标位于数据表视图中的该字段时,说明会显示在状态栏上。 说明还用作窗体或报表上通过拖动字段列表窗格中的字段创建的任何控件的状态栏文本,以及使用窗体向导或报表向导时为该字段创建的任何控件的状态栏文本。

  4. 添加所有字段后,保存表:

    • 在“文件”选项卡上,单击“保存”。

  5. 通过切换到数据表视图并单击第一个空单元格,你随时都可以开始在表中键入数据。 还可以粘贴另一个源的数据,如"将数据从另一个源复制到 Access 表 "部分中所述

在设计视图中设置字段属性    无论表的创建方式如何,都建议检查和设置字段属性。 虽然某些属性在数据表视图中可用,但某些属性只能在设计视图中设置。 若要切换到设计视图,请右键单击导航窗格中的表,然后单击"设计视图"。 若要查看字段的属性,请单击设计网格中的字段。 这些属性显示在设计网格下方的"字段属性 "下

若要查看每个字段属性的说明,请单击该属性并阅读"字段属性"下属性列表旁边的 框中的说明。 可以通过单击"帮助"按钮获取更多详细信息。

下表描述了一些经常调整的字段属性。

属性

说明

字段大小

对于文本字段,此属性设置可存储在字段中的最大字符数。 最大值为 255。 对于"数字"字段,此属性设置要存储在长整型 (双精度型等值中的) 。 对于最高效的数据存储,建议分配数据所需的最小空间量。 如果需要更改,以后可以向上调整值。

格式

此属性设置数据的显示方式。 它不会影响实际数据,因为它存储在字段中。 可以选择预定义格式或输入自定义格式。

输入掩码

使用此属性为将在此字段中输入的所有数据指定模式。 这有助于确保正确输入所有数据,并且它包含所需的字符数。 有关构建输入掩码的帮助,请单击 “生成器”按钮 框的右侧。

默认值

使用此属性指定每次添加新记录时将显示在此字段中的默认值。 例如,如果有一个"日期/时间"字段,其中始终要记录添加记录的日期,可以输入"日期 () " (不带引号) 作为默认值。

必需

此属性设置此字段中是否需要值。 如果将此属性设置为 "是",则 Access 不允许添加新记录,除非为此字段输入值。

返回页首

将数据从另一个源复制到 Access 表

如果数据当前存储在其他程序(如 Excel)中,您可以将其复制并粘贴到 Access 表中。 一般情况下,如果数据已分列,这效果最佳,因为它们位于 Excel 工作表中。 如果数据位于文字处理程序中,最好使用选项卡分隔数据列,或在复制数据之前将数据转换为文字处理程序中的表格。 如果数据需要任何编辑或操作 (例如,将全名分隔为名字和姓氏) ,可能需要在复制数据之前执行此操作,尤其是不熟悉 Access 时。

将数据粘贴到空表中时,Access 会数据类型字段的数据类型设置每个字段的索引。 例如,如果粘贴的字段只包含日期值,Access 将日期/时间数据类型应用于该字段。 如果粘贴的字段只包含"是"和"否"字样,Access 会向数据类型应用"是/否"。

Access 根据在粘贴数据的第一行中查找到的名称来命名字段。 如果粘贴数据的第一行的类型与后续行相似,Access 将确定第一行是数据的一部分,并分配字段泛型名称 (F1、F2 等) 。 如果粘贴数据的第一行与后续行不相似,Access 将确定第一行由字段名称组成。 Access 会相应地命名字段,并且数据中不包含第一行。

如果 Access 分配了通用字段名称,应尽快重命名字段以避免混淆。 使用以下过程:

  1. 按 Ctrl+S 保存表格。

  2. 在数据表视图中,双击每个列标题,然后键入每列的描述性字段名称。

  3. 再次保存表。

注意: 也可通过切换到"设计"视图并在那里编辑字段名称来重命名字段。 若要切换到"设计"视图,请右键单击导航窗格中的表,然后单击"设计视图"。 若要切换回数据表视图,请在导航窗格中双击该表。

返回页首

从另一个源导入、追加或链接到数据

你可能拥有存储在另一个程序中的数据,并且希望将数据导入到新表中或将其追加到 Access 中的现有表中。 或者,您可以与将数据保留在其他程序中的人合作,并且您希望通过链接到 Access 来使用这些数据。 无论使用哪种方式,Access 都可以轻松处理来自其他源的数据。 可以从 Excel 工作表、其他 Access 数据库中的表、SharePoint 列表或其他各种源导入数据。 使用的过程略有不同,具体取决于源,但以下过程将让你入门。

  1. 在 Access 中的"外部数据"选项卡上的"导入&"组中,单击要导入的文件类型的命令。

    “外部数据”选项卡上的“导入和链接”组

    例如,如果要从 Excel 工作表导入数据,请单击Excel。 如果看不到所需的程序类型,请单击"更多"。

    注意: 如果在"导入 & 链接"组中找不到正确的格式类型,可能需要启动最初创建数据的程序,然后使用该程序将数据保存为通用文件格式 (例如 带分隔符的文本文件 ) ,然后才能将数据导入 Access。

  2. 在"获取外部数据"对话框中,单击"浏览"以查找源数据文件,或在"文件名"框中键入源数据文件的完整路径。

  3. 单击所有程序 (导入的选项,有些程序允许追加或链接) "指定将数据存储在当前数据库中的操作方式和位置 "下。 你可以创建一个使用导入的数据的新表,或者将 (与某些程序一起创建) 可以将数据追加到现有表,或创建一个链接表来维护源程序中数据的链接。

  4. 如果向导启动,请按照向导后续几页上的说明进行操作。 在该向导的最后一页上,单击“完成”。

    如果从 Access 数据库导入对象或链接表,则会显示"导入 对象 "或" 链接表" 对话框。 选择想要的项目,然后单击"确定"。

    具体过程取决于是选择导入、追加还是链接数据。

  5. Access 会提示是否要保存刚刚完成的导入操作的详细信息。 如果认为将来会再次执行相同的导入操作,请单击"保存导入步骤",然后输入详细信息。 然后,可以单击"外部数据"选项卡上的"导入 按钮图像 链接&,轻松重复此操作。 如果不想保存操作的详细信息,请单击"关闭"。

如果选择导入表,Access 会将数据导入到新表中,然后在导航窗格中的"表 " 组下显示该表。 如果选择将数据追加到现有表,则数据将添加到该表。 如果选择链接到数据,Access 在导航窗格中的"表 " 组下创建一个链接表。

返回页首

添加应用程序部件

可以使用应用程序部件将功能添加到现有数据库。 应用程序部件可以像单个表一样简单,也可以由多个相关对象组成,例如表和绑定窗体。

例如,"批注"应用程序部件由一个表组成,该表包含"自动编号 ID"字段、日期字段和备注字段。 可以将其添加到任何数据库并按其使用,或者只需进行少量的自定义。

  1. 打开要添加应用程序部件的数据库。

  2. 单击“创建”选项卡。

  3. 在"模板"组中,单击"应用程序部件"。 随即打开可用部件列表。

  4. 单击要添加的应用程序部件。

返回页首

打开现有 Access 数据库

  1. “文件”选项卡上,单击“打开”

  2. "打开 "对话框中,浏览到要打开的数据库。

  3. 请执行以下操作之一:

    • 双击数据库以在"访问选项"对话框中指定的默认模式或管理策略设置的模式下打开该数据库。

    • 单击 " 打开"以在多用户环境中打开数据库进行共享访问,以便你和其他用户能够读取和写入数据库。

    • 单击"打开"按钮旁边的箭头,然后单击"打开只读"以打开数据库进行只读访问,以便可以查看但不能编辑该数据库。 其他用户仍然可以读取和写入数据库。

    • 单击"打开"按钮旁边的箭头,然后单击"以独占方式打开"以使用独占访问打开数据库。 打开具有独占访问权限的数据库时,尝试打开该数据库的任何人将收到"已在使用的文件"消息。

    • 单击"打开"按钮旁边的箭头,然后单击"打开独占只读"以打开数据库进行只读访问。 其他用户仍然可以打开数据库,但仅限于只读模式。

注意: 可以直接以外部文件格式(如 dBASE、Microsoft Exchange 或 Excel)打开数据文件。 也可以直接打开任何 ODBC 数据源 ,例如Microsoft SQL Server。 Access 会自动在数据文件相同的文件夹中创建新的 Access 数据库,并添加指向外部数据库中的每个表的链接。

提示

  • 若要打开最近打开的数据库之一,请在"文件"选项卡上单击"最近",然后单击该数据库的文件名。 Access 使用与上次打开数据库时相同的选项设置打开数据库。 如果未显示最近使用的文件列表,请在"文件"选项卡上单击"选项"。 在"访问选项"对话框中,单击"客户端设置"。"显示"下,输入"最近使用的文档"列表中要显示的文档数,最多 50 个。

    还可以在 Backstage 视图的导航栏中显示最近的数据库,以便双击访问:1) "文件"选项卡,2) 要打开的最近使用的数据库。 在"最近 "选项卡底部 附近,选中" 快速 访问此数目的最近使用的数据库"复选框,然后调整要显示的数据库数。

  • 如果要通过单击"文件"选项卡上的"打开"命令打开数据库,可以通过单击"打开"对话框中的"我的最近使用的文档"来查看以前打开的数据库的快捷方式列表。

返回页首

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

×