Sign in with Microsoft
Sign in or create an account.

直方图是显示频率数据的柱形图。

注意: 本主题仅讨论如何创建直方图。 有关 Pareto (排序直方图) 的信息,请参阅 创建 Pareto 图表

  1. 选择数据。

    (这是直方图.)

    用于创建上方的示例直方图的数据
  2. 单击“插入”>“插入统计信息图表”>“直方图”。

    从“插入统计图表”按钮访问的“直方图”命令

    你也可以从“推荐的图表”中的“所有图表”选项卡创建直方图。

提示: 

  • 使用"设计"和"格式"选项卡自定义图表的外观。

  • 如果你没有看到这些选项卡,请单击直方图中的任意位置以向功能区添加“图表工具”。

“图表工具”的“设计”和“格式”选项卡

  1. 右键单击图表的水平坐标轴,单击“设置坐标轴格式”,然后单击“坐标轴选项”。

    快捷菜单上的“设置坐标轴格式”命令
  2. 使用下表中的信息决定要在“设置坐标轴格式”任务窗格中的选项。

    选项

    说明

    按类别

    当水平坐标轴 (类别) 文本而不是数字时,请选择此选项。 直方图会对相同类别进行分组并对值坐标轴中的值求和。

    提示: 要对文本字符串的外观数进行计数,请添加一列并使用值“1”填充它,然后绘制直方图并将箱设置为“按类别”。

    自动

    这是直方图的默认设置。 箱宽度是使用 Scott 的普通引用规则计算的

    箱宽度

    为每个区域中的数据点数输入正十进制数字。

    箱数量

    为直方图输入箱数(包括溢出箱和下溢箱)。

    溢出箱

    要为高于右侧框中的值的所有值创建箱,请选中此复选框。 若要更改该值,请在该框中输入不同的十进制数字。

    下溢箱

    要为低于或等于右侧框中的值的所有值创建箱,请选中此复选框。 若要更改该值,请在该框中输入不同的十进制数字。

    “设置坐标轴格式”任务窗格

提示: 若要详细了解直方图及其如何帮助您可视化统计数据,请参阅由 Excel 团队撰写的这篇有关直方图、Pareto和箱形图的博客文章。 您可能还有兴趣详细了解此博客文章 中所述的其他 新图表类型

自动选项(Scott 正态引用规则)   

“自动”选项的公式

斯科特普通引用规则会尝试在最大程度上减少与数据集进行比较的直方图差异的偏差,同时采用正态分布数据。

溢出箱选项   

“上溢箱”选项的公式

下溢箱选项   

“下溢箱”选项的公式
  1. 确保已加载分析工具库。 有关详细信息,请参阅在 Excel中加载分析工具库

  2. 在工作表中,在一列中键入输入数据,根据需要,在第一个单元格中添加标签。

    确保使用定量的数值数据,如项目金额或测试分数。 直方图工具无法处理定性的数值数据,如以文本形式输入的标识号。

  3. 在下一列中,按升序键入组数字,根据需要,在第一个单元格中添加标签。

    最好使用您自己的仓数字,因为它们可能对您的分析更有用。 如果没有输入任何仓数字,通过将输入范围中的最小值和最大值作为起始和结束点,直方图工具将创建均匀分布的仓间隔。

  4. 单击“数据” > “数据分析”

    “数据分析”组中的“数据分析”按钮

  5. 单击“直方图” > “确定”

    “数据分析”对话框

  6. “输入”下方,执行下列操作:

    1. “输入区域”框中,输入具有输入数字数据区域的单元格引用。

    2. “仓区域”框中,输入具有仓数字区域的单元格引用。

      如果您在工作表上使用了列标签,您可以将其包含在单元格引用中。

      提示: 您可以单击"手动" “折叠”按钮 以暂时折叠对话框以选择工作表上的区域,而不是手动输入引用。 再次单击该按钮可展开对话框。

  7. 如果您在单元格引用中包含了列标签,请选中“标签”框。

  8. “输出选项”下,选择输出位置。

    您可以将直方图放在同一工作表上、当前工作簿的新工作表中或新工作簿中。

  9. 选中一个或多个以下复选框:

    Pareto (排序的直方图) 这会按频率的降序显示数据。

    累积百分比     这将显示累积百分比,并将累积百分比线添加到直方图。

    图表输出     这将显示嵌入直方图。

  10. 单击“确定”

    如果要自定义直方图,可以更改文本标签,然后单击直方图中的任何位置以使用图表右侧"图表元素"、"图表样式"和"图表筛选器"按钮。

  1. 选择数据。

    (这是直方图.)

    用于创建上方的示例直方图的数据
  2. 单击“插入”>“图表”。

    Word 中“插入”选项卡上的“插图”组中的“图表”按钮
  3. 在"插入图表"对话框中的"所有图表"下,单击"直方图",然后单击"确定"。

提示: 

  • 使用功能区上的"设计"和"格式"选项卡自定义图表的外观。

  • 如果你没有看到这些选项卡,请单击直方图中的任意位置以向功能区添加“图表工具”。

“图表工具”的“设计”和“格式”选项卡

  1. 右键单击图表的水平坐标轴,单击“设置坐标轴格式”,然后单击“坐标轴选项”。

    快捷菜单上的“设置坐标轴格式”命令
  2. 使用下表中的信息决定要在“设置坐标轴格式”任务窗格中的选项。

    选项

    说明

    按类别

    当水平坐标轴 (类别) 文本而不是数字时,请选择此选项。 直方图会对相同类别进行分组并对值坐标轴中的值求和。

    提示: 要对文本字符串的外观数进行计数,请添加一列并使用值“1”填充它,然后绘制直方图并将箱设置为“按类别”。

    自动

    这是直方图的默认设置。

    箱宽度

    为每个区域中的数据点数输入正十进制数字。

    箱数量

    为直方图输入箱数(包括溢出箱和下溢箱)。

    溢出箱

    要为高于右侧框中的值的所有值创建箱,请选中此复选框。 若要更改该值,请在该框中输入不同的十进制数字。

    下溢箱

    要为低于或等于右侧框中的值的所有值创建箱,请选中此复选框。 若要更改该值,请在该框中输入不同的十进制数字。

    “设置坐标轴格式”任务窗格

按照以下步骤在下列操作中创建直方Excel for Mac:

  1. 选择数据。

    (这是直方图.)

    用于创建上方的示例直方图的数据
  2. 在功能区上,单击"插入"选项卡,然后单击" 统计图表图标 (统计) ,然后在"直方图"下选择"直方图"。

提示: 

  • 可使用“图表设计”和“格式”选项卡自定义图表的外观。

  • 如果看不到"图表设计"和"格式"选项卡,请单击直方图中的任意位置以将其添加到功能区。

若要在 2011 for Mac Excel创建直方图,需要下载第三方加载项。 有关详细信息,请参阅:在2011 for Mac Excel中找不到分析工具库。

在 Excel Online 中,可以查看显示频率数据) 的直方图 (,但不能创建它,因为它需要分析工具库( Excel 网页版 中不支持的 Excel 加载项)。

如果你有桌面 Excel ,可以使用"在桌面Excel按钮在桌面上打开 Excel 并创建直方图

“在 Excel​ 中编辑”按钮

  1. 点击以选择数据。

    用于创建上方的示例直方图的数据
  2. 如果你在手机上,请点击"编辑"图标 “编辑”图标 显示功能区。 然后点击"开始"。

  3. 点击"插入>直方图>图表"。

    如有必要,可以自定义图表的元素。

    注意: 仅当具有 Microsoft 365 订阅时,此功能才可用。 如果你是 Microsoft 365 订阅者,请确保拥有最新版本的 Office

    购买或试用 Microsoft 365

  1. 点击以选择数据。

    用于创建上方的示例直方图的数据
  2. 如果你在手机上,请点击"编辑"图标 “编辑”图标 显示功能区,然后点击"开始"。

  3. 点击"插入>直方图>图表"。

若要在 Excel 创建直方图,请提供两种类型的数据 - 要分析的数据,以及表示要测量频率的间隔的箱数。 必须将数据组织为工作表上的两列。 这些列必须包含以下数据:

  • 输入数据    这是你想要使用直方图工具分析的数据。

  • 箱号    这些数字表示您希望直方图工具用于测量数据分析中的输入数据的间隔。

使用直方图工具时, Excel 计算每个数据箱中的数据点数。 如果数据量大于最小边界,并且等于或小于数据箱的最大边界,则数据点将包含在特定的 bin 中。 如果省略 bin 范围, Excel 在输入数据的最小值和最大值之间创建一组均匀分布的箱。

直方图分析的输出显示在新工作表 (或新工作簿) 中,并显示直方图表和反映直方图表中的数据的柱形图。

需要更多帮助吗?

你始终可以在 Excel 技术社区中咨询专家或在 Answers 社区获取

另请参阅

创建瀑布图

创建排列图

在 Office 中创建旭日图

创建盒须图

使用图表创建树状Office

需要更多帮助?

扩展你的技能
了解培训

此信息是否有帮助?

你对语言质量的满意程度如何?
哪些因素影响了你的体验?

谢谢您的反馈!

×