刷新数据透视表的数据

可随时单击“刷新”来更新工作簿中的数据透视表数据。 可刷新连接到以下外部数据的数据透视表数据:数据库(SQL Server、Oracle、Access 等)、Analysis Services 多维数据集、数据源和其他源。 也可在相同或不同的工作簿中刷新来自源表格的数据。 并且,可将工作簿设置为打开时自动刷新数据透视表数据。

默认情况下,数据透视表不会自动刷新,但您可以指定当您打开包含数据透视表的工作簿时,数据透视表会自动刷新。

手动刷新

  1. 单击数据透视表中的任意位置,在功能区上显示“数据透视表工具”。

    数据透视表工具

  2. 单击“分析”>“刷新”或按 Alt+F5。

    “分析”选项卡上的“刷新”按钮

    提示: 若要一次更新工作簿中所有数据透视表,请单击"分析">全部刷新"。

如果刷新所花费时间超过预期,请单击“分析”>“刷新”箭头 >“刷新状态”以检查刷新状态。

要停止刷新,请单击“取消刷新”。

防止调整列宽和单元格格式

如果在刷新数据透视表数据时,数据的列宽度和单元格格式违背你的意愿进行了调整,请确保检查以下选项:

  1. 单击“分析”>“选项”。

    “分析”选项卡上的“选项”按钮

  2. 在“布局和格式”选项卡上,选中“更新时自动调整列宽”和“更新时保留单元格格式”框。

打开工作簿时自动刷新数据

  1. 单击数据透视表中的任意位置,在功能区上显示“数据透视表工具”。

    数据透视表工具

  2. 单击“分析”>“选项”。

    “分析”选项卡上的“选项”按钮

  3. 在" 数据" 选项卡上,选中 打开文件框时刷新 数据。

手动刷新

  1. 单击数据透视表中的任意位置。

    这将显示 数据透视表工具,添加 "选项 "和"设计 " 选项卡。

  2. 在" 选项" 选项卡上的" 数据 "组中,执行下列操作之一:

  3. 若要更新信息以匹配数据源,请单击"刷新 " 按钮,或按 Alt+F5。

    也可以右键单击数据透视表,然后单击"刷新"。

  4. 若要刷新工作簿中所有数据透视表,请单击"刷新"按钮箭头,然后单击"全部刷新"。

    Excel 功能区图像

    如果刷新时间超过预期,请单击"选项">刷新>状态以检查刷新状态。

    要停止刷新,请单击“取消刷新”。

防止调整列宽和单元格格式

如果在刷新数据透视表数据时,数据的列宽度和单元格格式违背你的意愿进行了调整,请确保检查以下选项:

  1. 单击 "选项 > 选项

    “数据透视表工具”下“选项”选项卡上的“数据透视表”组
  2. 在“布局和格式”选项卡上,选中“更新时自动调整列宽”和“更新时保留单元格格式”框。

打开工作簿时自动刷新数据透视表数据

  1. 单击数据透视表中的任意位置。

  2. 在“选项”选项卡的“数据透视表”组中,单击“选项”。

    “数据透视表工具”下“选项”选项卡上的“数据透视表”组

  3. "数据透视表选项"对话框中的"数据"选项卡上,选中"打开文件时刷新数据"复选框。

如果向数据透视表数据源添加新数据,在该数据源基础上构建的所有数据透视表都需要刷新。 若要刷新数据透视表,可以右键单击数据透视表区域中的任意位置,然后选择“刷新”。

需要更多帮助吗?

你始终可以在 Excel 技术社区中咨询专家或在 Answers 社区获取

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×