在 Word 中创建用户可填写或打印的表单

若要在 Word 中创建其他人可以填写的表单,请从模板或文档开始,然后添加内容控件。 内容控件包括类似于复选框、文本框、日期选取器和下拉列表等控件。 如果您熟悉数据库,这些内容控件甚至可链接到数据。

显示“开发工具”选项卡

如果功能区中未显示"开发工具"选项卡,请参阅" 显示开发工具"选项卡

打开基于窗体的模板或空白文档

为节省时间,请从表单模板模板从头开始。

  1. 转到"文件">"新建"。

  2. "搜索联机模板"中,键入 "表单 "或"表单类型",然后按 Enter。

  3. 选择表单模板,然后选择"创建"或"下载"。

  1. 转到"文件">"新建"。

  2. 选择“空白文档”。

向表单添加内容

转到 "开发人员",然后选择要添加到文档或窗体的控件。 若要删除内容控件,请选择该控件,然后按 Delete。 插入 控件后 ,可以在控件上设置属性。

注意: 您可以打印使用内容控件创建的表单,但内容控件周围的框不会打印出来。

在格式文本内容控件中,用户可将文本格式设置为粗体或斜体,并可键入多个段落。 如果要限制用户添加的内容,请插入纯文本内容控件。

  1. 单击或点击要插入控件的位置。

  2. 选择"开发人员>内容控件" 格式文本控件按钮 或纯文本内容控件 纯文本控件按钮

若要在控件上设置特定属性,请参阅"设置或更改内容控件的属性"。

图片控件通常用于模板,但您也可将图片控件添加至表单。

  1. 单击或点击要插入控件的位置。

  2. 选择">图片内容控件" "图片控件"按钮

若要在控件上设置特定属性,请参阅"设置或更改内容控件的属性"。

想让用户选择特定的文本块时,请使用构建基块控件。 例如,当需要根据合同的特定要求添加不同的样本文本时,构建基块控件非常有用。 您可以为样本文字的每个版本创建格式文件内容控件,然后可以将构建基块控件作为容器用于格式文件内容控件。

  1. 单击或点击要插入控件的位置。

  2. 转到 "开发人员构建基块库内容控制 " 构建基块库控件 (或"构建基块内容 控制") 。

  3. 选择 构建 基块的开发人员和内容控件。

    显示内容控件的"开发工具"选项卡

  1. 单击或点击要插入控件的位置。

若要在控件上设置特定属性,请参阅"设置或更改内容控件的属性"。

在组合框中,用户可以从提供的选项列表中进行选择,也可以键入他们自己的信息。 在下拉列表中,用户只能从选项列表中进行选择。

  1. 转到开发人员>组合框内容控件 组合框按钮 或下拉列表内容控件 列表框按钮

  2. 选择内容控件,然后选择"属性"。

  3. 若要创建选项列表,请选择"在下拉列表属性下添加"。

  4. 在"显示名称"中键入选项,例如"是"、"否"或"也许"。

    重复此步骤,直到下拉列表中出现所有选项。

  5. 填写您所需的任何其他属性。

    注意: 如果您选中“无法编辑内容”复选框,用户将无法单击任何选项。

  1. 单击或点击要插入日期选取器控件的位置。

  2. 选择"开发人员>日期选取器内容控件 日期选取器按钮

若要在控件上设置特定属性,请参阅"设置或更改内容控件的属性"。

  1. 单击或点击要插入复选框控件的位置。

  2. 选中"开发>"复选框内容控件 复选框按钮

若要在控件上设置特定属性,请参阅"设置或更改内容控件的属性"。

旧表单控件与早期版本的 Word 兼容,由旧版表单和 Active X 控件组成。

  1. 单击或点击要插入旧控件的位置。

  2. 转到 "开发人员 > 旧版表单 旧版控件按钮 下拉列表。

  3. 选择想要包含在内的“旧式窗体”控件或“ActiveX 控件”。

设置或更改内容控件的属性

每个内容控件都具有可以设置或更改的属性。 例如,日期选取器控件提供要用于显示日期的格式选项。

  1. 选择要更改的内容控件。

  2. 转到开发人员>属性

    "控件属性"按钮

  3. 更改想要的属性。

向窗体添加保护

如果要限制其他人可以编辑表单或设置其格式的程度,请使用“限制编辑”命令:

  1. 打开要锁定或保护的表单。

  2. 选择">限制编辑"。

    "限制编辑"按钮

  3. 选择限制后,选择"是,开始强制实施保护"。

    限制编辑面板

高级提示:

如果只想保护文档的一部分,请将文档分为节,并仅保护要保护的节。

为此,请在" 限制编辑" 面板 中选择"选择分区 "。 有关节详细信息,请参阅"插入分节符"。

Resrict 分区面板上的分区选择器

显示“开发工具”选项卡

如果功能区中未显示"开发工具"选项卡,请参阅" 显示开发工具"选项卡

打开模板或使用空白文档

若要在 Word 中创建其他人可以填写的表单,请从模板或文档开始,然后添加内容控件。 内容控件包括复选框、文本框和下拉列表等内容。 如果您熟悉数据库,这些内容控件甚至可链接到数据。

  1. 转到“文件”>“根据模板新建”。

    "从模板新建"选项

  2. 在"搜索"中,键入 表单

  3. 双击要使用的模板。

  4. 选择">另存为",然后选择保存窗体的位置。

  5. "另存为"中,键入文件名,然后选择"保存"。

  1. 转到"新建>文件"。

    "新建文档"选项

  2. 转到“文件”>“另存为”。

  3. "另存为"中,键入文件名,然后选择"保存"。

向表单添加内容

转到 "开发人员",然后选择要添加到文档或窗体的控件。 若要删除内容控件,请选择该控件,然后按 Delete。 插入控件 ,可以设置控件上的"选项"。 在"选项"中,你可以添加在用户与控件交互时要运行的进入和退出宏,以及组合框的列表项。

  1. 在文档中,单击或点击要添加内容控件的地方。

  2. "开发工具"上,选择"文本框"、"复选框"或"组合框"。

    包含内容控件的"开发工具"选项卡

  3. 若要设置控件的特定属性, 请选择"选项",然后设置。

  4. 对要添加的每个控件重复步骤 1 到 3。

使用 选项可以设置常用设置,以及控制特定设置。 选择一个控件,然后选择 "选项 "以设置或进行更改。

  • 设置常用属性。

    • 选择要运行的宏,可选择在字段的"进入"或"退出"上运行的录制宏或自定义宏。

    • 书签 设置每个控件的唯一名称或书签。

    • 退出时计算 这会强制 Word 运行或刷新任何计算,例如用户退出字段时的总价格。

    • 添加帮助文本 提供每个字段的提示或说明。

    • 确定” 保存设置并退出面板。

    • 取消” 忘记更改并退出面板。

  • 设置文本框 的特定属性

    • 类型 选择表单常规文本、数字、日期、当前日期、当前时间或计算。

    • 默认 文本设置可选说明文本,该文本在文本框中显示,用户先在字段中输入。 设置 启用的文本框 以允许用户在字段中输入文本。

    • 最大长度 设置用户可以输入的文本长度。 默认值为"无限制"。

    • 文本格式可以设置文本是自动设置为大写、小、第大写还是标题大小写

    • 文本框已启用 允许用户在字段中输入文本。 如果有默认文本,则用户文本会替换它。

  • 设置复选框的特定 属性

    • 默认值 选择"未选中"或"默认选中"。

    • 复选框大小 设置大小" 精确 "或 "自动 "以根据需要更改大小。

    • 复选框已启用 允许用户选中或清除文本框。

  • 设置组合框 的特定属性

    • 下拉项目 键入列表框项的字符串。 按 + 或 Enter 将项目添加到列表。

    • 下拉列表中的项目 显示当前列表。 选择一个项目并使用向上或向下箭头更改顺序,按 - 删除所选项目。

    • 已启用下拉列表 允许用户打开组合框并做出选择。

  1. 转到开发人员>保护表单

    "开发工具"选项卡上的"保护表单"按钮

    注意: 若要取消保护窗体并继续编辑,请再次 选择"保护窗体 "。

  2. 保存并关闭窗体。

如果需要,可以先测试窗体再分发。

  1. 保护窗体。

  2. 重新打开窗体并按用户的标准进行填写,然后保存副本。

显示“开发工具”选项卡

  1. 在功能区右侧,选择" 操作弹出菜单 ,然后选择"功能区首选项"。

  2. "自定义"下,选择"开发人员"。

打开基于窗体的模板或文档

可以从空白文档开始创建自己的窗体。 要节省时间,也可以从窗体模板开始。

  1. 转到“文件”>“根据模板新建”。

  2. 在左窗格中,展开"联机模板",然后选择"窗体"。

  3. 双击要使用的窗体模板。

向窗体添加内容控件

  1. 在文档中,单击希望添加控件的位置。

  2. 在"开发工具"选项卡上的"表单控件"下,选择"文本框"、复选框"组合框"。

  3. 若要设置控件的特定属性, 请选择"选项",然后配置需要的属性。

    注意: 要在组合框中创建下拉项列表,请选择组合框占位符,单击“选项”,然后添加希望在下拉列表中显示的项。

  4. 对要添加的每个控件重复步骤 1 到 3。

添加说明性文本 (可选)

文本框中的说明文本(如“键入名字)可提高窗体的易用性。 默认情况下,文本框中不显示任何文本,但是可以添加文本。

  1. 选择要添加说明文本的文本框控件。

  2. 在"开发工具"选项卡上的"表单控件"下,选择"选项"。

  3. "默认文本"中,键入说明文本。

  4. 确保已选中"已启用填充",然后选择"确定"。

保护窗体

  1. 在"开发工具"选项卡上的"表单控件"下,选择"保护窗体"。

    注意: 要取消保护窗体并继续编辑,请再次单击“保护窗体”。

  2. 保存并关闭窗体。

测试表单 (可选)

如果需要,可以先测试窗体再分发。

  1. 保护窗体。

  2. 重新打开窗体并按用户的标准进行填写,然后保存副本。

创建可填写的表单在 Word 网页版 。

可以按照"创建可填写的表单"中的说明,使用桌面版本的 Word 创建窗体

保存文档并将其重新打开 Word 网页版 ,将看到所做的更改。

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×