管理约会、计划和预算 - 使用 Microsoft 365 轻松完成

导入 XML 数据

如果以前 创建了 XML 映射,可以使用它将 XML 数据导入到映射的单元格中,但还有一些方法和命令用于导入不带 XML 映射的 XML 数据。

如果有 XML 映射,则执行此操作以将 XML 数据导入到映射的单元格中:

  1. 在 XML 映射中,选择一个映射的单元格。

  2. 单击 "开发人员 > 导入"。

    如果看不到“开发工具”选项卡上,请参阅显示“开发工具”选项卡

  3. 在"导入 XML"对话框中,找到并选择要导入 (.xml) XML 数据文件,然后单击"导入"。

导入 XML 数据的其他方法

有关问题详细信息,请参阅本文末尾的 "导入 XML 数据的常见问题"。

将 XML 数据文件导入为 XML 表

  1. 单击 "开发人员 > 导入"。

    如果看不到“开发工具”选项卡上,请参阅显示“开发工具”选项卡

  2. 在"导入 XML"对话框中,找到并选择要导入 (.xml) XML 数据文件,然后单击"导入"。

    如果 XML 数据文件未引用架构,Excel 会从 XML 数据文件推断架构。

  3. "导入数据 "对话框中,执行下列操作之一:

    1. 选择 现有工作表中的 XML 表,将 XML 数据文件的内容导入到工作表中指定单元格位置的 XML 表中。

    2. 选择 新工作表中的 XML 表 ,将文件的内容导入到从单元格 A1 开始的新工作表中的 XML 表中。 XML 数据文件的架构显示在 "XML 源"任务窗格中。

  4. 如果 XML 数据文件未引用架构,Excel 会从 XML 数据文件推断架构。

  5. 若要控制 XML 数据组的行为 (数据绑定、格式和布局) ,请单击"属性",其中显示了"XML映射属性"对话框。 例如,默认情况下导入数据时,映射范围中的现有数据将被覆盖,但可以更改此情况。

导入多个 XML 数据文件

  1. 选择映射的单元格,将多个 XML 文件导入到一组映射的单元格中。

    如果要将多个 XML 文件导入到多组映射单元格中,请单击工作表上未映射的任意位置的单元格。

  2. 单击 "开发人员 > 导入"。

    如果看不到“开发工具”选项卡上,请参阅显示“开发工具”选项卡

  3. 在" 导入 XML" 对话框中,找到并选择要导入 (.xml) XML 数据文件。

    • 如果文件是连续的,请按 Shift,然后单击列表中的第一个文件和最后一个文件。 XML 文件的所有数据都将导入并追加到映射的单元格中。

    • 如果文件不连续,请按住 Ctrl,然后单击要导入列表中的每个文件。

  4. 单击“导入”。

    如果选择了不连续的文件,将显示"导入<文件名称 C1.xml 对话框。 选择对应于要针对每个文件导入的 XML 数据文件的 XML 映射。

    若要对尚未导入的所有选定文件使用单个映射,请为此架构的所有选定文件选择"使用此XML 映射"。

将多个 XML 数据文件导入为外部数据

若要导入使用相同命名空间但不同 XML 架构的多个 XML 文件,可以使用"从 XML 数据导入" 命令。 Excel 会为导入的每个 XML 数据文件创建唯一的 XML 映射。

注意: 如果要导入多个不定义命名空间的 XML 文件,这些 XML 文件将被视为使用相同的命名空间。

  1. 如果将 Excel 与Microsoft 365 订阅一起使用,请单击"数据">从"文件">"从 XML >数据"。

    如果使用的是 Excel 2016 或更早版本,请单击"来自其他源>">"从XML 数据导入"。

  2. 转到包含要导入的 XML 数据文件 (.xml) 驱动器、文件夹或 Internet 位置。

  3. 选择文件,然后单击“打开”。

  4. "导入数据 "对话框中,执行下列操作之一:

    • 现有工作表中的 XML 表    该文件的内容将导入到新工作表的新 XML 表中。 如果 XML 数据文件未引用架构,Excel 会从 XML 数据文件推断架构。

    • 现有工作表    XML 数据导入到包含行和列的二维表中,这些行和列将 XML 标记显示为列标题,数据显示在列标题下方的行中。 根节点 (的第一个元素) 标题一样使用,并显示在指定的单元格位置中。 其余标记将按字母顺序排列到第二行。 在这种情况下,Excel 不会推断架构,并且你不能使用 XML 映射。

    • 新建工作表    Excel 会向工作簿添加新工作表,并自动将 XML 数据放在新工作表的左上角。 如果 XML 数据文件未引用架构,Excel 会从 XML 数据文件推断架构。

  5. 若要控制 XML 数据的行为(例如数据绑定、格式和布局),请单击"属性 ",其中显示了 "XML 映射属性 "对话框。 例如,默认情况下导入数据时,映射范围中的现有数据将被覆盖,但可以更改此情况。

打开 XML 数据文件以导入其数据

  1. 单击“文件”>“打开”。

    如果使用的是 Excel 2007,请单击"打开 Microsoft Office按钮 Office 按钮图像 > 打开

  2. "打开 "对话框中,单击包含要打开的文件的驱动器、文件夹或 Internet 位置。  

  3. 选择文件,然后单击“打开”。

  4. 如果显示"导入 XML" 对话框,则打开的文件引用一个或多个可扩展样式表语言转换 (XSLT) 样式表,因此可以单击以下选项之一:

    • 打开文件而不应用样式表    XML 数据导入到包含行和列的二维表中,这些行和列将 XML 标记显示为列标题,数据显示在列标题下方的行中。 根节点 (的第一个元素) 标题一样使用,并显示在指定的单元格位置中。 其余标记将按字母顺序排列到第二行。 在这种情况下,Excel 不会推断架构,并且你不能使用 XML 映射。

    • 打开应用了以下样式表的文件, (一)     选择要应用样式表,然后单击"确定"。 XML 数据根据所选的样式表进行格式设置。

      注意: XML 数据在 Excel 中以只读方式打开,因此不会意外将原始源文件保存为 Excel Macro-Enabled 工作簿文件格式 (.xlsm) 。 在这种情况下,Excel 不会推断架构,并且你不能使用 XML 映射。

  5. 如果 显示"打开 XML" 对话框,则 XML 文件没有任何 XSLT 样式表引用。 若要打开该文件,请单击以下选项之一:

    • 单击 "作为 XML 表 "以创建新工作簿中的 XML 表。

      该文件的内容将导入到 XML 表中。 如果 XML 数据文件未引用架构,Excel 会从 XML 数据文件推断架构。

    • 单击"作为只读工作簿"。

      XML 数据导入到包含行和列的二维表中,这些行和列将 XML 标记显示为列标题,数据显示在列标题下方的行中。 根节点 (的第一个元素) 标题一样使用,并显示在指定的单元格位置中。 其余标记将按字母顺序排列到第二行。 在这种情况下,Excel 不会推断架构,并且你不能使用 XML 映射。

      XML 数据在 Excel 中以只读方式打开,因此不会意外将原始源文件保存为 Excel Macro-Enabled 工作簿文件格式 (.xlsm) 。 在这种情况下,Excel 不会推断架构,并且你不能使用 XML 映射。

    • 单击 "使用 XML 源"任务窗格

      XML 数据文件的架构显示在 "XML 源"任务窗格中。 然后,您可以将架构的元素拖动到工作表,以将这些元素映射到工作表。

      如果 XML 数据文件未引用架构,Excel 会从 XML 数据文件推断架构。

导入 XML 数据的常见问题

Excel 无法根据 XML 映射 验证数据时显示"XML 导入错误"对话框。 在此对话框中,单击 "详细信息 ",了解有关每个错误的其他信息。 下表列出了一些常见的导入错误:

错误

发生了什么事

架构验证失败

"XML映射属性"对话框中单击"根据架构验证数据以导入和导出"时,已导入数据,但数据未根据指定的 XML 映射进行验证。

某些数据已导入为文本

导入的一些或所有数据已从声明的数据类型转换为文本。 若要在计算中使用此数据,需要将数据从文本转换为数字或日期。 例如,转换为文本的日期值在 YEAR 函数中将无法正常工作,直到将其转换为 Date 数据类型。 当发生:

  • 数据采用 Excel 不支持的格式。

  • 数据与 XSD 表的 Excel 内部表示数据类型。 若要解决此问题,请检查每个数据类型声明,确保 XML 数据根据 XML 架构有效。

XML 分析错误

XML 分析器无法打开指定的 XML 文件。 请确保 XML 文件没有语法错误,并且 XML 格式良好。

找不到与数据对应的 XML 映射

当选择要导入的多个 XML 数据文件,并且 Excel 找不到其中一个文件的匹配 XML 映射时,可能会发生此问题。 对于在对话框标题栏中命名的文件,请首先导入相应的架构,然后再次尝试导入文件。

无法调整 XML 表的大小以适应数据

您尝试通过将数据导入或追加到 XML 表来添加行,但该表没有空间可展开。 XML 表只能从下到下展开。 例如,XML 表正下方可能有一个对象(如图片或其他表)阻止 XML 表展开。 或者,对于要展开的 XML 表,它将超过 Excel 行限制 1,048,576。 若要解决此问题,请重新排列工作表上的表和对象,以允许 XML 表从下到下展开。

指定的 XML 文件不引用架构

尝试打开的 XML 文件不引用 XML 架构。 若要处理文件中 XML 数据,Excel 需要基于 XML 文件内容的架构。 如果该架构不正确或不足,请将其从工作簿中删除。 然后创建 XML 架构文件并编辑 XML 数据文件,使 XML 数据文件引用架构。 有关详细信息,请参阅将 XML 元素映射到 XML 映射中的单元格

注意: 无法将 Excel 推断的架构导出为单独的 XML 架构数据文件 (.xsd) 。 虽然有用于创建 XML 架构文件的 XML 架构编辑器和其他方法,但是您可能无法方便地利用它们或不了解如何使用它们。

请按照以下步骤删除 Excel 从工作簿中创建的架构:

  1. 单击“开发工具”>“”。

    “开发工具”选项卡上的“XML”命令

    如果看不到“开发工具”选项卡上,请参阅显示“开发工具”选项卡

  2. 在“XML 源”任务窗格中,单击“XML 映射”。

  3. "XML 映射"对话框中,单击 Excel 创建的 XML 映射,并单击"删除"。

导入使用相同命名空间但不同架构的多个 XML 文件无法如期工作

使用多个 XML 数据文件和 XML 架构时,通常会为每个架构创建 XML 映射,映射需要的元素,然后将每个 XML 数据文件导入到相应的 XML 映射。 使用 Import 命令打开多个同一命名空间的 XML 文件,只能使用一个 XML 架构。 使用此命令打开使用相同命名空间但架构不同的多个 XML 文件时,可能会获得意外结果。 例如,数据可能会被覆盖,或者文件无法打开。

若要导入使用多个使用相同命名空间但不同 XML 架构的 XML 文件,请尝试使用"从XML数据导入"命令 (单击"来自其他源>数据) 。 此命令允许同一命名空间的多个 XML 文件使用多个 XML 架构。 Excel 为要导入的每个 XML 数据文件创建唯一的 XML 映射。

注意: 如果要导入多个不定义命名空间的 XML 文件,这些 XML 文件将被视为使用相同的命名空间。

显示“开发工具”选项卡

如果看不到“开发工具”选项卡,请通过执行下列操作来显示该选项卡:

  • 在 Excel 2013 和 Excel 2010 中:

    1. 单击“文件”>“选项”。

    2. 单击“自定义功能区”类别。

    3. 在“主选项卡”下,勾选“开发工具”框,然后单击“确定”。

  • 在 Excel 2007 中:

    1. 单击 Excel Microsoft Office中的 Office 按钮图像 > 按钮

    2. 单击“常用”类别。

    3. 在“使用 Excel 时采用的常规选项”中,勾选 [在功能区中显示“开发工具”选项卡] 框,然后单击“确定”。

另请参阅

Excel 中的 XML Over 视图

在 XML 映射中将 XML 元素映射到单元格

导出 XML 数据

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×