将宏模块复制到另一个工作簿中

如果工作簿包含Visual Basic for Applications (VBA) 宏,可以使用 Visual Basic Editor (VBE) 将包含该宏的模块复制到另一个打开的工作簿。

宏和 VBA 工具位于“开发工具”选项卡上,由于该选项卡默认是隐藏的,因此第一步是启用选项卡。

  • 对于Windows,请转到"文件">选项>"功能区"。

  • 对于Mac,转到"Excel >首选项...">功能&工具栏

  • 接下来,在" 自定义功能区"部分 的主 选项卡下,选中" 开发工具" 复选框。

宏和 VBA 概述

如果不熟悉宏和 VBA,可能会发现以下信息很有用。

  • 宏是可用于自动执行任务的操作或操作集。

  • 可以使用"开发工具"选项卡上的" 录制宏 " 命令录制宏

  • 宏以 VBA 编程语言录制。

  • 您可以在 Excel 打开的窗口的 Visual Basic 编辑器中检查和编辑宏。 下面是适用于 Windows 的 VBE 窗口的示例

    包含两个存储在 Book1 的 Module1 中的宏的模块。

名为 MakeCellGreenSetRowHeight 的宏位于名为 Module1的模块中,该模块存储在 Book1 中。

将模块从一个工作簿复制到另一个工作簿

  1. 打开包含要复制的宏的工作簿和要复制宏的工作簿。

  2. 在" 开发工具 "选项卡 上,Visual Basic 打开Visual Basic 编辑器

  3. 在Visual Basic编辑器的"视图"菜单上,单击"项目资源管理器" “项目资源管理器”按钮图像 ,或按Ctrl+R。

  4. "项目资源管理器 "窗格中,拖动包含要复制到目标工作簿的宏的模块。 在这种情况下,我们要将 Module1 从 Book2.xlsm 复制到 Book1.xlsm。  

    VBA 项目资源管理器

  1. 从 m 复制的 module1 Book2.xlsm

  2. 复制到 m 的 Module1 Book1.xls副本

需要更多帮助吗?

你始终可以在 Excel 技术社区中咨询专家或在 Answers 社区获取

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×