将数据添加到 Visio 形状

将数据添加到 Visio 形状

在 Visio 中,形状可包含相关数据(称为形状数据),用于提供详细信息。 例如,形状数据可显示流程中的步骤或网络图表中的数件设备,而无需在图表中填充文本。

可直接将数据添加形状中;如果你有 Visio 专业版,则可将外部数据源中的数据链接到形状。 本文介绍如何直接将数据添加到形状中。 

下列文章探讨了如何使用外部数据源:

查看形状数据

若要查看任何 Visio 对象的形状数据:

  • 右键单击该形状,然后选择“数据”>“形状数据”。

    右键单击一个形状,然后依次选择“数据”和“形状数据”。

    形状数据”窗口随即打开。

将数据添加到所选形状

要将数据添加到绘图中已有的形状,请首先将数据域添加到这些形状,然后再添加数据值。

将数据字段添加到所选形状

  1. 在“视图”选项卡上的“显示”组中,单击“任务窗格”,然后单击“形状数据”。

    这样可切换“形状数据”任务窗格的显示。

  2. 选择要向其添加数据的形状。

  3. 右键单击所选形状,在快捷菜单上指向“数据”,然后单击“定义形状数据”。

  4. 在“定义形状数据”对话框中,单击“新建”,然后执行下列操作:

    • 在“标签”框中,键入新字段的名称。

    • 在“类型”列表中,选择要包含的新字段的数据类型。

    • 在“格式”列表中,选择显示数据的格式。 “格式”选项会有所变化,具体取决于所选择的数据类型。

    • 如果您想要为某人提供将数据添加到该字段的文本提示,请在“提示”框中,输入所需的文本。 将鼠标指针停留在“形状数据”窗口中的字段上方时会显示该文本。

  5. 单击“确定”。

将值添加到数据字段

  • 选择各个形状(一次选择一个),然后在“形状数据”窗口的数据域中键入数据值。

    形状数据”窗口的内容只显示所选形状的数据。

创建一组可重用的数据域

你不必分别为每个形状创建数据字段,可以创建一组数据字段,并将其应用于绘图中的所有选定形状以及以后放在绘图中的形状。

创建一组可重用的数据字段

  1. 在“视图”选项卡上的“显示”组中,单击“任务窗格”,然后单击“形状数据”。

    这样可切换“形状数据”任务窗格的显示。

  2. 右键单击“形状数据”任务窗格中的任何位置,然后单击“形状数据集”。

  3. 在“形状数据集”任务窗格中,单击“添加”。

  4. 在“添加形状数据集”对话框中,键入数据集的名称。

  5. 选择“创建新数据集”,然后单击“确定”。

    数据集即会显示在“形状数据集”窗口的“名称”列中。

  6. 选择新数据集,然后单击“定义”。

  7. 在“定义形状数据”对话框中,定义形状数据集的字段。

  8. 要创建其他字段,单击“新建”。

  9. 定义完所有数据域后,单击“确定”。

  10. 要将数据集应用于绘图中的所选形状,请在“形状数据集”任务窗格中选择该数据集,然后单击“应用”。

要查看已应用数据集的其中之一形状中的新域,请选择该形状,然后在“形状数据”窗口中查看。

将数据域添加到主控形状

如果希望每次使用特定形状时都添加相同的形状数据集,可以将这些数据域添加到该形状的主控形状的副本,这样能够节省时间。 例如,可以将姓名和雇员编号等数据域添加到人员形状的主控形状。

创建自定义模具上的形状副本

  1. 在“形状”窗口中,右键单击该主控形状,指向“添加到我的形状”,然后执行下列操作之一:

    • 如果要将主控形状添加到新模具,单击“添加到新模具”。

    • 如果要将主控形状添加到现有的自定义模具中,单击“添加到现有模具”。

  2. 在“另存为”对话框中,键入新模具的名称,然后单击“保存”。

  3. 在“形状”窗口中,单击“更多形状”,指向“我的形状”,然后单击包含复制的主控形状的模具。

在自定义模具上编辑新的主控形状

  1. 右键单击新模具的标题栏,然后在快捷菜单上单击“编辑模具”。

  2. 右键单击刚添加到该模具中的形状,指向“编辑主控形状”,然后单击“编辑主控形状”。

  3. 在该形状的编辑窗口中,右键单击该形状,指向“数据”,然后单击“形状数据”。

  4. 在“定义形状数据”对话框中,键入域的名称,然后填写所需的任何其他信息。 例如,此时您可能希望更改数据类型或者添加形状提示。

  5. 要创建其他域,请单击“新建”,然后重复前面的步骤。

  6. 完成定义数据域后,请单击“确定”。

  7. 要关闭主控形状的编辑窗口,请在“视图”选项卡上的“窗口”组中,单击“层叠”,选择主控形状窗口,然后单击上方的“关闭”按钮 (X)。

  8. 将出现一条消息,询问您是否要更新形状,此时请单击“”。

  9. 在“形状”窗口中,右键单击模具,然后单击“保存”。

删除数据字段

  1. 选择具有要删除数据字段的形状。

  2. 右键单击“形状数据”窗口中的任何位置,然后单击“定义形状数据”。

  3. 在“定义形状数据”对话框中的“属性”下,选择要删除的数据字段,单击“删除”,然后单击“确定”。

在 Visio 网页版 中,不能向形状添加数据,但可以在 Visio 桌面应用中查看已添加到形状中的数据。 同样,如果在 Visio 桌面应用中向形状添加了超链接,该超链接也是可见的,可进行访问。

查看形状数据

  1. 打开图表进行查看。

  2. 选择“形状信息形状信息命令

  3. 要查看形状的数据,请选择该形状。

    包含超链接的形状数据示例

另请参阅

Visio 网页版帮助

在 Visio 网页版中查看、创建和编辑图表

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×