将自动完成列表导入或复制到另一台计算机

自动完成列表是一项功能,当您开始键入姓名和电子邮件地址时,该功能会显示建议。 这些建议可能与已发送的电子邮件中的姓名和电子邮件地址列表匹配。 

自动完成列表

将自动完成列表从一台计算机复制到另一台计算机的方法取决于您已添加到 Outlook 的电子邮件帐户类型。 如果你有Microsoft 365 帐户、Exchange Server 帐户或 IMAP 帐户 (这是其他电子邮件帐户) 的最常见类型,则自动完成列表将存储为 Outlook 数据文件中的隐藏文件。 有关 说明,请参阅复制自动完成列表。

如果你有一个 POP3 帐户 (不太常见,但通常用于 Comcast、Earthlink 和 Verizon) 等第三方电子邮件提供商,则自动完成列表将存储在你的计算机上存储的文件中。 请参阅 复制并导入 .nk2 文件

如果不知道拥有的帐户类型,请选择"文件">"帐户>设置"。 可在此处找到帐户类型。

复制"自动完成"列表

步骤 1:导出自动完成邮箱邮件

  1. 退出 Outlook,然后关闭 Outlook Web Access 或 Outlook Web App (OWA) 连接到您的邮箱的所有工作站上的 OWA 应用。

  2. 从客户端下载并安装 MFCMAPI http://mfcmapi.codeplex.com。

  3. 运行mfcmapi.exe。

  4. 在"会话"菜单上,单击"登录"。

  5. 如果系统提示输入配置文件,请选择所需的配置文件名称,然后单击"确定"。

  6. 在顶部窗格中,找到与邮箱对应的行,然后双击它。

  7. 在左侧导航窗格中,展开"根容器",然后展开"信息存储顶部"或"IPM_SUBTREE"。

  8. 右键单击"收件箱"文件夹,然后单击"打开关联内容表"。 此操作将打开包含各种属性的新 MFCMAPI 窗口。

  9. "主题"列下,右键单击主题为IPM.Config项目。自动完成,然后单击"导出邮件"。 此操作将打开" 将消息保存到文件" 窗口。

  10. 在下拉列表中,选择"UNICODE (MSG) ",然后单击"确定"。

  11. 选择要将邮件保存到的文件夹位置,然后单击"保存"。 请注意此位置。

步骤 2:导入自动完成邮箱邮件

  1. 退出 Outlook,然后关闭 Outlook Web Access 或 Outlook Web App (OWA) 连接到您的邮箱的所有工作站上的 OWA 应用。

  2. 从客户端下载并安装 MFCMAPI http://mfcmapi.codeplex.com。

  3. 运行mfcmapi.exe。

  4. 在"会话"菜单上,单击"登录"。

  5. 如果系统提示输入配置文件,请选择所需的配置文件名称,然后单击"确定"。

  6. 在顶部窗格中,找到与邮箱对应的行,然后双击它。

  7. 在左侧导航窗格中,展开"根容器",然后展开"信息存储顶部"或"IPM_SUBTREE"。

  8. 右键单击"收件箱"文件夹,然后单击"打开关联内容表"。 此操作将打开包含各种属性的新 MFCMAPI 窗口。

  9. 若要避免重复条目,必须删除现有的"自动完成"消息。

    注意: 在删除 IPM.Configuration 之前。自动完成消息,必须使用"如何导出自动完成缓存"部分中的步骤导出消息。

    若要删除现有的"自动完成"消息,请执行以下步骤:

    1. "主题 "列中,找到主题为"IPM.Config 的项目。自动完成

    2. 右键单击该项目,然后单击"删除邮件"。 这将打开" 删除项目" 窗口。

    3. 在下拉列表中,选择"永久删除", (删除项保留(如果支持) 保留期),然后单击"确定"。

  10. 在"文件夹"菜单上,单击"导入",然后单击"从 MSG"。

  11. 找到在以上"导出自动完成邮箱邮件"的步骤 11 中创建的 .msg 文件,然后单击"确定"。

  12. 在出现的"加载 MSG"窗口中,选择"加载样式"列表中的"将邮件加载到当前文件夹",然后单击"确定"。

自动完成信息从 IPM.Config导入。Autocomplete_<十六 进制代码>.msg,其中占位符< 六进制>表示一长串数字和字母。

复制和导入 .nk2 文件

步骤 1:从旧计算机复制自动完成文件

  1. 由于默认文件夹是隐藏文件夹,打开文件夹的最简单方法是在Windows搜索框中使用命令%APPDATA%\Microsoft\Outlook (,或者浏览到 C:\Users\username\AppData\Roaming\Microsoft\Outlook) 。

  2. 在 Outlook 文件夹中,找到"自动完成列表" (.nk2) 文件。

    注意: 默认情况下,文件扩展名在 Windows 中处于隐藏状态。 若要更改是否显示文件扩展名,请在 Windows 7或 Windows Vista 的"工具"菜单 (上的"窗口资源管理器"中,按Alt 键查看"工具"菜单) ,单击"文件夹选项"。 在" 视图" 选项卡上,选中或清除"隐藏已知 文件类型的 扩展名"复选框。

  3. 将文件复制到新计算机。 该文件较小,可以放置在可移动媒体(如 USB 内存摇杆)上。

步骤 2:将自动完成文件复制到新计算机

  1. 在新计算机的"控制面板"中,单击或双击"邮件"。

    邮件显示在不同的控制面板位置,具体取决于 Microsoft Windows 操作系统的版本、选择的"控制面板"视图,以及是否安装了 32 位或 64 位操作系统或 Outlook 2010 版本。

    找到“邮件”的最简单的方法是,打开 Windows 中的“控制面板”,然后在窗口顶部的“搜索”框中,键入“邮件”。 在 Windows XP 的控制面板中,在“地址”框中键入“邮件”。

    注意: “邮件”图标会在 Outlook 首次启动后显示。

  2. 单击"显示配置文件"。

  3. 记下配置文件的名称。 稍后需要更改 .nk2 文件名以匹配名称。

  4. 将 .nk2 文件复制到保存 Outlook 配置的文件夹中的新计算机。 由于默认文件夹是隐藏文件夹,打开文件夹的最简单方法是在Windows搜索框中使用命令%APPDATA%\Microsoft\Outlook (,或者浏览到 C:\Users\username\AppData\Roaming\Microsoft\Outlook) 。

  5. 将文件复制到文件夹后,右键单击该文件,单击"重命名",然后更改名称以匹配步骤 3 中显示的个人资料名称。

步骤 3:导入自动完成列表

现在,可以启动 Outlook 并导入文件,但必须使用特殊的一次命令启动 Outlook。

  • 在 Windows 搜索框中键入 outlook /importnk2,然后按 Enter。

撰写邮件并开始在"收件人"、抄送或"密件抄送"框中键入时,自动完成列表现在应包含其他计算机中的条目。

返回页首

在 Outlook 2007 中,可以将自动完成列表中的名称和电子邮件地址从一台计算机复制到另一台计算机。 例如,如果要升级到新计算机,并且不希望丢失自动完成列表中存储的所有信息,可以将名称和电子邮件地址从旧计算机复制到新计算机。

重要: 必须先退出 Microsoft Outlook ,然后才能开始以下过程。 重新启动 Outlook 时,姓名将包含在自动完成列表中。

从旧计算机复制自动完成文件

  1. 在旧计算机上,转到驱动器:\user\AppData\Local\Microsoft\Outlook。

    注意: 根据文件设置,此文件夹可能处于隐藏状态。

  2. 右键单击"配置文件名称.nk2",然后单击"复制"。

    提示: 可以将文件复制到可移动媒体(如 U 盘)中,然后将文件复制到新计算机上的正确位置。 或者,你可以将文件附加到电子邮件,并将该邮件发送给你自己。 在新计算机上,在 Outlook 中打开附件,并将其保存在正确的位置。

  3. 在要填充自动完成列表的计算机上,右键单击驱动器:\user\AppData\Local\Microsoft\Outlook 中的任意位置,然后单击"粘贴"以保存配置文件名称.nk2。

  4. 如果要移动 .nk2 文件的计算机上 Outlook 用户配置文件名称不同,则必须使用新计算机上使用的 Outlook 用户配置文件名称重命名该文件,再将该文件复制到正确的文件夹。 例如,如果将张屆嫢从 Outlook 用户配置文件名称为"Kim Akers"的原始计算机中移动,并且将"张柾"文件复制到新计算机,则必须使用新计算机上使用的 Outlook 配置文件名称重命名该文件。

  5. 当系统提示有关替换现有文件时,请单击"是"。

  6. 打开 Outlook 以查看对自动完成列表所做的更改。

返回页首

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×