如果在任务中反复执行Microsoft Office Project,可以使用宏自动执行任务。 宏是一系列命令和函数,存储在一个 模块 并且每当需要执行任务时都可以运行。

  1. 在"视图"选项卡上,选择"宏",然后选择"录制宏"。

    (在 Project 2007 中,在"工具"菜单上,指向"",然后选择"录制新宏.)

  2. "宏名称 "框中,键入名称 宏 。

    宏名的第一个字符必须是字母。 其他字符可以是字母、数字或下划线字符。 宏名中不允许使用空格,但下划线可以用作单词分隔符。

  3. 若要通过按键盘键运行宏 快捷键 ,请在"快捷键"框中输入字母 或键 组合。

    对于小写字母) ,可以使用 Ctrl+字母 (或 Ctrl+Shift+字母 (作为大写字母) ,其中字母是键盘上的任何字母键,而不是数字或特殊字符。 不能使用已在 Microsoft Office Project 中使用的键Microsoft Office Project。

  4. "将宏存储在 "列表中,选择要存储宏的位置:

    • 若要在使用该宏时使用该Project,请选择"全局文件"。

    • 若要使宏仅可用于当前项目,请选择"此Project"。

  5. 若要包含宏的说明,在"说明"框中 键入说明

  6. 如果在录制宏时选择单元格,则宏每次运行时都将选择同一列 (字段) ,而不考虑首先选择哪个单元格,因为它记录对列的绝对引用。 如果希望宏在运行宏时选择列而不考虑活动单元格的位置,请在"列引用"下选择"相对"。

    相反,宏将在运行宏时选择行,而不考虑活动单元格的位置,因为它记录对行的相对引用。 如果希望宏始终选择同一行,而不考虑首先选择哪个单元格,请选择"行引用" (") "绝对ID"。

    注意: Project宏时,将继续使用这些设置,直到您更改设置或关闭Project。

  7. 选择 "确定",然后执行要录制的操作。

  8. 完成要录制的所有操作后,在"视图"选项卡上,选择"",然后选择"停止录制"。

    (2007 Project中,在"工具"菜单上,指向"",然后选择"停止录制器")

安全说明: 由于宏可能包含病毒,因此请谨慎运行它们。 采取以下预防措施:在计算机上运行最新的防病毒软件;将宏安全级别设置为高;清除"信任所有已安装的加载项和模板"复选框;使用数字签名;维护受信任的发布者列表。

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

你对翻译质量的满意程度如何?

哪些因素影响了你的体验?

是否还有其他反馈?(可选)

谢谢您的反馈意见!

×