打开、插入、转换以及保存 DWG 和 DXF (AutoCAD) 绘图

Office 365 订阅, Office 2021, Office 2019, Office 2016, Office 2013, Office 2010

如果要在 Visio 绘图中使用 AutoCAD 对象,可以使用 Visio 打开它们并将其转换为 Visio 形状。 还可以将 Visio 绘图转换为 AutoCAD 文件。

注意    Microsoft Visio 支持采用以下方式的 AutoCAD 文件格式:使用 Visio 计划 2 ,可以导入从 AutoCAD 版本 2017 或早期版本创建的 .dwg 或 .dxf 文件。 使用 Visio Standard 或 Professional,可以导入从 AutoCAD 版本 2007 或早期版本创建的 .dwg 或 .dxf 文件。 如果无法打开 a. dwg 或 .dxf 文件,则其文件格式可能不受支持。 解决方法是,在 AutoCAD 中打开文件,然后将其保存为 Visio 产品或计划支持的文件格式。 有关详细信息,请参阅如何将 AutoCAD 绘图保存为以前的或旧的文件格式和 DWG 版本历史记录

在 Visio 中打开 AutoCAD 绘图

  1. 单击“文件”>“打开”。

  2. 找到要保留绘图的文件夹。 单击文件夹或单击"浏览"。

  3. 单击"所有 Visio 文件"列表,然后单击"AutoCAD 绘图"。

  4. 浏览到该文件,然后单击"打开"。

将 DWG 或 DXF 文件插入现有 Visio 图表

  1. 在“插入”选项卡上,单击“CAD 绘图”。

  2. 浏览到该文件,然后单击"打开"。

将 DWG 和 DXF 对象转换为 Visio 形状

导入或打开 AutoCAD 绘图后,你可以将其转换为可以在 Visio 中操作的形状。 请注意,转换为 Visio 形状的操作不能撤消。

  1. 单击图表上的空白位置以取消选择任何可能已选择的内容。

  2. 将光标停放在 AutoCAD 绘图的外边缘上,直到光标变为此图标:
    带有移动图标的箭头光标

  3. 右键单击,然后单击“CAD 绘图对象”>“转换​​”。

  4. 在“转换 CAD 对象”对话框中,选择要转换为 Visio 形状的 AutoCAD 图层。

  5. 单击“高级”查看更多选项。 例如,可以选择删除转换后的图层,也可以将尺寸转换为尺寸形状,或将影线图案转换为形状。

将绘图转换为 DWG 或 DXF 格式时,将转换 CAD 绘图上次保存的空间视图。 CAD 绘图可能保存在模型空间 纸张 空间中

  • 模型空间    是 CAD 绘图器创建绘图的主要绘图工作区。 转换在模型空间中保存的绘图时,选择图层上的所有对象和文本将转换为 Visio 形状。

  • 纸张    空间是类似于一张纸的工作区,CAD 绘图器可以排列绘图的不同视图。

    下图显示了保存在纸张空间的 DWG 绘图。

    保存在图纸空间中、显示同一平面布置图的两种视图的 CAD 绘图

    绘图包含两个矩形 视区。 视区是三维 CAD 绘图的窗口。 每个视区可以设置为不同的比例或角度。

    转换保存在纸张空间的绘图时,只有未剪切 (视口边缘) 剪切的对象将转换为 Visio 形状。 剪切的对象和文本将转换为行。 例如,视区完全包围的圆圈将转换为 Visio 圆形形状。 由视区剪裁的圆圈将转换为一系列线条。

将 Visio 图表另存为 DWG 或 DXF 文件

  1. 单击“文件”>“另存为”。

  2. 浏览找到要保存绘图的位置或文件夹。

  3. 在" 另存为类型 "列表中,单击想要的文件类型:

    • AutoCAD 绘图 (*.dwg)

    • AutoCAD 交换 (*.dxf)

如果你的 Visio 有多个绘图页,必须单独保存每一页。

另请参阅

Introduction to working with AutoCAD drawings in Visio(在 Visio 中处理 AutoCAD 绘图简介)

准备导入 AutoCAD

导入 AutoCAD 绘图

转换多个 AutoCAD 绘图

在 Visio 中打开 AutoCAD 绘图

  1. 单击“文件”>“打开”。

  2. 找到要保留绘图的文件夹。 单击文件夹。

  3. 单击"所有 Visio 文件"列表,然后单击"AutoCAD 绘图"。

  4. 浏览到该文件,然后单击"打开"。

将 DWG 或 DXF 文件插入现有 Visio 图表

  1. 在“插入”选项卡上,单击“CAD 绘图”。

  2. 浏览到该文件,然后单击"打开"。

将 DWG 和 DXF 对象转换为 Visio 形状

导入或打开 AutoCAD 绘图后,你可以将其转换为可以在 Visio 中操作的形状。 请注意,转换为 Visio 形状的操作不能撤消。

  1. 右键单击 CAD 绘图,指向"CAD 绘图对象",然后单击"转换"。

  2. "转换 CAD 对象 "对话框中,选中包含要转换的 CAD 对象的 AutoCAD 图层的复选框。

    注意: 若要保持绘图文件大小较小并加快转换过程,请仅转换所需的图层或级别。

  3. 单击“高级”查看更多选项。 例如,可以选择删除或隐藏转换后的图层、将尺寸转换为尺寸形状或将阴影线图案转换为形状。

  4. 单击“确定”。

将绘图转换为 DWG 或 DXF 格式时,将转换 CAD 绘图上次保存的空间视图。 CAD 绘图可能保存在模型空间 纸张 空间中

  • 模型空间    是 CAD 绘图器创建绘图的主要绘图工作区。 转换在模型空间中保存的绘图时,选择图层上的所有对象和文本将转换为 Visio 形状。

  • 纸张    空间是类似于一张纸的工作区,CAD 绘图器可以排列绘图的不同视图。

    下图显示了保存在纸张空间的 DWG 绘图。

    保存在图纸空间中、显示同一平面布置图的两种视图的 CAD 绘图

    绘图包含两个矩形 视区。 视区是三维 CAD 绘图的窗口。 每个视区可以设置为不同的比例或角度。

    转换保存在纸张空间的绘图时,只有未剪切 (视口边缘) 剪切的对象将转换为 Visio 形状。 剪切的对象和文本将转换为行。 例如,视区完全包围的圆圈将转换为 Visio 圆形形状。 由视区剪裁的圆圈将转换为一系列线条。

将 Visio 图表另存为 DWG 或 DXF 文件

  1. 单击“文件”>“另存为”。

  2. 浏览找到要保存绘图的位置或文件夹。

  3. 在" 另存为类型 "列表中,单击想要的文件类型:

    • AutoCAD 绘图 (*.dwg)

    • AutoCAD 交换 (*.dxf)

如果你的 Visio 有多个绘图页,必须单独保存每一页。

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×