Outlook 搜索问题疑难解答

选择最能描述 Outlook 搜索问题的方案:

Outlook 搜索不返回任何结果

使用 Outlook 搜索时未收到任何结果时,请按提供的顺序执行以下步骤:

  • 在 Windows 10中:选择"开始"按钮,选择"设置">"&"安全",然后选择"故障排除"。 找到并单击"搜索和索引",然后单击"运行疑难解答"。

  • 在 Windows 8.1:"开始"中,搜索"设置"。"设置" 中,搜索"疑难解答 ",然后选择 搜索结果中的"疑难解答"。 查找并运行 搜索和索引疑难解答

  • 在 Windows 7:"开始"中,选择"控制面板",然后选择"疑难解答"。 查找并运行 搜索和索引疑难解答

  1. 启动 Outlook 并单击“搜索”框。

  2. 在“搜索”菜单中,选择“搜索工具”>“索引状态”。

  3. 出现"索引状态"对话框时,应看到以下内容

    Outlook 搜索的索引编制状态

如果 Outlook 还没有完成索引,请记下还需编制索引的项目,等待五分钟,然后再次检查。 如果项目数目没有减少,继续执行下一步。

  1. 启动 Outlook 并单击“搜索”框。

  2. 在“搜索”菜单中,选择“搜索工具”>“要搜索的位置”。

  3. 确保已选择列出的所有数据文件/存储。

  1. 单击 Windows"开始"菜单,然后单击"搜索 " 框。

  2. 键入 services.msc, 然后按 Enter。

  3. 在"名称"列下,找到并双击"Windows 搜索"。

  4. 将"启动类型" ("延迟) "(如果还没有)。

  5. 如果"服务状态"未显示"正在运行",请单击其下方的"启动"按钮以启动服务。

  1. 退出 Outlook。

  2. 在 Windows 控制面板中,打开“索引选项”。

  3. 在“索引选项”对话框中,确保“Microsoft Outlook”列在“包含的位置”列中。

  4. 如果未列出“Microsoft Outlook”,选择“修改”,然后单击以启用“Microsoft Outlook”旁的复选框。

  5. 选择“确定”,然后选择“关闭”。

按照以下步骤执行操作,确保索引选项配置正确:

  1. 退出 Outlook。

  2. 在 Windows 控制面板中,打开“索引选项”。

  3. 在“索引选项”对话框中,选择“高级”。

  4. 选择“文件类型”选项卡。

  5. 向下滚动,直到在“扩展”列中找到“msg”,然后选中它。

  6. 请确保已启用“索引属性和文件内容”选项。

  7. 选择“确定”,然后选择“关闭”。

注意: 请确保“筛选器说明”列显示“Office Outlook MSG IFilter”。 如果未显示,则表明 Windows 搜索服务未正确运行,或 Microsoft Outlook 无法正确安装筛选器。 如果发生以上任一情况,应联系 Microsoft 支持人员,获得解决问题的帮助。

  1. 退出 Outlook。

  2. 在 Windows 控制面板中,打开“索引选项”。

  3. 在“索引选项”对话框中,选择“高级”。

  4. 在“高级选项”对话框中,选择“重新创建”。

  5. 选择“确定”,然后选择“关闭”。

如果索引没有完成,请联系 Microsoft 支持人员,请求有关 Windows 桌面搜索的帮助。

请按照以下步骤创建新的配置文件和测试搜索:

  1. 在 Outlook 中,选择“文件”>“帐户设置”>“管理配置文件”。 或者,可以退出 Outlook,然后在 Windows 控制面板中打开“邮件”。

  2. 在“邮件设置 - Outlook”对话框中,选择“显示配置文件”,然后在“常规”选项卡中选择“添加”。

  3. 在“配置文件名称”框中键入新配置文件的名称,然后选择“确定”。

  4. 如果出现提示,提供帐户信息(如电子邮件地址和密码),然后选择“下一步”。

  5. 选择“完成”。 你将发现添加的新配置文件名称列出在“邮件”对话框中的“常规”选项卡上。

  6. 在“启动 Microsoft Outlook 时使用此配置文件”下,选择“提示要使用的配置文件”,然后选择“确定”。

  7. 重新启动 Outlook。

  8. 在“选择配置文件”对话框中的下拉列表中,选择你创建的新配置文件名称,然后选择“确定”。

  9. 单击“搜索”框,然后尝试搜索。

如果搜索正常运行,则可能是旧的配置文件有问题。 可能需要将此配置文件设置为新的默认配置文件,然后将旧的配置文件中的信息转移到新的配置文件。

访问修复工具的步骤取决于您的操作系统。 请从下面的下拉列表中选择。

  • 选择操作系统
  • Windows 10
  • Windows 8 或 8.1
  • Windows 7 或 Windows Vista
  1. 右键单击“开始”按钮 Windows 8 和 Windows 10 中的 Windows“开始”按钮 (左下角),然后在弹出菜单中选择“应用和功能”。

    显示“应用和功能”的开始菜单屏幕截图
  2. 选择要修复的 Microsoft Office 产品,然后选择“修改”。

    注意: 即使要修复的只是一个应用程序(如 Word 或 Excel),此操作仍将修复整个 Office 套件。 若安装了独立的应用,则可按名称搜索此应用程序。

  3. 根据你的 Office 副本是即点即用安装还是基于 MSI 的安装,将看到以下修复选项。 请按照适用于你的安装类型的步骤进行操作。

    即点即用

    在“你想要如何修复 Office 程序”窗口中,选择“联机修复”>“修复”,以确保修复所有内容。 (还可以使用“快速修复”选项,此选项运行速度更快,但它只检测并替换已损坏的文件。)

    基于 MSI

    在“更改安装”中,选择“修复”,然后单击“继续”。

  4. 按照屏幕上的说明完成修复。

  1. 右键单击“开始”按钮 Windows 8 和 Windows 10 中的 Windows“开始”按钮 (在左下角),然后从弹出菜单中选择“控制面板”。

    按 Windows 徽标键 + X 后看到的选项和命令列表
  2. 从“程序”下的“类别”视图,选择“卸载程序”。

  3. 右键单击要修复的 Microsoft Office 产品,然后从下拉菜单中选择“更改”。

    注意: 如果你拥有的是套件,如 Microsoft 365 家庭版、Office 家庭和学生版 2016 或 Office 家庭和学生版 2013,请搜索套件名称,即便你只想修复 Word 或 Excel 等特定应用程序。 如果你拥有的是独立应用程序,如 Word 或者 Excel,请搜索应用程序名称。

  4. 根据你的 Office 副本是即点即用安装还是基于 MSI 的安装,执行以下操作:

    即点即用安装类型:

    在“你想要如何修复 Office 程序”中,选择“联机修复”以确保修复所有内容,然后选择“修复”。 (还可以使用“快速修复”选项,此选项运行速度更快,但它只检测并替换已损坏的文件。)

    基于 MSI 的安装类型:

    在“更改安装”中,选择“修复”,然后单击“继续”。

  5. 按照屏幕上的剩余说明完成修复。

  1. 单击“开始”按钮 Windows 7“开始”按钮 >“控制面板”。

  2. 在“类别”视图的“程序”下,选择“卸载程序”。

  3. 单击要修复的 Office 产品,然后单击“更改”。

    注意: 如果你拥有的是套件,如 Microsoft 365 家庭版、Office 家庭和学生版 2016 或 Office 家庭和学生版 2013,请搜索套件名称,即便你只想修复 Word 或 Excel 等特定应用程序。 如果你拥有的是独立应用程序,如 Word 或者 Excel,请搜索应用程序名称。

  4. 根据你的 Office 副本是即点即用安装还是基于 MSI 的安装,执行以下操作:

    即点即用安装类型:

    在“你想要如何修复 Office 程序”中,选择“联机修复”以确保修复所有内容,然后选择“修复”。 (还可以使用“快速修复”选项,此选项运行速度更快,但它只检测并替换已损坏的文件。)

    基于 MSI 的安装类型:

    在“更改安装”中,选择“修复”,然后单击“继续”。

  5. 按照屏幕上的剩余说明完成修复。

  1. 单击以下按钮可以下载和安装 Office 卸载支持工具。

  2. 按照以下步骤下载对应于你的浏览器的卸载支持工具。

    提示: 该工具可能需要几分钟才能下载并安装。 完成安装后,会打开卸载 Office 产品窗口。

    Microsoft Edge 或 Chrome

    • 在左下角,右键单击“SetupProd_OffScrub.exe”>“打开”。

      在 Chrome Web 浏览器的何处查找和打开支持助理下载文件

    MIcrosoft Edge(之前版本) 或 Internet Explorer

    • 在浏览器窗口底部,选择“运行”以启动 SetupProd_OffScrub.exe

      在 Microsoft Edge 或 Internet Explorer Web 浏览器的何处查找和打开支持助理下载文件

    Firefox

    • 在弹出窗口,选择“保存文件”,然后在浏览器窗口的右上角,选择“下载”箭头 > SetupProd_OffScrub.exe

      在 Chrome Web 浏览器的何处查找和打开支持助理下载文件
  3. 选择要卸载的版本,然后选择“下一步”。

  4. 执行剩余屏幕上的操作,在出现提示时,重启计算机。

    重启计算机后,卸载工具会自动重新打开以完成卸载过程的最后一步。 按照剩余提示操作。

  5. 选择要安装或重新安装的 Office 版本的步骤。 关闭卸载工具。

    Microsoft 365 | Office 2019 | Office 2016 | Office 2013 | Office 2010 | Office 2007

注意: 如果这些步骤没有帮助,请尝试本文中的高级步骤:POP、IMAP或 Exchange 帐户没有搜索结果

Outlook 搜索返回不完整的结果

使用 Outlook 搜索获得不完整的结果时,请按提供的顺序执行以下步骤:

如果缺少的搜索结果在"已删除邮件"文件夹中,可以将此文件夹添加到搜索结果中:

  1. 启动 Outlook。

  2. 单击"文件>选项",然后选择"搜索"。

  3. 在"所有项目"中搜索时,选中"在每个数据文件包含已删除邮件"文件夹中的邮件复选框,然后单击"确定"。

  4. 重新启动 Outlook。

您可以增加电子邮件帐户的脱机设置中的时间,以便本地缓存更多或所有电子邮件以编制索引。 要执行此操作:

  1. 启动 Outlook。

  2. 单击“文件” > “帐户设置” > “帐户设置”。

  3. 在"电子邮件"选项卡上,选择电子邮件帐户,然后单击"更改"。

  4. "下载过去的电子邮件:"滑块拖动到所需时间量,或将最右侧拖动到"所有"。

  5. 单击"下一步",然后单击"完成"。 关闭窗口并重启 Outlook。

默认情况下,Outlook 将显示 250 个搜索结果。 可以增大此范围以显示所有结果,但搜索速度会变慢。 要执行此操作:

  1. 打开 Outlook。

  2. 单击"文件>选项",然后选择"搜索"。

  3. 清除"通过限制显示的结果数来提高搜索速度"复选框,然后单击"确定"。

  4. 重新启动 Outlook。

使用"所有 邮箱"或 "所有 Outlook 项目"范围在 Outlook 中搜索时,"存档邮箱"返回的结果有限或无。 仅通过搜索文件夹本身,才能搜索已移至自动展开存档邮箱的项目。 选择文件夹列表中的存档文件夹,选择" 当前文件夹 "选项作为搜索范围。 如果自动扩展的存储区域中的文件夹包含子文件夹,必须单独搜索每个子文件夹。 有关详细信息,请参阅 Microsoft 365 中无限存档的概述

Outlook 搜索无法找到较早的电子邮件

当使用 Outlook 搜索找不到超过 6 个月的电子邮件时,请按提供的顺序执行以下步骤:

如果缺少的搜索结果在"已删除邮件"文件夹中,可以将此文件夹添加到搜索结果中:

  1. 启动 Outlook。

  2. 单击"文件>选项",然后选择"搜索"。

  3. 在"所有项目"中搜索时,选中"在每个数据文件包含已删除邮件"文件夹中的邮件复选框,然后单击"确定"。

  4. 重新启动 Outlook。

您可以增加电子邮件帐户的脱机设置中的时间,以便本地缓存更多或所有电子邮件以编制索引。 要执行此操作:

  1. 启动 Outlook。

  2. 单击“文件” > “帐户设置” > “帐户设置”。

  3. 在"电子邮件"选项卡上,选择电子邮件帐户,然后单击"更改"。

  4. "下载过去的电子邮件:"滑块拖动到所需时间量,或将最右侧拖动到"所有"。

  5. 单击"下一步",然后单击"完成"。 关闭窗口并重启 Outlook。

默认情况下,Outlook 将显示 250 个搜索结果。 可以增大此范围以显示所有结果,但搜索速度会变慢。 要执行此操作:

  1. 打开 Outlook。

  2. 单击"文件>选项",然后选择"搜索"。

  3. 清除"通过限制显示的结果数来提高搜索速度"复选框,然后单击"确定"。

  4. 重新启动 Outlook。

"搜索"选项卡在 Outlook 2016 (灰)

升级到 Windows 10 版本 1709 及更早版本后可能会发生此问题。 此问题在 Windows 10 版本 1803 和更高版本中已修复。 若要解决此问题,请执行以下步骤:

访问修复工具的步骤取决于您的操作系统。 请从下面的下拉列表中选择。

  • 选择操作系统
  • Windows 10
  • Windows 8 或 8.1
  • Windows 7 或 Windows Vista
  1. 右键单击“开始”按钮 Windows 8 和 Windows 10 中的 Windows“开始”按钮 (左下角),然后在弹出菜单中选择“应用和功能”。

    显示“应用和功能”的开始菜单屏幕截图
  2. 选择要修复的 Microsoft Office 产品,然后选择“修改”。

    注意: 即使要修复的只是一个应用程序(如 Word 或 Excel),此操作仍将修复整个 Office 套件。 若安装了独立的应用,则可按名称搜索此应用程序。

  3. 根据你的 Office 副本是即点即用安装还是基于 MSI 的安装,将看到以下修复选项。 请按照适用于你的安装类型的步骤进行操作。

    即点即用

    在“你想要如何修复 Office 程序”窗口中,选择“联机修复”>“修复”,以确保修复所有内容。 (还可以使用“快速修复”选项,此选项运行速度更快,但它只检测并替换已损坏的文件。)

    基于 MSI

    在“更改安装”中,选择“修复”,然后单击“继续”。

  4. 按照屏幕上的说明完成修复。

  1. 右键单击“开始”按钮 Windows 8 和 Windows 10 中的 Windows“开始”按钮 (在左下角),然后从弹出菜单中选择“控制面板”。

    按 Windows 徽标键 + X 后看到的选项和命令列表
  2. 从“程序”下的“类别”视图,选择“卸载程序”。

  3. 右键单击要修复的 Microsoft Office 产品,然后从下拉菜单中选择“更改”。

    注意: 如果你拥有的是套件,如 Microsoft 365 家庭版、Office 家庭和学生版 2016 或 Office 家庭和学生版 2013,请搜索套件名称,即便你只想修复 Word 或 Excel 等特定应用程序。 如果你拥有的是独立应用程序,如 Word 或者 Excel,请搜索应用程序名称。

  4. 根据你的 Office 副本是即点即用安装还是基于 MSI 的安装,执行以下操作:

    即点即用安装类型:

    在“你想要如何修复 Office 程序”中,选择“联机修复”以确保修复所有内容,然后选择“修复”。 (还可以使用“快速修复”选项,此选项运行速度更快,但它只检测并替换已损坏的文件。)

    基于 MSI 的安装类型:

    在“更改安装”中,选择“修复”,然后单击“继续”。

  5. 按照屏幕上的剩余说明完成修复。

  1. 单击“开始”按钮 Windows 7“开始”按钮 >“控制面板”。

  2. 在“类别”视图的“程序”下,选择“卸载程序”。

  3. 单击要修复的 Office 产品,然后单击“更改”。

    注意: 如果你拥有的是套件,如 Microsoft 365 家庭版、Office 家庭和学生版 2016 或 Office 家庭和学生版 2013,请搜索套件名称,即便你只想修复 Word 或 Excel 等特定应用程序。 如果你拥有的是独立应用程序,如 Word 或者 Excel,请搜索应用程序名称。

  4. 根据你的 Office 副本是即点即用安装还是基于 MSI 的安装,执行以下操作:

    即点即用安装类型:

    在“你想要如何修复 Office 程序”中,选择“联机修复”以确保修复所有内容,然后选择“修复”。 (还可以使用“快速修复”选项,此选项运行速度更快,但它只检测并替换已损坏的文件。)

    基于 MSI 的安装类型:

    在“更改安装”中,选择“修复”,然后单击“继续”。

  5. 按照屏幕上的剩余说明完成修复。

共享邮箱:搜索结果问题

如果未从共享邮箱搜索获取预期结果或收到错误,请执行以下步骤之一:

禁用服务器搜索作为短期解决方案。 请按以下步骤完成此操作:

重要: 下列步骤演示如何修改注册表。 但如果注册表修改不当,可能造成严重问题。 请确保仔细按照下列步骤操作。 为增强保护,请在修改前备份注册表。 然后,即可在出现问题时还原注册表。 有关如何备份和还原注册表的详细信息,请转到如何备份和还原 Windows 中的注册表

  1. 在 Windows 中,右键单击“开始”,然后选择“运行”。 在“打开”框中键入 regedit,然后单击“确定”。 这将打开注册表编辑器。

  2. 在注册表编辑器对话框中,在注册表中查找此子项,并单击它:

    • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Search

  3. 单击“编辑”>“新建”>“DWORD 值”。

  4. 键入 DisableServerAssistedSearch 作为 DWORD 的名称,然后按 Enter。

  5. 右键单击"DisableServerAssistedSearch",并单击"修改"。

  6. 在"数据"框中,键入 1 以启用注册表项,然后单击"确定"。

  7. 关闭注册表编辑器,然后重启 Windows。

注意: 此策略和其他重要注意事项记录在搜索 博客 上

若要搜索共享邮箱,请单击该邮箱并使用"当前 文件夹" 范围。 这是一个设计限制,当前正在针对将来的更新进行开发。 有关何时 支持哪些 范围的更多详细信息,请转到此了解搜索范围博客。

若要解决此问题,可以将共享邮箱作为辅助 Exchange 帐户添加到配置文件。 首先,需要检查共享邮箱是否已在配置文件中列为帐户。 如果是这样,必须将其删除。 请按以下步骤完成此操作:

  • 在" 文件" 菜单中,选择 "帐户设置",然后再次 选择"帐户设置 "。

  • 双击 Exchange 帐户。

  • 选择 "更多设置",然后选择" 高级" 选项卡。

  • 在"打开这些附加邮箱"部分中,选择共享邮箱,然后选择"删除"。

按照以下步骤将共享邮箱作为辅助帐户添加到配置文件:

  • 在"文件"菜单中,选择"添加帐户"。

  • 在此对话框中,输入邮箱的完整名称,例如 support@company.com。

  • 当系统提示输入密码时,请选择选项" 使用 另一个帐户登录",并使用对共享邮箱具有权限的 Exchange 帐户凭据。

搜索添加为其他邮箱的共享邮箱时,可能会看到此错误:

  • "从服务器提取结果时遇到问题。 某些项目可能不包含在搜索结果中。"

如果使用永久批量许可证或 MSI 版本 (,) 会发生这种情况。 Office 永久版本目前存在此限制。

若要解决这一问题,可以禁用服务器搜索作为短期解决方案。 请按以下步骤完成此操作:

重要: 下列步骤演示如何修改注册表。 但如果注册表修改不当,可能造成严重问题。 请确保仔细按照下列步骤操作。 为增强保护,请在修改前备份注册表。 然后,即可在出现问题时还原注册表。 有关如何备份和还原注册表的详细信息,请转到如何备份和还原 Windows 中的注册表

  1. 在 Windows 中,右键单击“开始”,然后选择“运行”。 在“打开”框中键入 regedit,然后单击“确定”。 这将打开注册表编辑器。

  2. 在注册表编辑器对话框中,在注册表中查找此子项,并单击它:

    • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Search

  3. 单击“编辑”>“新建”>“DWORD 值”。

  4. 键入 DisableServerAssistedSearch 作为 DWORD 的名称,然后按 Enter。

  5. 右键单击"DisableServerAssistedSearch",并单击"修改"。

  6. 在"数据"框中,键入 1 以启用注册表项,然后单击"确定"。

  7. 关闭注册表编辑器,然后重启 Windows。

注意: 此策略和其他重要注意事项记录在搜索 博客 上

在 Microsoft Outlook 2016 for Mac 中,尝试搜索电子邮件或将筛选器应用于文件夹时,可能会收到"无结果"消息,任务项目不会显示在"任务"文件夹中。 此外,使用 Mac OS 本机聚焦搜索搜索邮件项目时,搜索可能失败。

发生这种情况的原因如下:

  • 聚焦搜索索引编制不完整。

  • 配置文件名称包含特殊字符,例如 / (的斜杠) 。

  • "配置文件"或其父文件夹之一将添加到"聚焦"中的"隐私"选项卡。

  • Outlook 15 配置文件文件夹不位于 ~/Library/Group Containers/UBF8T346G9 下。Office/Outlook。

  • 聚焦搜索索引已损坏。

若要解决此问题,请执行以下步骤:

  1. 运行 OutlookSearchRepair 实用工具。

  2. 如果你最近在 Outlook 2016 for Mac 中创建了一个新的 Outlook 配置文件、添加了一个新帐户,或者你最近从 PST 或 OLM 文件等源导入了新数据,则聚焦索引编制可能不完整。 在这种情况下,Outlook for Mac 将显示"无结果"消息。 若要解决此问题,请等待索引编制完成,然后再次搜索。

  3. 请确保 Outlook 2016 for Mac 中的个人资料名称没有特殊字符,例如/ (斜) 。

在 Outlook 2016 for Mac 中查看个人资料或标识名称:

  1. 单击"转到,应用程序"。

  2. Right-Click Microsoft Outlook,然后选择"显示程序包内容"。

  3. 展开"内容","共享""支持",并打开"Outlook 配置文件管理器"。


如果配置文件或标识名称包含特殊字符,请按照以下步骤更改名称:

  1. 打开 Outlook 2016 for Mac 配置文件文件夹,该文件夹位于:/Users/<用户名>/Library/Group Containers/UBF8T346G9。Office/Outlook/Outlook 15 配置文件/

  2. 重命名 Outlook 2016 for Mac 配置文件文件夹名称并删除特殊字符。

如果问题仍未解决,则聚焦索引可能已损坏。 若要为 Spotlight 索引重新编制索引,请执行以下步骤:

  1. 重新启动 Mac,以便重新启动 Spotlight 服务。

  2. 导航到"Finder > Applications > Utilities > Terminal"。

  3. 键入 mdimport -L。

    重要: 如果看到多个"Microsoft Outlook Spotlight Importer.mdimporter"实例,请删除您未使用的 Outlook 应用程序,将其从回收站清空,重新启动 Mac,然后返回到步骤 1.。

  4. 在终端中,通过以下命令重新索引 Outlook 数据库,并替换自己的用户名作为 <user_name> 占位符:mdimport -g "/Applications/Microsoft Outlook.app/Contents/Library/Spotlight/Microsoft Outlook Spotlight Importer.mdimporter" -d1 "/Users/<user_name>/Library/Group Containers/UBF8T346G9。Office/Outlook/Outlook 15 配置文件/<my_profile_name>"

    注意: 在此命令中,"-g"后的路径是 Outlook 安装的默认路径。 "-d1"后的路径是配置文件的默认路径,其中<my_profile_name>默认为"主配置文件"。 如果已重命名配置文件或在不同位置安装了 Outlook,必须替换实际路径。

重新索引需要一些时间才能完成。 该过程完成后,退出,然后重新启动 Outlook。 

如果执行这些步骤后仍无法在 Spotlight 中搜索,并且如果已允许足够时间完成聚焦索引,可能需要卸载Office for Mac重新安装。 

另请参阅

了解如何缩小搜索条件的范围以便在 Outlook 中更好地搜索

使用“即时搜索”查找邮件或项目

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×