适用于 Azure Site Recovery 的更新汇总 36

应用对象
Azure Site Recovery

简介

本文介绍更新汇总 36 中针对以下版本的 Microsoft Azure Site Recovery 修复的问题:

详细了解 已修复问题 的详细信息,以及安装此更新之前应验证的 先决条件

更新信息

先决条件

若要安装 Microsoft Azure Site Recovery 提供程序更新汇总 36 (版本 5.1.4150.0) ,必须安装以下内容之一:

  • Microsoft Azure Hyper-V 恢复管理器 (版本 3.4.486 或更高版本)
  • Microsoft Azure Site Recovery Hyper-V 提供程序 (版本 4.6.660 或更高版本)
  • Microsoft Azure Site Recovery 提供程序 (版本 5.1.3700 或更高版本)
  • Microsoft Azure Site Recovery VMware 统一安装程序 (Azure) (版本 9.20。xxxx.X 或更高版本)

备注可以在控制面板的程序和功能项中检查已安装的提供程序版本。

 

此更新中修复的问题

应用此更新后,将修复以下问题,并进行了以下改进。
 

Microsoft Azure Site Recovery提供程序

改进

A2A:

  • 通过 PowerShell 支持) 改进了服务 (的证书过期和续订支持。
  • 虚拟机 (VM) 从服务进行区域内移动支持。
  • 改进了监视体验。
  • 支持将新磁盘添加到受保护的 VM。
  • 若要启用自动更新用于复制 Azure VM 的代理,需要使用自动化帐户。 以前,这是 Site Recovery 创建的默认帐户。 现在,可以选择其他现有自动化帐户。 为 VM 启用复制时,可以找到此选项。 更改作为特定恢复服务保管库的一部分受到保护的 VM 的设置适用于在同一保管库中受保护的所有 Azure VM。

已修复的问题

A2A:

  • 新的验证程序,用于检查可用性集和 VM 资源组是否不同,以便在故障转移之前警告用户。
  • 故障回复增强功能,用于在从源区域删除 VM 时处理该场景。
  • 修复了在随机资源组(而不是客户指定的资源组)中创建缓存存储帐户的问题。
  • 修复了检查区域中的可用性区域时 VM 保护失败的问题。
  • 修复了删除源 VM 系统磁盘时重新保护失败的问题。
  • 修复了故障回复期间如果未检索可用性区域属性,UI 将卡在进程中的问题。
  • 添加用于删除由 ASR 在交叉订阅中创建的过时资源链接的逻辑。

 

Microsoft Azure Site Recovery 统一安装和配置服务器模板

改进

配置服务器监视改进:

针对以下方案增强了错误消息,以提供明确的根本原因和建议的操作:

  • vCenter 已断开连接
  • 进程服务器已断开连接
  • CS 已断开连接
  • 进程服务器没有检测信号
  • MT 已断开连接
  • VM 关闭
  • 已删除 VM

 

进程服务器监视

为进程服务器添加了以下警报以改进监控:

  • CPU、内存和可用空间警报,用于监视资源使用情况
  • 在关键 ASR 服务未运行时发出警报

 

进程服务器选择产品内指南

在为 新复制选择进程服务器期间,将根据资源可用性和连接运行状况显示进程服务器 (关键、警告和正常) 的运行状况。

注意

  • 关键进程服务器无法用于启用新 VM 的复制。
  • 虽然您可以选择显示警告状态的进程服务器,但我们不建议您这样做。 任何其他工作负载都可能影响现有工作负载。
  • 标记为正常的进程服务器可用于保护新服务器。

有关进程服务器指南的详细信息,请参阅 https://aka.ms/asr_ps_selection_guidance
 

已修复的问题

(不适用)

 

移动服务

已修复的问题:适用于 VMware VM 的 DR

  • 减小了影响 Ubuntu*、Debian*、SLES 12 的移动代理安装程序的大小 (- 推送安装和升级)

  • 仅当有关联的驱动程序更改时才显示重启警告

  • 安装程序错误消息增强功能,提供明确的失败问题的根本原因

  • 增强服务启动日志记录机制

  • 修复了物理环境或 VMware 环境中符合无冻结条件的基于 Windows Server 2019 的计算机的故障转移问题

  • 修复了移动代理升级中返回错误代码 95507 的故障

  • 对于 VMware 到 Azure 和 Azure 到 Azure DR 方案,可以保护以下操作系统:

    • Windows 10 (x64)
    • Windows 8.1 (x64)
    • Windows 8 (x64)
    • Windows 7 (x64) SP1 及更高版本 (Windows 7 RTM 不受支持)

已修复的问题

  • 修复了在 Windows Server 2019 中脱机显示数据磁盘偶尔出现的问题。

 

Microsoft Azure Site Recovery (服务)

改进

配置为具有虚拟网络防火墙的 Azure 存储帐户现在支持从 VMware 或物理服务器将数据复制到 Azure。
 

已修复的问题

(不适用)

 

Microsoft Azure Site Recovery (门户)

改进

对于从 VMware 到 Azure,进程服务器运行状况状态会添加到 VM 概述视窗。 在进程服务器上引发的事件将添加到“进程服务器”边栏选项卡上的事件表中。
 

已修复的问题

(不适用)

 

更新 Azure Site Recovery 本地组件

在两个本地 VMM 站点之间

  1. 下载 Microsoft Azure Site Recovery 提供程序的最新更新汇总。
  2. 首先在管理恢复站点的本地 VMM 服务器上安装该更新汇总。
  3. 更新恢复站点后,在管理主站点的 VMM 服务器上安装该更新汇总。

备注 如果 VMM 是高可用性 VMM (群集 VMM) ,请确保在安装 VMM 服务的群集的所有节点上安装升级。
 

在本地 VMM 站点和 Azure 之间

  1. 下载 Microsoft Azure Site Recovery 提供程序的更新汇总。
  2. 在本地 VMM 服务器上安装此更新汇总。
  3. 在所有 Hyper-V 主机上安装最新的 MARS 代理。

备注 如果你的 VMM 是高可用性 VMM (群集 VMM) ,请确保在安装 VMM 服务的群集的所有节点上安装升级。
 

在本地 Hyper-V 站点和 Azure 之间

  1. 下载 Microsoft Azure Site Recovery 提供程序的更新汇总。
  2. 在已在 Azure Site Recovery 中注册的 Hyper-V 服务器的每个节点上安装提供程序。

备注 如果你的 Hyper-V 是主机群集 Hyper-V 服务器,请确保在群集的所有节点上安装升级
 

从本地 VMware 或物理站点到 Azure

  1. 更新本地管理服务器。 这是具有配置服务器和进程服务器角色的服务器。 为此,请下载并运行 Microsoft Azure Site Recovery 统一安装程序
  2. 如果您有横向扩展进程服务器,接下来请运行 Microsoft Azure Site Recovery Unified Setup 来更新它们。
  3. 转到 Azure 门户,然后转到“受保护的项>复制的项”页。 在此页上选择一个 VM。 选择显示在每个虚拟机的页面底部的 “更新代理 ”按钮。 这将更新所有受保护 VM 上的移动服务代理。

建议在每次升级移动代理后重新启动,以确保在源虚拟机上加载所有最新更改。 但是,重启 不是强制性的。 如果上次重新启动期间的代理版本与当前版本之间的差异大于 4 (4) ,则必须重新启动。 有关详细说明,请参阅下表。

上次重启期间的代理版本 升级到版本 是否需要重新启动?
9.16 9.18 非必需
9.16 9.19 非必需
9.16 9.20 非必需
9.16 9.21 必需

首先,升级到 9.20 版本。 然后,在升级到 9.21 之前重启。 这是因为执行上次重启的 9.16 (版本与目标版本 9.21) 之间的差异大于 4 (4) 。

参考资料

了解 Microsoft 用于描述软件更新的术语

第三方信息免责声明

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。