简介
本文介绍更新汇总 2 中为 Microsoft System Center 2016 Data Protection Manager 修复的问题。 它还包含此更新的安装说明。
注意现有 Data Protection Manager 到 Windows Azure 客户应升级到最新的代理 (版本 2.0.9062.0 或更高版本) 。 如果未安装最新的代理,则联机备份可能会失败,并且 Windows Azure操作无法正常运行的 Data Protection Manager。
宣布备份 SQL Server 2016 和 SharePoint 服务器 2016
安装此更新后,可以无缝备份 SQL Server 2016 和 SharePoint 服务器 2016 工作负载。
宣布增强备份的安全性
此更新包括对 Azure 备份 安全功能的以下改进。 这些改进提高了对重要业务数据的对抗攻击的复原能力和可恢复性。
保留已删除的备份数据
现在可以将Azure 备份配置为从删除之日起 14 天内保留因对抗攻击而删除的任何备份数据。 这样,在受到攻击后,可以更轻松地恢复数据。
最小保留期范围
最小保留期检查确保攻击后有多个恢复点可用。
Azure基于门户的身份验证
现在可以将Azure 备份配置为请求对影响组织数据备份和恢复的重要操作Azure基于门户的身份验证。
安全警报和通知
可以设置Azure 备份,以在运行影响数据保护计划的重要操作时接收安全警报和通知。 这使你可以密切监视未经授权的人员进行的任何侵入性操作。
注意若要访问这些功能,请确保计算机或服务器已注册到 Azure 恢复服务保管库。
此更新汇总中已修复的问题
当文件路径的长度较长时,文件名不会显示在“ 恢复 ”选项卡上。
使用 RCT 的 VM 备份在 CC 后失败。
Windows Server 2008 R2 Service Pack 1 的 BMR 备份失败。
备份失败,并显示错误,指出无法装载或卸载包含副本 (replica) 或副本 (replica) 快照的 VHD。
将工作负载从新式备份存储迁移到或迁移到新式备份存储时,Data Protection Manager 崩溃。
除了磁盘备份之外,还启用了SQL Server数据库的自动保护,以便备份到Azure。
DPM 服务器的 VM 备份失败,并生成以下错误消息:
注意
Microsoft Hyper-V VM 名称对<服务器名称>>的<副本 (replica) 与受保护的数据源不一致。
DPM 已检测到受保护对象的文件位置或卷配置中的更改,因为数据源已配置为保护。 (ID30135)
如何获取和安装 System Center 2016 Data Protection Manager 的更新汇总 2
下载信息
可从 Microsoft 更新或手动下载获取 Data Protection Manager 的更新包。
Microsoft 更新
若要从 Microsoft Update 获取并安装更新包,请在安装了 Data Protection Manager 组件的计算机上执行以下步骤。
如果运行的是基于 R2 的计算机Windows Server 2012:
- 单击“开始”,然后单击“控制面板”。
- 在“控制面板”中,双击“Windows 更新”。
- 在“Windows 更新”窗口中,单击“联机检查Microsoft更新中的更新”。
- 单击“ 重要更新可用”。
- 选择更新汇总包,然后单击“ 确定”。
- 单击“ 安装更新” 以安装更新包。
如果运行的是基于 Windows Server 2016 的计算机:
- 单击“ 开始”,然后单击“ 设置”。
- 在“设置”中,单击“汇报 &安全性”。
- 在“Windows 更新”选项卡上,单击“联机检查Microsoft更新中的更新”。
- 单击“ 重要更新可用”。
- 选择更新汇总包,然后单击“ 确定”。
- 单击“ 安装更新”。
手动下载更新包
转到以下网站,从Microsoft更新目录手动下载更新包:
立即下载 Data Protection Manager 更新包。
安装说明
若要为 Data Protection Manager 安装此更新,请执行以下步骤:
- 在安装此更新之前,请备份 Data Protection Manager 数据库。
- 在运行 System Center 2016 Data Protection Manager 的服务器上安装此汇总包。 为此,请在服务器上运行 Microsoft Update。
- 在 Data Protection Manager 管理员控制台中,更新保护代理。 若要完成此操作,请使用以下方法之一。
注意 此更新汇总代理更新不需要重启受保护的服务器。
方法 1:从 Data Protection Manager 管理员控制台更新保护代理
- 打开 Data Protection Manager 管理员控制台。
- 单击“ 管理 ”选项卡,然后单击“ 代理 ”选项卡。
- 在“受保护的计算机”列表中,选择一台计算机,然后在“操作”窗格中单击“更新”。
- 单击“ 是”,然后单击“ 更新代理”。
方法 2:更新受保护服务器上的保护代理
从 System Center 2016 Data Protection Manager 服务器上的以下目录获取更新保护代理包:
Data_Protection_Manager_installation_location\DPM\DPM\Agents\RA\5.0.322.0
安装包如下所示:-
- 对于基于 x86 的更新: i386\1033\DPMProtectionAgent_KB3209593.msp
- 对于基于 x64 的更新: amd64\1033\DPMProtectionAgent_KB3209593_AMD64.msp
在每个受保护的服务器上运行相应的 DPMProtectionAgent.msp 包,具体取决于代理的体系结构。
在 System Center 2016 Data Protection Manager 服务器上打开 Data Protection Manager 管理员控制台。
单击“ 管理 ”选项卡,然后单击“ 代理 ”选项卡。选择受保护的服务器,更新信息,然后验证代理版本号是否为 5.0.322.0。