使用适用于 Outlook 的 Microsoft Dynamics CRM 客户端时,Outlook 功能区将从 Outlook 中消失

本文可帮助你修复使用适用于 Microsoft Office Outlook 的 Microsoft Dynamics CRM 客户端后 Outlook 功能区消失的问题。

适用范围:Microsoft Dynamics CRM 2011
原始 KB 编号: 2494581

症状

安装适用于 Microsoft Office Outlook 的 Microsoft Dynamics CRM 客户端,然后在 Microsoft Office Outlook 中找到Microsoft Dynamics CRM文件夹后,Outlook 和 CRM 功能区将消失。 此外,除非禁用Microsoft Dynamics CRM,否则 Office Outlook 功能区不会重新出现。

原因

出现此行为的原因可能是早期版本的 Microsoft Outlook 中遗留的注册表项。

解决方案

重要

本文包含有关如何更改注册表的信息。 在更改注册表之前,请确保备份注册表。 并且一定要知道在发生问题时如何还原注册表。 有关如何备份、还原和更改注册表的详细信息,请参阅 如何在 Windows 中备份和还原注册表

  1. 退出 Outlook。

  2. 单击 “开始”,单击“ 运行”,键入 regedit,然后单击“ 确定”。

  3. 找到以下注册表子项:

    HKEY_CLASSES_ROOT\TypeLib\{2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}

  4. 在此位置中,你可能会找到与以下 Office 版本对应的文件夹:

    • 2.4 for Office 2007 (版本 12.0.0.0)
    • 2.5 for Office 2010 (版本 14.0.0.0)
    • 2.6 和 2.7 for Office 2013 (版本 15.0.0.0) (2.6 和 2.7 也适用于 Office 2016,前提是在 2.7.)
    • 2.8 for Office 2016 (版本 16.0.0.0)
  5. 右键单击不正确的 Office 版本的注册表项,然后选择“ 导出”。 将导出保存到桌面以创建备份。

  6. 右键单击不正确的 Office 版本的密钥,选择“ 删除”。

  7. 启动 Outlook。