使用 Microsoft Dynamics 365 App for Outlook 时显示“无法连接到 Exchange”消息
本文提供有关在使用 Microsoft Dynamics 365 App for Outlook 时收到“无法连接到 Exchange”消息的问题的解决方法。
适用于:Microsoft Dynamics 365 Customer Engagement Online
原始 KB 数: 4534356
症状
使用 Microsoft Dynamics 365 App for Outlook 时,会看到以下消息:
“无法连接到 Exchange”。
应用的其余部分可能会成功加载,但跟踪项目和使用 Set Regarding 的功能可能缺失。
原因
这通常在使用 Microsoft Exchange 本地邮箱时发生,可能由以下原因之一引起:
原因 1: Exchange 中未启用 OAuth 身份验证。
原因 2: Exchange 使用的身份验证证书存在问题。
解决方法 1:验证是否在 Exchange 中启用了 OAuth 身份验证
在 Exchange 服务器上,打开 Exchange 命令行管理程序。
运行以下命令:
Get-WebServicesVirtualDirectory | FL server,*auth
验证返回的结果是否显示 OAuthAthentication 设置为 True。
如果
OAuthAthentication
设置为 False,则需要运行如下所示的命令:Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -OAuthAuthentication $true
标识值是可在 Exchange 管理员中心找到的虚拟目录的名称,方法是选择服务器,然后选择虚拟目录,或者运行以下命令并查看返回的名称值:
Get-WebServicesVirtualDirectory | FL
有关此命令的详细信息,请参阅 Set-WebServicesVirtualDirectory。
有关允许 Outlook 外接程序将异步 Exchange Web 服务 (EWS) 请求的身份验证要求的详细信息,请参阅 makeEwsRequestAsync 的身份验证和权限注意事项。
运行以下命令:
Get-OrganizationConfig | FL OAuth2ClientProfileEnabled
如果返回的值为 False,请运行以下命令:
Set-OrganizationConfig -OAuth2ClientProfileEnabled:$True
还要验证 Exchange 版本是否具有在 2016 Exchange Server 2016 年和 2013 Exchange Server无法通过 makeEwsRequestAsync 从 Outlook/OWA 加载项访问 EWS 中所述的更新。
解决方法 2:验证 Exchange 证书
在 Exchange 服务器上,打开 Exchange 命令行管理程序。
运行以下命令:
Get-AuthConfig | FL
验证结果将 IsValid 显示为 True。
复制为 CurrentCertificateThumbprint 返回的值,并在以下命令中使用它:
Get-ExchangeCertificate -Thumbprint <CurrentCertificateThumbprint Value>| FL
验证结果是否显示以下内容:
Status = Valid
当前日期在 NotAfter 和 NotBefore 日期内,指示证书未过期。
如果前面的命令未成功检索证书,则表示证书配置存在问题,可能需要创建和配置新证书。 下面是一些资源,其中包含创建和配置新证书的步骤:
如果在执行上述步骤后需要进行任何更改,请关闭并重新打开 Outlook 以查看问题是否已解决。 如果问题仍然存在,并且 Microsoft Exchange 管理员已验证已启用 OAuth 且证书有效,则可能需要联系 Microsoft 支持部门。
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