电子邮件未同步,因为电子邮件地址已针对其他组织配置错误

本文为尝试在 Microsoft Dynamics 365中测试和启用邮箱时列出的错误提供了解决方法。

适用范围:Microsoft Dynamics CRM
原始 KB 编号: 4053618

症状

尝试在 Microsoft Dynamics 365 中测试和启用邮箱时,会记录以下警报之一:

未同步传入电子邮件,因为邮箱名称>邮箱的电子邮件地址<是为另一个Dynamics 365组织配置的。 要求管理员为当前组织测试并启用邮箱,并将非主要组织的同步方法更改为“无”。
Email服务器错误代码:IncomingIncorrectCrmOrgError

未发送传出邮件,因为电子邮件地址<电子邮件地址>是为另一个Dynamics 365组织配置的。 要求管理员为当前组织测试并启用邮箱,并将非首要组织的同步方法更改为“无”。
Email服务器错误代码:OutgoingIncorrectCrmOrgError

无法同步约会、联系人和任务,因为邮箱<邮箱名称>的电子邮件地址配置了另一个 Microsoft Dynamics 365 组织。 最佳做法是在主要组织中测试和启用邮箱时覆盖配置。 此外,将非主要组织中的邮箱的同步方法更改为“无”。
Email服务器错误代码:ExchangeSyncIncorrectCrmOrgError

如果在警报中选择“ 查看详细信息 ”,则可能还会看到以下更多详细信息:

异常:Exchange 上的检查和更新配置文件夹失败。

原因

Exchange 邮箱只能配置为 Server-Side 与一个 Microsoft Dynamics 365 组织同步。 如果你有多个 Microsoft Dynamics 365 组织,并尝试将邮箱配置为使用与多个组织的 Server-Side 同步,则记录这些警报。

解决方案

在主要 Microsoft Dynamics 365 组织中测试和启用邮箱

  1. 登录到要配置为使用 Exchange 邮箱 Server-Side 同步的 Microsoft Dynamics 365 组织。

  2. 导航到“设置”,然后选择“Email配置”。

  3. 选择 “邮箱”。

  4. 将所选视图从“我的活动邮箱”更改为 “活动邮箱”。

  5. 选择要启用 Server-Side 同步的邮箱,然后选择“ 测试 & 启用邮箱 ”按钮。

    重要

    请确保选中出现的对话框中的 复选框 ,然后选择“ 确定”。 如果 Exchange 邮箱以前配置了另一个 Microsoft Dynamics 365 组织,则选中此复选框将更新 Exchange 邮箱以改为与 Microsoft Dynamics 365 组织同步。 如果未选中此复选框,并且 Exchange 邮箱已配置了另一个 Microsoft Dynamics 365 组织,则测试将失败并记录本文症状部分中列出的警报之一。

  6. 等待测试 & 启用过程完成。 如果测试结果不是“成功”,请查看邮箱记录中的“警报”区域。

将非主要 Microsoft Dynamics 365 组织的同步方法更改为“无”

如果有多个 Microsoft Dynamics 365 组织,请将非主要组织中的用户邮箱配置为同步方法 () 设置为 None。 例如:如果你有一个用于生产的 Microsoft Dynamics 365 组织,而另一个组织用于测试,则可以使用户能够在其中一个组织中使用 Server-Side 同步,但不能同时在两个组织中使用同步。

  1. 以具有系统管理员角色的用户身份登录到非主要 Microsoft Dynamics 365 组织。
  2. 导航到“设置”,然后选择“Email配置”。
  3. 选择 “邮箱”。
  4. 将所选视图从“我的活动邮箱”更改为 “活动邮箱”。
  5. 打开要为 Server-Side 同步禁用的邮箱。
  6. 将同步方法选项更改为 “无 ”,然后选择“ 保存 & 关闭”。