Microsoft Dynamics 365 中Email服务器配置文件的测试连接失败

本文提供了 Microsoft Dynamics 365 中Email服务器配置文件测试连接失败的问题的解决方案。

适用于:Microsoft Dynamics 365 Customer Engagement Online
原始 KB 编号: 4493267

症状

在 Dynamics 365 中使用 Email 服务器配置文件中的“测试连接”选项时,测试失败,你可能会看到类似于以下示例的错误:

“远程服务器错误: (401) 未授权。 请确保输入的用户名和密码正确,然后重试。”

“System.Net.WebException:操作已在 System.Net.HttpWebRequest.GetResponse ()
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeConnectivityDiscoverer.ValidateServerUrl (EmailDirectionCode emailDirection) ”

原因

  • 原因 1: 用户名或密码不正确。

  • 原因 2:如果使用Dynamics 365 (联机) 连接到本地 Exchange,则如果防火墙不允许从Dynamics 365连接到 Exchange 服务器,则可能会出现此错误。

  • 原因 3: 在某些情况下,即使凭据正确且连接不成问题,测试连接也可能失败。 请参阅“解决方法”部分中的“解决方法 3”。

解决方案

  • 解决方法 1: 验证用户名和密码是否正确。

    注意

    “用户名”值需要采用 UPN (用户主体名称) 格式。 例如, username@contoso.com 而不是 contoso\username

  • 解决方法 2:如果将Dynamics 365 (联机) 与本地 Exchange 配合使用,请验证防火墙是否允许从Microsoft Dynamics CRM Online IP 地址范围(包括引用的 Azure IP 范围)中所述的 IP 范围列表中建立连接。

  • 解决方法 3: 测试连接结果并不总是可靠的。 如果在从 Microsoft 远程连接分析器执行测试连接时使用相同的用户名和密码,请使用 Dynamics 365 中的“测试 & 启用邮箱”选项,而不是“测试连接”选项。 如果邮箱的“测试 & 启用”成功,则可以忽略“ 测试连接 ”对话框中的结果。

    注意

    如果使用“测试 & 启用邮箱”按钮发生任何失败,请参阅邮箱记录中的“ 警报 ”选项卡,并查看包含的任何帮助链接。