2003.5 版本后,UCI 仪表板不会加载

本文提供了在 2003.5 版本发布后 UCI 仪表板无法加载的问题的解决方案。

适用于:Microsoft Dynamics 365 Customer Engagement Online
原始 KB 编号: 4558635

症状

更新到 2003.5 版本后,具有已配置为使用自定义控件 (的子网格的仪表板例如,可编辑网格) 不会在 UCI 中加载。

仪表板可能卡在加载微调器上,或者可能显示一般错误消息:

(“出了问题。有关更多详细信息,请查看技术详细信息“) 。

原因

如果仪表板上有一个已配置为使用自定义控件的子网格,但并非所有外形规格,则会导致此问题。 如果存在自定义控件配置,但并非所有外形规格都具有自定义控件配置,则最终会成为阻止加载仪表板的未经处理的 null 异常。

例如,控件配置可能如下所示:

屏幕截图显示了控件配置的示例。

或者,它可能是由未用于任何外形规格的控件配置引起的,如下所示:

未使用的子网格自定义控件配置的屏幕截图。

解决方案

该 bug 已在 2004.3 版本中修复。 但是,客户可以通过为所有外形规格添加控制配置来更快地解决此问题。

在某些情况下,使用的自定义控件可能不允许为所有外形规格设置 (例如,无法为手机外形规格) 设置可编辑网格,或者客户可能希望对某些外形规格使用默认只读网格。 在这些情况下,此解决方法仍然适用,因为可能还会选择只读网格作为自定义控件配置。

例如,上面的 “原因 ”部分中的第一个控制配置可以更改为如下所示,以缓解问题:

屏幕截图显示了所有外形规格的子网格自定义控件配置。

或者,如果由于未在任何外形规格上使用的控制配置而发生此问题,则可以删除该控件配置。