邮箱无法同步传入电子邮件,因为电子邮件连接通道设置为使用Email路由器同步

本文针对尝试在 Dynamics 365 中测试和启用邮箱时发生的错误提供了解决方案。

适用范围:Microsoft Dynamics CRM
原始 KB 编号: 4053588

症状

尝试在 Dynamics 365 中测试和启用邮箱时,会记录以下警报之一:

  • “邮箱<邮箱名称>无法同步传入电子邮件,因为电子邮件连接通道设置为使用Email路由器同步。 请与管理员联系,将默认连接通道更改为 Server-Side 同步。
    Email服务器错误代码:IncomingEmailConnectionChannelError”

  • “邮箱<邮箱名称>无法同步传出电子邮件,因为电子邮件连接通道设置为使用Email路由器同步。 请与管理员联系,将默认连接通道更改为 Server-Side 同步。
    Email服务器错误代码:OutgoingEmailConnectionChannelError”

  • “邮箱<邮箱名称>无法同步约会、联系人和任务,因为电子邮件连接通道设置为使用Email路由器同步。 请与管理员联系,将默认连接通道更改为 Server-Side 同步。
    Email服务器错误代码:ExchangeSyncACTEmailConnectionChannelError”

原因

如果将“系统设置”中的“进程Email使用”选项配置为使用 Microsoft Dynamics 365 Email 路由器而不是服务器端同步,则会记录这些警报。

解决方案

若要使用 Server-Side 同步而不是Email路由器,请确保“系统设置”中的“进程Email使用”选项配置为使用服务器端同步

  1. 以具有系统管理员角色的用户身份访问Dynamics 365实例。
  2. 导航到 “设置” ,然后选择“ 管理”。
  3. 选择“Email”选项卡。
  4. 找到“进程Email使用”选项,并确保将其设置为“服务器端同步”。
  5. 选择“确定”。
  6. 导航到“设置”,然后选择“Email配置”。
  7. 选择 “邮箱”。
  8. 将所选视图从 “我的活动邮箱” 更改为 “活动邮箱”。
  9. 选择要启用 Server-Side 同步的邮箱,然后选择“ 测试 & 启用邮箱 ”按钮。 请确保选中出现的对话框中的复选框,然后选择“ 确定”。
  10. 等待测试 & 启用过程完成。 如果测试结果不成功,请查看邮箱记录中的“警报”区域。

更多信息

只能使用Email路由器或 Server-Side 同步 (建议) 在Dynamics 365中发送和接收电子邮件。 这两个选项不能在同一Dynamics 365实例中使用。 “处理Email使用”选项确定启用这些选项中的哪一个。 “ 测试 & 启用邮箱 ”按钮可用于 Server-Side 同步功能。 如果使用Email路由器,则无需测试 & 启用邮箱。