使用 Microsoft Entra 帐户排查桌面流凭据无效错误
本文提供了解决运行 UI 流时 InvalidConnectionCredentials 或 WindowsIdentityIncorrect 错误的解决方案。
适用于: Power Automate
原始 KB 编号: 4555623
症状
使用 Microsoft Entra 帐户运行的流失败,并显示 InvalidConnectionCredentials 或 WindowsIdentityIncorrect 错误代码。
原因
使用 Microsoft Entra 帐户时,可能会出现此错误的原因有很多:
- 在连接中输入的帐户凭据可能与计算机上的凭据不匹配。
- 设备可能未Microsoft Entra加入 (或Microsoft Entra混合联接) 以支持Microsoft Entra身份验证。
- Microsoft Entra帐户可能未同步到计算机。
解决方案
首先,确保设备Microsoft Entra已加入或已加入域:
- 打开命令提示符。
- 运行命令
dsregcmd /status
。 - 检查“设备状态”部分。
确保其中一个 DomainJoined
或 AzureAdJoined
值为 YES。
如果情况并非如此,除非已加入设备,否则无法使用Microsoft Entra帐户,请参阅有关如何加入设备的 Microsoft 文档。
其次,确定在计算机配置中使用的Microsoft Entra帐户:
- 打开 “设置” ,然后选择“ 帐户”。
- 选择 “访问工作单位或学校”。
- 请确保看到类似于“已连接到<your_organization> Microsoft Entra ID”的文本。 它表示已连接的帐户可以在连接中使用。
第三,同步设备上的Microsoft Entra帐户。 为此:
- 在“访问工作或学校”屏幕中选择Microsoft Entra连接时,请选择“信息”按钮。
- 这将打开一个描述连接信息和设备同步状态的屏幕。 此时将有一个按钮 “同步 ”,选择此按钮,然后等待此过程完成。
第四,检查配置的Microsoft Entra帐户可以登录到设备:
- 尝试使用上一步中标识的 Microsoft Entra 帐户登录到计算机。
- 设备登录必须成功才能在连接中使用。
最后,请确保使用正确的用户名和密码正确配置了流。 这与计算机上的帐户非常匹配。
反馈
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