症状

当使用 Dynamics 365 应用程序进行 Outlook 时,您将看到以下消息:

"无法连接到 Exchange"。

应用的其余部分可能会成功加载,但可能缺少跟踪项和使用"设置关于"的能力。

原因

这通常发生在使用 Microsoft Exchange本地邮箱时,并且可能由以下原因之一引起:

原因 1:在 Exchange 中未启用 OAuth 身份验证

原因 2:Exchange 使用的身份验证证书出现问题。

解决方案

解决方法 1:验证在 Exchange 中启用了 OAuth 身份验证

  1. 在 Exchange 服务器上,打开Exchange 管理命令行程序。

  2. 运行以下命令: 获取 Web 服务虚拟目录 |FL 服务器,[auth]

  3. 验证返回的结果显示,OAuthAation设置为True。

  4. 如果 OAuthAthenation 设置为 False,则需要运行如下命令: 设置 Web 服务虚拟目录 - 标识"EWS(默认网站)" - OAuth身份验证 $true

    其他信息

    标识值是虚拟目录的名称,可以通过单击服务器,然后单击虚拟目录或运行以下命令并查看返回的名称值在Exchange 管理中心中找到该虚拟目录:获取 WebServices 虚拟目录 |FL 有关此命令的详细信息,请参阅 Exchange 文档: 集 Web

  5. 服务

  6. 虚拟

  7. 目录https://docs.microsoft.com/powershell/module/exchange/client-access-servers/Set-WebServicesVirtualDirectory?view=exchange-ps 有关允许 Outlook 外接程序发出异步 Exchange Web 服务 (EWS) 请求的身份验证要求的详细信息,请参阅以下文章: 使EwsRequestAsynchttps://docs.microsoft.com/outlook/add-ins/web-services#authentication-and-permission-considerations-for-makeewsrequestasync的身份验证和权限注意事项

  8. 运行以下命令: 获取组织组合 |FL OAuth2 客户端配置文件已启用 如果返回的值为 False,则运行以下命令: 设置组织Config -OAuth2客户端配置文件启用:$True

  9. 还要验证您的 Exchange 版本具有以下文章中提及的更新: 无法通过 Exchange 服务器 2016 和 Exchange 服务器 2013 https://support.microsoft.com/help/4056329 从 Outlook/OWA 外接程序访问 EWS

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