升级到 Microsoft Dynamics CRM 2011年后,发生错误:"登录的用户没有适当的安全权限来查看这些记录或执行特定的操作"

症状

升级到 Microsoft Dynamics CRM 2011年后,用户可能会遇到错误下面时试图在 Microsoft Dynamics CRM 中执行某项操作︰

登录的用户没有适当的安全权限来查看这些记录或执行特定的操作。




如果启用 Microsoft Dynamics CRM 平台跟踪,则平台跟踪包括以下出错信息︰ > MSCRM 错误报告︰


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错误︰ 服务器无法处理请求。
错误编号︰ 0x80040220
失败的错误消息︰ SecLib::CrmCheckPrivilege。返回的是 hr = 用户 Id 上的-2147220960: e65023ae-54d1-da11-8e39-00145e3d5192 和 PrivilegeId: a8ecac53-09e8-4a13-b598-8d8c87bc3d33


注意:在此示例中的信息、 用户 Id 值和 PrivilegeId 值是实际值的占位符。

原因

升级到 Microsoft Dynamics CRM 2011年时,自定义安全角色不自动授予的特权应用于所有新功能。只有优秀的角色将被授予默认权限。

如果未授予用户的角色所执行的操作所需的权限,也可能发生此问题。如果满足以下条件之一为真,则可能会出现这种情况下︰

  • 从头开始创建角色。

  • 从标准角色复制角色。然后,该角色被广泛地编辑。

解决方案

若要解决此问题,请执行以下步骤:

注意:下列步骤要求您从 Microsoft Dynamics CRM 平台跟踪的信息。

  1. 在 Microsoft Dynamics CRM 平台跟踪中出现出错信息,找到 PrivilegeId 值。

  2. 通过运行使用 PrivilegeId 值的 SQL 查询来确定缺少的特权。例如,运行一个 SQL 查询,如下所示对单位名称_MSCRM 数据库︰

    select Name, * from PrivilegeBase where PrivilegeId = 'a8ecac53-09e8-4a13-b598-8d8c87bc3d33'
  3. 缺少权限授予用户,请执行以下步骤︰

    1. 启动 Microsoft Dynamics CRM 2011年。

    2. 单击设置,单击管理设置,然后单击安全角色

    3. 双击分配给用户的角色。

    4. 授予用户的角色缺少特权。例如,要授予给用户的角色 prvReadLead 特权,核心记录选项卡,然后导致行上,单击相应的读权限。

    5. 单击保存并关闭

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