单击 Internet 资源管理器中的链接时,没有任何反应

症状

当您单击网页上或电子邮件中的超链接时,不会发生任何操作。互联网资源管理器未打开该网页。 Information icon注意此信息适用于 Internet 资源管理器 9、Internet 资源管理器 8 和 Internet 资源管理器 7。

原因

发生这种情况的原因有以下一个或多个:

  • 选择要使用的 Web 浏览器的设置已损坏。这可能会导致 Windows 误解将哪个浏览器设置为计算机上的默认浏览器。

  • 安装软件后,设置已更改,这可能会导致指向网页的链接无法正常工作。

  • 以前安装的浏览器或外接程序可能会干扰计算机上的其他软件。

  • 注册表项已更改或损坏。

解决方案

本节面向初级到中级计算机用户。如果这些方法不能解决问题,则可以尝试"高级故障排除"部分中的方法。 要解决此问题,请使用以下方法的显示顺序。 方法 1:检查默认 Web 浏览器设置

在 Microsoft Windows 中,您可以选择要使用的 Web 浏览器。要使 Internet 资源管理器成为默认 Web 浏览器,请按照以下步骤操作:

  1. 要打开 Internet 资源管理器,请单击"开始",然后单击"互联网资源管理器"。

  2. 如果系统提示您确认您希望 Internet 资源管理器是默认浏览器,请单击"是"。

  3. 在"工具"菜单上,然后单击"互联网选项"。

  4. 单击"程序"选项卡,然后单击"默认"。

  5. 单击"确定",然后关闭 Internet 资源管理器。 Information icon注意您的更改将在下次启动 Internet 资源管理器时生效。

检查问题是否已解决。如果问题已解决,则已完成本文。如果问题未解决,请尝试下一个方法。

方法 2:更改 Internet 资源管理器默认打开的文件类型

适用于 Windows 7 和 Windows Vista

  1. 关闭所有 Internet Explorer 窗口。

  2. 单击“开始”,然后单击“控制面板”。

  3. 单击"程序",然后单击"设置默认程序"。

  4. 在"程序"菜单上,单击"互联网资源管理器",然后单击"选择此程序的默认值"。

  5. 请确保.htm的复选框。选择 html和.url,然后单击"保存"。

  6. 单击"确定"。Information icon注意您的更改将在下次启动 Internet 资源管理器时生效。

适用于 Windows XP

  1. 要打开 Windows 资源管理器,请右键单击"开始",然后单击"我的计算机"。

  2. 在"工具"菜单上,单击"文件夹选项",然后单击"文件类型"选项卡。

  3. 找到并选择HTM文件类型。

  4. 确保将 Internet 资源管理器选择为"打开程序"。 如果未选择"互联网资源管理器",请单击"更改",选择"Internet 资源管理器"作为建议的程序,然后单击"确定"。

  5. 对以下文件类型重复步骤 3 和 4: Html 其 Mht MTHML Xml Xsl

检查问题是否已解决。如果问题已解决,则已完成本文。如果问题未解决,请转到下一个方法。

方法 3:使用 Internet 资源管理器无加载项模式

尽管浏览器加载项可以改善您的在线体验,但它们偶尔会干扰或与计算机上的其他软件发生冲突。但是,请注意,如果禁用了外接程序,某些网页或 Internet Explorer 本身可能无法正确显示。首先,使用暂时禁用的加载项启动 Internet Explorer 以查看问题是否已解决。(加载项将仅在您以常规方式重新启动 Internet 资源管理器之前被禁用)。为此,请按照以下步骤操作:

  • 单击"开始",在"搜索"框中键入Internet 资源管理器,然后单击"互联网资源管理器"(无加载项)。Information icon注意对于 Windows XP,单击"开始",右键单击 Internet 资源管理器图标,然后单击"不带加载项的浏览"。

如果 Internet Explorer 无加载项模式解决了问题,请按照以下步骤确定导致问题的浏览器外接程序:

  1. 要启动 Internet 资源管理器,请单击"开始",然后单击"互联网资源管理器"。

  2. 单击"工具"按钮,然后单击"管理加载项"。

  3. 单击"名称"列表中的外接程序,然后单击"禁用"。测试互联网资源管理器。

  4. 重复步骤 3,直到确定导致问题的附加程序。

检查问题是否已解决。如果问题已解决,则已完成本文。如果问题未解决,请尝试下一个方法。

方法 4:重置 Internet 资源管理器设置

如果问题是由损坏或不兼容的 Internet 资源管理器设置或加载项引起的,通常可以通过将 Internet 资源管理器设置重置为默认设置来解决此问题。 重置 Internet 资源管理器设置时,所有以前的设置都将丢失,无法恢复。还原 Internet Explorer 默认设置时,某些依赖于存储的 Cookie、表单数据、密码或以前安装的浏览器加载项的网页可能无法正常工作。但是,将 Internet 资源管理器重置为默认设置不会删除收藏夹、源和其他几个个人设置。 要重置 Internet 资源管理器设置,请按照以下步骤操作:

  1. 关闭所有 Internet Explorer 窗口。

  2. 单击"开始",在"搜索"框中键入inetcpl.cpl,然后单击"程序"列表上的inetcpl.cpl。 将显示"互联网选项"对话框。 Information icon注意Windows XP,单击"开始",单击"运行",在"打开"框中键入inetcpl.cpl,然后单击"确定"。

  3. 单击"高级"选项卡。

  4. 在"重置 Internet 资源管理器设置"下,单击"重置"。然后,再次单击"重置"。

  5. 当 Internet 资源管理器完成重置时,单击"重置 Internet 资源管理器设置"对话框中的"关闭"。

  6. 再次启动互联网资源管理器。 您的更改将在下次打开 Internet 资源管理器时生效。

方法 5:重新注册必要的 Internet 资源管理器 DLL 文件

Information icon注意此信息适用于 Windows XP 要重新注册 DLL 文件,请按照以下步骤操作:

  1. 单击"开始",单击"所有程序",单击"附件",右键单击cmd,然后选择"以管理员身份运行"。如果系统提示您输入管理员密码或确认,请键入密码或提供确认。

  2. 在"打开"框中键入regsvr32 urlmon.dll,然后单击"确定"。

  3. 收到确认时,请单击"确定"。

  4. 对以下命令重复步骤 2 和 3: regsvr32 mshtml.dll regsvr32 什多克夫.dll regsvr32 浏览.dll regsvr32 msjava.dll

检查问题是否已解决。如果问题已解决,则已完成本文。如果问题未修复,则转到下一节。

高级故障排除

本部分适用于更高级的计算机用户。 方法 1:创建新用户帐户

有关用户配置文件的详细信息,请参阅。 有关方法的详细信息,请转到以下 Microsoft 网站:

Windows 7:

视窗Vista:

Windows XP:

方法 2:使用系统还原

系统还原使用"还原点"将系统文件和设置返回到较早的时间点,而不会影响您的个人文件。恢复点每周自动创建,并且就在重大系统事件(如程序、设备或驱动程序的安装)之前创建。 在开始系统还原之前,请保存所有打开的文件并关闭所有程序。确认还原点后,系统还原将重新启动计算机。要执行系统还原,请按照以下步骤操作: 适用于 Windows 7 和 Windows Vista

  1. 单击"开始",单击"所有程序",单击"附件",单击"系统工具",然后单击"系统还原"。如果系统提示您输入管理员密码或确认,请键入密码或提供确认。

  2. 单击"系统还原"页上的"下一步"。

  3. 选择所需的系统还原日期或说明。 Information icon注意如果看不到要查找的特定日期,请选择"显示更多日期",然后选择所需的日期。

  4. 在确认窗口中,单击"完成"。

您的计算机将重新启动。该过程完成后,您将收到一条确认消息。 适用于 Windows XP

  1. 使用具有管理权限的帐户登录到 Windows。

  2. 单击"开始",单击"所有程序",单击"附件",单击"系统工具",然后单击"系统还原"。

  3. 在"欢迎恢复系统"页上,选择"将计算机还原到较早的时间"选项,然后单击"下一步"。

  4. 在"选择还原点"页上,单击"打开此列表"上的最新系统还原点,单击还原点列表,然后单击"下一步"。

  5. 在"确认还原点选择"页上,单击"下一步"。系统还原还原还原以前的 Windows XP 配置,然后重新启动计算机。

  6. 以管理员身份登录到计算机。然后,在"系统恢复还原完成"页上单击"确定"。

您的计算机将重新启动。该过程完成后,您将收到一条确认消息。 如果使用"系统还原",但仍出现问题,或者出现其他问题,则可以撤消还原操作。撤消操作后,可以尝试使用其他还原点。要撤消系统还原操作,请按照以下步骤操作:

  1. 单击"开始",单击"所有程序",单击"附件",单击"系统工具",然后单击"系统还原"。

  2. 单击"撤消系统还原",然后单击"下一步"。

  3. 查看您的选择,然后单击"完成"。

您的计算机将重新启动。该过程完成后,您将收到确认。

其他资源

检查问题是否已解决。如果问题已解决,则已完成本文。如果问题未解决,您还可以使用 Microsoft 客户支持服务查找其他解决方案。Microsoft 支持服务包括:

  • 查找微软产品的技术支持信息和自助工具。

  • :查看特定于产品、常见问题和支持亮点。

  • 微软社区:联系同行、同行和微软最有价值的专业人士(MVP)。

  • 提出问题、联系 Microsoft 客户支持服务或提供反馈。

如果您继续遇到 Internet 资源管理器问题,或者想要提出问题,请与 Microsoft 支持部门联系,或提供反馈,请访问网站。

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

谢谢您的反馈意见!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×