症状

Microsoft Dynamics CRM客户端Microsoft Office Outlook固定视图时可能执行缓慢。

原因

固定视图后,视图中的记录将下拉到本地 SQL {orgid.sdf} 中的 CE 数据库并缓存。 固定视图后,它们以"列表视图"而不是"分页视图"呈现给用户。 每次访问固定视图时,它返回本地 .sdf 文件的结果。

此数据作为后台进程定期更新。 如果用户具有多个固定视图,或者计算机没有大量资源,则可能会导致性能和加载问题变慢。

解决方案

为了防止固定视图将信息拉取到本地 SQL CE 缓存,可以在 Microsoft Dynamics CRM 2011 Outlook 客户端上设置注册表项。 这还有助于减少从 Microsoft Dynamics CRM 2011 服务器发送到 Microsoft Dynamics CRM 2011 Outlook 客户端计算机的总体网络流量。

当此值设置为 1 时,用户仍能够固定视图;但是,查询将发送到 CRM 服务器以检索结果,而不是从本地缓存检索结果。

重要说明 本部分、方法或任务包含可告知如何修改注册表的步骤。 但是,注册表修改不当可能会出现严重问题。 因此,请一定严格按照下列步骤操作。 为了获得进一步的保护,请在修改注册表之前对其进行备份。 这样就可以在出现问题时还原注册表。 若要详细了解如何备份和还原注册表,请单击以下文章编号以查看 Microsoft 知识库中的文章
:322756如何在 Windows 中备份和还原注册表。若要让我们修复此问题,请转到"为我修复它


" 部分。 如果你希望自己修复此问题,请转到"让我自己修复"部分

帮我修复此问题



若要自动修复此问题,请单击" 修复它"按钮 或链接。 然后单击 "文件 下载 "对话框中的 "运行",然后按照修复向导 中的步骤 操作。




备注

  • 此向导可能只提供英文版本。 但是,自动修复功能同样适用于其他语言版本的 Windows。

  • 如果你不在遇到问题的计算机上,将"修复它"解决方案保存到闪存驱动器或 CD,然后在有问题的计算机上运行它。


然后,转到"此问题是否修复?"部分。



我自己修复此问题

若要解决此问题,请执行以下步骤
:1. 以安装了 Microsoft Dynamics CRM 2011 Outlook 客户端的用户用户Microsoft Dynamics CRM 2011 Outlook 客户端计算机。
2. 单击"开始",单击"运行",键入 regedit,然后单击"确定"。 导航到注册表项,HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient。 在“编辑”菜单上,指向“新建”,然后单击“DWORD (32 位)值”。
3. 键入 DisableMapiCaching,然后按 Enter。
4. 右键单击 DisableMapiCaching,指向"新建",然后单击"DWORD 值"。
5. 右键单击 DisableMapiCaching,然后单击"修改"。
6. 在"值"数据框中,键入 1,然后单击"确定"。
7. 退出注册表编辑器。


此方法是否已修复问题?

  • 检查问题是否已修复。 如果问题已修复,您不用再往下看了。 如果问题没有修复,你可以联系技术支持部门

  • 我们将感谢你提供反馈。 若要提供反馈或报告此解决方案的任何问题,请在"为我修复它"博客上留下评论 或向我们发送电子邮件

更多信息

必须安装更新汇总 6 或更高版本,DisableMapiCaching 注册表项才能正常工作。 有关更新汇总 6 的信息,请参阅 KB 2600640。


注意:此注册表项无效更新汇总 14 后创建。 这必须使用 OrgDbOrgSettings 工具进行更新。

适用于 2011 年 Microsoft Dynamics CRM 的 OrgDBOrgSettings 工具

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

你对翻译质量的满意程度如何?
哪些因素影响了你的体验?

谢谢您的反馈意见!

×